Posts created by laineyloo

 
 
 posted in Curse at Twilight: Thief of Souls Collector's Edition on Jan 8, 12 12:59 AM
Please help, I can't find the last lever piece for the owl plate on the first door. clicked all over but cam't find it anywhere.
 
 
 posted in Mystery Murders: Jack the Ripper on Sep 3, 11 2:41 AM
angela1116 wrote:i filled my water pitcher then it disappeared


Same here, soo frustrating
 
 
 posted in Midnight Mysteries: Salem Witch Trials on Jun 13, 10 5:25 AM
make that four
 
 
 posted in Youda Legend: The Golden Bird of Paradise on Jan 1, 10 10:10 AM
I'malsostuck here, tried everything I can think of
 
 
 posted in Diamon Jones: Amulet of the World on May 18, 09 10:44 AM
I don't any an image of people at all, I just get the background screen and dialogue, completely unplayable.... very disappointed
 
 
 posted in Syberia II on May 15, 09 11:32 AM
Found it very moving when Kate said goodbye to Oscar! Soppy or what lol
 
 
 posted in Pocahontas: Princess of the Powhatan on May 3, 09 9:02 AM
Thank you for tip weeharleyboy. I have tried but will try again. Will not be buying this game that's for sure!!
 
 
 posted in Pocahontas: Princess of the Powhatan on May 3, 09 5:33 AM
I can't find the hand on the ship. Clicked all over. The hint seems to indcate left of stairs by the banjo thing, but still no luck, Please help
 
 
 posted in Pocahontas: Princess of the Powhatan on May 3, 09 5:31 AM
Me too! very disappointed. I got to the ship but can't find the hand, again hint points to general area, but i have clicked and clicked all over but STILL can't fin it> Any clues anyone?
 
 
 posted in Nostradamus: The Last Prophecy on Mar 22, 09 1:26 AM
Thank you, thank you thank you.....
 
 
 posted in Nostradamus: The Last Prophecy on Mar 21, 09 5:32 AM
I'm stuck with the same problem...please help us :
 
 
 posted in Nostradamus: The Last Prophecy on Mar 21, 09 5:06 AM
Please help, I am in the library and need to modify rope i think to attatch it to the pole, How do I modify the rope, I get the icons but when I enlarge it in the screen it say it can't be modofied in that screen.......please help
 
 
 posted in Nostradamus: The Last Prophecy on Mar 21, 09 3:10 AM
thank you
 
 
 posted in Nostradamus: The Last Prophecy on Mar 20, 09 1:24 PM
I have got all the ingredients for the colouring and gone to the workshop, I have managed to get the ingredients in the cooking pot but I can't get the pestle and mortar to work with the clay, all i get is the cog symbol with a red line through, any ideas anyone. I did manage to get water from the well after much fussing!!!!!
 
 
 posted in Mae Q`West and the Sign of the Stars on Mar 2, 09 11:52 AM
Does anyone know if game fixed yet. Very frustrating
It's already evening where i am lol....
 
 
 posted in The Broken Clues on Feb 3, 09 11:37 AM
I agree, didn't hold me at all! I love HO games but this is diabolical! Ghostly images too faint, spot the difference much to subtle not to mention the awful music!!!!!
Very disappointed
 
 
 posted in Amazing Finds on Dec 21, 08 4:59 AM
I've got all bits in snow globe and guy still ops up.
Is there a glitch or am I missing something, been all through book and I seem to have everything...
Help please
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator