Posts created by joyce422

 
 
 posted in Unsolved Mystery Club ®: Ancient Astronauts ® on Mar 17, 16 6:44 AM
I recently purchased this game, and am at the second chapter. I'm trying to break the wall next to the green-eyed idol with the bludgeon, and it keeps telling me that I can't use that item there, even though both the walk through and help section within the game say that's what I'm supposed to do. I thought maybe other things had to be done first, so I went back to the statue and tried to put the chest piece on, and received the same message.

I'm also having an issue with Unsolved Mysteries Amelia Earhart in getting it to start. I've uninstalled both the Big Fish Ap and the game itself, downloaded it again, and it still doesn't work. I think whoever created these games still has a lot of work to do to remove all of the glitches. In any case, I'll be asking for a refund for both of these if I can't get them to work correctly when I try to play them. It's very frustrating!!
 
 
 posted in Emerald City Confidential on Aug 25, 13 2:28 PM
Can anyone tell me how to undo an action in this game? I accidentally gave one of the knowledge pills to Toto instead of having Petra take it, and it's gone. I've tried summoning Toto with the whistle but he's nowhere to be found. I need the pill so that I can get Capt Bill to admit guilt. Until then, I'm stuck. It seems like in this game, if you mess up, you have to repeat the entire chapter or maybe even the game?? Can someone clue me in??
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator