Posts created by anon457

 
 
 posted in Shadowplay: The Forsaken Island Collector's Edition on Feb 1, 18 8:19 AM
How long is this game?
 
 
 posted in Crossroad Mysteries: The Broken Deal on Oct 22, 17 1:48 PM
How the heck did you figure that out from the clue? The clue kinda shows 1 bottle on the 2nd vial 1 bottle on the 4th vial and 2 bottles on the 5th and the metal holder I thought was signifying the fill line. never would have thought to put in 9 doses. Kudos!
 
 
 posted in Crossroad Mysteries: The Broken Deal on Oct 22, 17 11:00 AM
I have a Mac and I can zoom in on each scene by holding down the apple key and scrolling on the mouse. Then i can scroll around and look at different sections of the scene. at a larger magnification (handy for the hard to find things). There are at least 2 to 4 'crosses' in each scene plus the candy bars
 
 
I have finished the game and the bonus game, in the extras section when i go to the collectables, all available choices are covered with "clouds" am i missing something?
 
 
 posted in Maze: Nightmare Realm Collector's Edition on Aug 13, 17 5:38 AM
Has anyone finished the game? If so, about how long ?
 
 
I think they are in the "secret room".
 
 
Did anybody finish the game collecting 64 of the 63 flowers?
 
 
I am playing the mac version of this game. In chapt. 7 is anyone having trouble getting the cursor to sync with some of the bubbles. I put the "right color" in the "right bubble" but some of them are not putting the color where the cursor points.Another thing I noticed, after filling all the yellow bubbles ( they seemed to be cursor accurate) while I was filling in the other colors, the yellow bubbles started to disappear !? This game is so messed up that after 25 times trying to figure out where to place the cursor to fill in the bubble (because if you get one wrong you have to fill in a lot of them over again) I skippped it. Does somebody quality check these games for quality ????
 
 
 posted in Harrowed Halls: Lakeview Lane Collector's Edition on Nov 4, 16 6:10 AM
I have the board filled in and some of the dominos are wrong. The game will not let me return the wrong ones back to the left side.It also has no reset so the only way to proceed is to skip. Any thoughts?
 
 
 posted in Harrowed Halls: Lakeview Lane Collector's Edition on Nov 1, 16 5:35 PM
I did click the reset button but only after the arrows started moving all but 13 balls randomly between the 2 circles. Something changed in the movement of the balls using the arrows. clicking the arrows did not rotate each ball in its corresponding circle. I tried deleting and reinstalling but it still moved 21 balls across the 2 circles randomly.??????? Thanks for the reply!
 
 
 posted in Harrowed Halls: Lakeview Lane Collector's Edition on Nov 1, 16 3:11 PM
I too did not understand the directions at first! Clicking the arrows moved the balls either forward or backwards one ball at a time around the 2 corresponding circles. After trying to solve the puzzle for a while,I quit the game. Later when I came back to play again the arrows acted in a different manor, This time, each arrow I pushed moved all but 13 of the 33 balls across the two circles randomly. Anybody else experience this difference in ball/arrow movement? IMac 27" w/OS8.5
 
 
 posted in Lost Lands: The Golden Curse Collector's Edition on Nov 29, 15 7:07 PM
In the Room of Riddles there is a "math" problem 2 ? 2 ? 2 = ?. I entered this
2 + 2 x 2 = 8 and got nothing. Is that not a correct possibility? I then tried this
2 ÷ 2 + 2 = 3 and the door opened. Is the first choice not mathematically correct?
 
 
 posted in Grim Facade: Hidden Sins Collector's Edition on Jul 8, 15 9:39 PM
I also had inventory items disappear (at least 3 or 4) AND the map no longer appears or functions
 
 
 posted in New York Mysteries: High Voltage Collector's Edition on Jun 8, 15 8:41 AM
I am having a problem with the cursor at the very beginning (before you press the "PLAY" button). If The cursor is in the top left side of the screen at startup it becomes trapped in an invisible 4" by 5" box and the cursor will be stopped in that invisible area from moving down to press "PLAY". The only way to do anything is to control/quit and restart the game trying to get the cursor somewhere other than the top left side. Am using a 2009 iMac running !0.8.5 . Everything is up to date.
 
 
 posted in Phantasmat: The Endless Night Collector's Edition on Jan 21, 15 11:16 PM
The phone is wrapped in paper and tied with rope and is supposed to unwrap when you click on it! I watched it online in a video. It does not work for me . I am using an IMac running 10.8.5.. Also the hint button does not work when i click on it. When I click on hint it gives me a message "I suppose I"d better move along" . On the video when you click on hint it shows you where it is and what to use if it is a 2 step process
 
 
 posted in Phantasmat: The Endless Night Collector's Edition on Jan 21, 15 11:02 PM
Bitsie1 wrote:I have passed the cursor all over the scene with the phone. I can tell from the shape that the phone is wrapped in white paper but it does not show anything with cursor over it. Cannot find anything to get rid of the paper.
 
 
Can anyone explain how to solve this puzzle other than looking in the SG for the answer. It just gives a picture of the solved puzzle with no explanation, The INFO on the puzzle is not very explanatory
 
 
 posted in Echoes of the Past: Wolf Healer Collector's Edition on Oct 18, 14 9:49 AM
I'm running Mac OS 10.8.5 on a 2010 27" iMac. I very rarely have problems, but after I downloaded this game there was no buttons for "PLAY" "EXIT" or any other buttons to interact with. Only the ability to "change player". What happened to the" Quality Tested" guarantee? I am going to try to download it again.
P.S. My screen resolution is set at 2560x1440
!!!!!CHANGE RESOLUTION TO A DIFFERENT SETTING!!!!! 1680X1050 WORKED FOR ME. THANKS, RJohn
 
 
 posted in Mysteries and Nightmares: Morgiana on Jul 28, 14 3:16 PM
I also finished the game thanks to goran_LGC's hint. But I have one question! Did anyone finish and still have a pair of scissors still in their inventory like I did?
 
 
 posted in Mysteries and Nightmares: Morgiana on Jul 28, 14 2:32 PM
goran_LGC, Thanks for the hint i was getting very frustrated. Just prior to this game I was playing Natural Threat 2 which also I had to suspend playing because of many many BUGS. Thankfully this game was just user caused.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator