Posts created by smg521

 
 
 posted in Moai V: New Generation Collector's Edition on Sep 4, 17 4:01 PM
I have tried and tried almost a dozen times to hire the 12 workers on Level 13. I have built huts, upgraded, opened Watergate, collected over 1,000 extra manna but, for the life of me, cannot hire anymore than 6 workers! I give up. I am ready to ditch this game. I do not know how other people have gotten past this level.
 
 
 posted in Moai V: New Generation Collector's Edition on Aug 31, 17 8:14 PM
I have played this level over and over and for the life of me, I cannot hire 12 workers. Cannot even get to six to open the Water Gate. I am thinking of just giving up and deleting this game! I have tried to follow the guide. It never stated how to hire all of these workers. Never had any problems with the previous series!
 
 
 posted in Dark Romance: Curse of Bluebeard Collector's Edition on Oct 24, 16 6:35 PM
Like everyone else, I had trouble with the bonus chapter. Well, I installed the update and every time I tried to get back to the game, it would go back to where I left off. In other words, it did not work! I would close the game many times, restart it and then when I clicked on the bonus chapter, back to where I left off! I closed big fish app, reopened it, same thing! Restarted my computer! Same thing!!! Very frustrating! Any suggestions?
 
 
 posted in PuppetShow: Her Cruel Collection Collector's Edition on Oct 4, 16 3:46 PM
When I first purchased this game, I had no difficulties at all. Purchased it around two weeks ago. When I tried to play it today, it kept freezing and I had a black screen. I uninstalled and reinstalled it; played from the beginning. Same problem. Very upsetting! I also have Windows 10 and have had no problems with all of my other games, just this one!
 
 
 posted in Chimeras: Cursed and Forgotten Collector's Edition on Aug 21, 16 7:48 AM
Wow! Such a simple thing! Thanks so very much!!!
 
 
 posted in Chimeras: Cursed and Forgotten Collector's Edition on Aug 7, 16 2:57 PM
This screen is so dark that I cannot read anything on it. It has to be the game because I have played these games for years and have never had any difficulty before.
 
 
 posted in Dreampath: The Two Kingdoms Collector's Edition on Mar 17, 16 1:38 AM
I found a walkthrough online, which explained the problem and then when I opened the game, everything was in site with the answer. Sometimes you just have to work it out yourself.
 
 
 posted in Dreampath: The Two Kingdoms Collector's Edition on Mar 17, 16 1:25 AM
There is one part where the whole screen is black, a hop game with a gold medallion with three empty spaces. When I hit the hint button, it directs me to the top of the screen but nothing happens. Even checked out the strategy guide, but it was no help. How do I find this tower?
 
 
 posted in Behind the Reflection 2: Witch's Revenge on Jan 30, 16 3:29 PM
When I played the one hour free demo, I had no problem. Now, all of a sudden, I can advance a couple of times, into the kitchen, etc. but when I get sent to another room, I get an error message stating "Error access violation at 0x0067A6Bo (tried to read from oxoE12F3031 progress terminated. And then I am advised to close the program. When I close the program and restart the game, it is always at the beginning and then I get to the same place and the same thing happens. I should have realized that this is an old game and not purchased it. Please advise or issue a refund for this game.
 
 
 posted in Dark Romance: The Swan Sonata Collector's Edition on Oct 29, 15 10:31 AM
I also have the problem of the orange tiles appearing; when you press the "hint" button, it states that there is nothing more to do at this time. I really enjoyed this game and hate that I cannot finish! Please tell us how to fix this problem.
 
 
rexan, you are a genius. I had given up and even contacted tech support. Then I thought I would try again--followed your instructions, and, it worked!!! Thank you, thank you, thank you
 
 
Rexan wrote:Here's how it works: Click on the upper leg area, above the silver button, set in place. Then click on the silver button at the knee and set in place. Do this for both legs. The arm, click on the upper arm above the silver button and set in place, then click on the elbow, the silver button and set in place. You've got it! The makers of this game should have put 2 silver buttons on the body. It was awful trying to figure this out. Good luck!
 
 
I also am having difficulty with this part of the game. I have tried all of the suggestions posted, but no luck! Very frustrating. I just signed out and will maybe try again. I really do like this game, but am not happy with things like this!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator