Posts created by jaindough

 
 
 posted in Grim Facade: A Deadly Dowry Collector's Edition on Oct 19, 17 9:59 AM
Hey "Puppy",
I can't remember exactly but seems I do remember a handle in my inventory that belonged to another item. Sorry to be so vague. Hoping you've already collected that item or that someone can tell you something more specific.
Have a good (and lucky) day! Donna in TX
 
 
Yes, Severine Snape, that's how I entered the Bonus game. Also, I thought for a short while that I was starting the Main Game again; until, they started talking about having visited that city before. Then, "Ah-Ha" moment! and I'm playing a new game
Now, if someone could just help me figure out what to do with that bony spine that I pulled down from that tree by the cliffside with the red rags on it, I'd be a happier camper. All I've accomplished, thus far, is stretching it and letting it snap back into shape. Can't think what good that would be?... to cross the divide (maybe)??
Thanking ya'll in advance for a clever suggestion Donna
 
 
 posted in Secret Bunker USSR on Oct 3, 17 9:02 PM
Nevermind, I finally figured it out and finished this delicious little game; and, I would definitely recommend it. It's not your usual game, but it clicked along pleasingly. And I truly relished it.
P.S. I meant to look into that babushka doll when I first spotted it, but let myself be distracted by chasing some other thread of the game and forgot her and where I saw her. DUH!
Anyway, I did finally finish after a long unwinding break from the game.
Thanks for listening, Donna in TX
 
 
 posted in Secret Bunker USSR on Oct 3, 17 1:55 PM
10/3/17
Secret Bunker USSR
I checked out the locked forum & saw 2 posts requesting help for the same problem that I'm currently having (Oct. 2017). Neither post was responded to; and, since they asked in 2014, posting a PM might be a little too late for them to remember if they solved it & how. Their posts:

1) Secret Bunker
[Post New]by _TX2STEP on Jun 23, 14 2:27 PM
I can't get past the floor trapdoor under the bearskin rug. It wiggles when I click on it, but won't open. And I have no tools to open it. plus, I can't go back to any other rooms. Can someone help?

2) Under the Bear Skin Rug
[Post New]by dpanrell on Feb 4, 14 9:03 AM
I am now stuck... there is a panel in the floor under the bear skin rug and when I click on it, it slightly moves up and down. In my inventory I have a grenade and a screw driver, neither one works on it. I opened the safe on the wall, there's a trap in it, but neither inventory item works on it either. Any help would be greatly appreciated!

I can't ask any better than my "co-gameplayers". Can you help me so that I might finish this very entertaining game? I'll be happy to recommend it (if i finish, otherwise I can't recommend an unfinished game and if you will link-or-tell me the Best place to post my recommendation since current forum "locked"? Thanks for your attention to my HELP request, Donna
 
 
Hey Guys,
I'm not far along enough to review yet;however, if someone could tell me where to put the phone so that I might receive the newspaper, I might get to travel around a bit and see more of the game. I did figure out that one has to leave the HOP mini-game to find the lost postcards; but, I can't take the phone out of the booth. And, although I pressed it upon every likely surface, it was never accepted as the desired location. Please advise. Eagerly awaiting your help, another Donna ; )
 
 
"Same issue - nail file & tweezers missing and cannot open the box in the basement to proceed."
I lost mine when I thought it would help me with the wrong situation. Thought it HAD worked when they "disappeared"; but, NO... they just disappeared and left the problem I had. Found another solution to that challenge.
Now, I have a problem that they COULD DO (de-booby-trapping the box in the basement) and they are nowhere to be found. Makes you hesitant to make a guess.
Anyone in charge with a solution, since I don't want to re-start the game under another name. PLEASE find the answer and let us know.
 
 
 posted in Vacation Adventures: Park Ranger 4 on Jun 17, 16 2:48 PM
In the store with the bear holding a soccer ball and the cash register facing you, I've looked everywhere....DUH, never mind, just spotted it. It's just so nice to know that ya'll are there to catch me before I fall down in a fit of frustration. Thanks, Donna
 
 
To Gremmie,
problem: "I am also having problems with the book medallion--rings are perfectly aligned,& nothing happens. Hit on the hint button ,it just circles the medallion--did the puzzle 4 times,aligns EVERYTIME. Nothing--cannot progress in game."

I, too, had this problem last night (and i tried several times). However, I went and readjusted all the rings this morning and it clicked. Don't know what I did to accomplish this..maybe it took a certain amount of tries or maybe i turned a ring or two in a different direction??? I just got lucky that time, so I was basically doing the right move. Note: trusting your design is centered at the top? Good luck!
 
 
 posted in Parallels Cross on Feb 5, 16 2:18 AM
mcmar12, did the machine pod lift open to free the boy seated inside?
 
 
 posted in Elly Cooper and the City of Antiquity on Jan 3, 16 11:05 AM
Thanian, you are such a genius! Seriously, I thought I needed my diving gear to enter the "underwater" and all I had to do was "jump" into the side of the pool to THEN use my gear....DUH on me!!! Many thanks to you Donna
 
 
 posted in Elly Cooper and the City of Antiquity on Jan 3, 16 10:55 AM
I've got two pieces to a puzzle, some shallow-diving gear, and a message that refers to "underwater" on the left side of the pool; yet, I cannot seem to enter the water. Any advise on how or where to successfully dive in? Thanks for any help Donna
 
 
 posted in Phantasmat on Nov 6, 15 10:50 PM
Mr_Russ wrote:
Campsalot wrote:I was able to get through the first combination lock for the sewer but the little box indicating whether the numbers you've clicked on are right or wrong doesn't light up on the second combination lock in the sewer. Please don't tell me to trash the game and download a new copy, I really don't want to work my way through the whole thing again. Thanks in advance.
There are 3 / 4 / 5 digits for each puzzle.


I'm having the same problem as Campsalot and don't want to start over at this point either. I tried 3/ 4/ 5 and it didn't work! I love the games where they give you feedback on your guesses ( I was "O, Boy!" when I entered the first level) but sewer level number 2 and probably any further levels in this sewer are working in the dark with too many possibilities to filter with no feedback. Please tell me how to fix this {or let me know the codes (i.e. SKIP this broken section)} so I can continue this game. Thanks, Donna in TX
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator