Posts created by neffb4neff

 posted in Lost Lands: Ice Spell Collector's Edition on Sep 29, 17 1:23 PM
After trying several times to download the fix and having no success, I decided to start the game over with a different profile also. I didn't reload the game, only started it over. The difference this time was that I slowed down and made sure I listened to all conversations before moving on. That's it!! I had no problems recovering the cold blood elixir and was thankful that there were no other glitches. Why, you ask am I thankful? After playing the game, including the bonus chapter, I'm absolutely in love with this game. I haven't had this much fun playing a game in quite some time.
I don't know if my comments will help anyone but I sure do hope that everyone gets an opportunity to finish this game. Well done!
 posted in Lost Lands: Ice Spell Collector's Edition on Sep 24, 17 11:11 AM
I tried to get the update that is suppose to be available and when manually telling system to load any updates, I'm told that there are no updates
 posted in Lost Lands: Ice Spell Collector's Edition on Sep 16, 17 10:35 AM
Same here. Hint won't work. Only able to look at the alchemists table.
 posted in Lost Lands: Ice Spell Collector's Edition on Sep 15, 17 12:48 PM
After sewing up the tapestry, I am unable to grab the recipe to the elixir. I can look at the alchemist table only. Hint won't work. Any ideas?
 posted in The Emptiness on Jan 24, 17 11:51 AM
The maze with the black witch looking woman has me stumped. No matter how many times I get her to the outside of the room with no exit, i'm unable to get her to move sideways into the room. Please help
I am unable to finish the urns. Some have disappeared and it is frozen and the skip won't work. After reviewing the forum, I realized that this all was a really big problem back in 2012 and now I'm totally confused as to why the problems still exsist . ANYBODY?
 posted in Cadenza: The Kiss of Death Collector's Edition on Apr 8, 15 11:03 AM
I'm at hospital admissions with antidote and white jacket guy is in the way. I am only able to go to admissions and the mortuary and my hint says there is nothing to do in any of these areas. I've tried using the map, hint button and shut the game down twice. The strategy guide says I should be giving Anthony the antidote, so why can't I? Need Help, Please
Can't seem to figure out the order of books. The poem isn't giving enough information. Anyone PLEASE?
 posted in Dark Dimensions: Homecoming Collector's Edition on Feb 12, 15 10:14 AM
Just started the game and already have a problem. The HO in the first room of the house wants me to cut the vines with a hot knife. I'm unable to do so. The guide says nothing and the hint button keeps pointing to the knife and then the vines. Someone help please
 posted in The Emptiness on Feb 11, 15 5:04 PM
Thanks, I found it. I'm stuck on the (x) looking character in the word that is only characters. Got any help there?
 posted in The Emptiness on Feb 11, 15 12:15 PM
I'm actually at the clue that says look for highlight and I cannot find a highlight anywhere. Someone please help
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator