Posts created by likegames1

 
 
 posted in Emberwing: Lost Legacy Collector's Edition on Mar 21, 14 8:22 PM
Thanks jcsgame. Yours is actually the response that I wrote down and tried immediately upon returning to the game. Unfortunately I still wasn't able to get a handle on it and progress further in the game. I'm still hoping that there will eventually be a solution to my troubles. Grimtooth's still busy waiting to be healed!
 
 
 posted in Emberwing: Lost Legacy Collector's Edition on Mar 21, 14 1:37 PM
I was really intrigued by the game description, so I only had to play partway through the demo and decided to buy the game. I really enjoyed it until, as so many other players have encountered, I got stuck on the elves and eagles section of the picture board minigame. Thank you so much to the contributor who took the time to write a detailed response. However, I followed the instructions and still can't get anything to happen. Nothing has changed - the hint says nothing further can be done here. I don't skip a minigame unless it's absolutely necessary, but in this case I'd pay money to be able to skip this in order to progress further so that I can heal Grimtooth and move further on in the game. There is no skip option that I can see and to add to my problems the game update that bfVanya mentioned isn't showing on my game manager. Updates for other games have come through, but this one isn't. I tried getting it manually from the options tool on the game manager, but it says no updates are available. I uninstalled the game yesterday and then reinstalled, hoping that I might be able to get past the picture board problem, but everything there was just the same. Can anyone help me with this and please, please, please tell me if there's a way that I can skip this one and keep moving forward in the game.
 
 
Thanks, Kimooey. Unfortunately I tried that a few times and it didn't work for me. I really hoped that it would but no luck. I keep trying that part of the game - clicking all over the Deck area and the ice card still won't come out to play lol! Hopefully, somehow Mary Maltese and I (and anybody else who's having the same trouble) will be able to get past that and start playing the rest of the game, too.
 
 
The problem is that I powered up the ice card and now I can't get at it to use it on the lava. Really annoying because I enjoyed the bit of the game that I played and would like to get into the rest of it.
 
 
It's really embarrassing for a veteran gamer to admit, but after JUST entering the world of fire and powering up my ice card, I can't even use it. I am not using the tutorial, but the tutorial shows up on the screen for this part, and when I click on the DECK logo nothing happens. The arrow keeps pointing and pulsing and I've been clicking all over the deck - nada. I can't do anything else within the scene - it won't let me go to menu, the strategy guide, nothing. I'm stuck clicking all over the deck area and can't get at the ice card to let me freeze the lava and move further into the game than the first 5 minutes. Help!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator