Posts created by TheSherlockian

 
 
 posted in Agency 33 on Sep 26, 14 7:55 PM
meinaz wrote:I have gotten so used to the misnomers that I am having difficulty finding the items with their correct names. I am glad that a lot of the misnomers were fixed, but it takes me longer to find them with the correct names especially with challenges.

Seconded.

I think it speaks largely to just how ingrained some of these scenes are in our memory from so much repetition. I know the "Boom" at the Fringe Hut was horribly misnamed from the beginning, but it still takes me a moment when I see "Arrow" now to understand the reference.

Same with the "Dragon" at the Circus Tent. And if you ask me, there was nothing wrong with "Dragon". The fact that it's now "Magic Ball" is a terrible "fix".
 
 
 posted in Agency 33 on Sep 26, 14 4:58 PM
SugarplumPCCLisa wrote:So, thanks Sherlockian for helping me finally place the sun symbol, but now I'm having the same problem with the griffin sign - how do you get the griffin symbol to be accepted where it goes in the mansion near library door ???

Thanks!

Is this the Griffin symbol that looks like a running cat?
If it is, this symbol is used in the Crypt in the Paris Cemetery, not in the Mansion.

If it's a different symbol, let me know what it looks like because I don't recall another one.
 
 
 posted in Agency 33 on Sep 25, 14 9:09 PM
khabnus wrote:I didn't receive any tasks for crafting, gathering anything or completing a HOS. I did scroll through the task and click each one and tried clicking on each one separately. Nothing.

The rewards listed at the bottom of the Help the Scientist/Inventor with his missions tasks are the snowflake, letter A, codfish and frog.

So do I have to quit the game or start all over? Grrrrrrrrrrrrrrr!!!!!!!!

Well, I hate to say it for certain, but this is my process of reasoning:

Your ability to progress revolves around acquiring those creation formulas (the frog, "A", snowflake, etc.) All the other tasks you mentioned rely on having these formulas completed..

But the only way to attain those creation formulas is to "help" Dr. Mensa (15 times) and Damian (8 times) with their tasks (per the "Handy Man" task).

But--for whatever reason--the game did not give you the separate tasks needed to complete the "Handy Man" task.

So it looks like this is, in fact, a game bug and not just a need for patience. If I'm missing something, I would love for another player to chime in, but I'm going to call this a glitch.
 
 
 posted in Agency 33 on Sep 25, 14 8:09 PM
khabnus wrote:The Help the Scientist/Inventor with his missions tasks have the following counters:

Scientist (0/15): A separate mission with the scientist's picture says to Find proof of the Apocolypse.

Inventor (0/8): No separate missions listed.

Okay, then I think there's a problem:

The task that has those counters that says:
- Scientist (0/15)
- Inventor (0/8)
That task should have appeared at the same time as two other tasks (one for the Scientist and one for the Inventor). These other tasks should require you to do some "menial labor", such as crafting or gathering items or completing of HOSs...or something.

(Also, don't forget to possibly scroll the task list as some of them are hidden at the bottom. I know you have probably done this, but just want to cover everything.)

It's this that needs to be completed before you can move forward.

If you'll note at the bottom of this "help" task, there should be some formulas listed as a reward. If you look at them carefully, I bet you'll see they are the snowflake, frog, letter "A", etc.
 
 
 posted in Agency 33 on Sep 25, 14 7:49 PM
gabrielmine wrote:Yes, it is. What level do you have to at to open it?

Just to note moving forward:

Hidden object scenes are unlocked by level.

Portals (or arches, like the Gallery or The Alps) are unlocked by your place in the story line and are only opened by completing relevant tasks. You'll have to complete a series of tasks and discover Martha's Diary before you can access the new portal to the Tibet Cloister.

Edited to add: Unfortunately, the energy cap has been 290 since Level 29 for everyone.
 
 
 posted in Agency 33 on Sep 25, 14 7:36 PM
khabnus wrote:I did remove the Charon in the Boat symbol and placed it to complete the mural in the Gallery. I understand that this game progresses by completing tasks, but it hasn't given me a task to complete in the past five levels. I've tried going back to the Headquarters, the Gallery, the Mansion grounds and to the scientist's office, but no luck getting any direction. I've completed all levels of the HOS's available. I want to continue playing this game but am tried of playing the same scenes over and over...and over...with no additional tasks.

Just to clarify what I meant earlier: You are only awarded new tasks by completing current tasks. So, one of the tasks you have now must be finished before the game will give you another task to complete. (Your level has no influence on your task list.)

Just curious...since you said you placed the Charon boat...
What level of the Gallery mural are you on?
Which figure do you need to place next?

Also, the task you mentioned that says "Help the Scientist/Inventor with his missions"...Is this a task that has several formulas as a reward? It also should have a counter, such as:
- Help Dr. Mensa - 0/8
- Help Damian - 0/5
Is this the kind of task you're referring to?

If so, there should be some sub-missions that appear with this task, asking you to give items or craft items or complete certain scenes...anything like that?

Also, have you tried clicking the Hint button in the inventory bar?
Where does the game point you toward?
 
 
 posted in Agency 33 on Sep 25, 14 6:03 PM
Just another bit of advice as you play...tasks are not awarded or do not arrive by level, but by completing other tasks. So in order to get more tasks, you must accomplish some of those you have already received.

With that being said, when you put the symbol on the well (Charon in the Boat), did you take it off again? I know it sounds strange, but that symbol needs to be removed from the well and then placed on the mural in the Gallery.

If you overlooked this (which is easy to do), that should get you moving again.
 
 
 posted in Agency 33 on Sep 25, 14 4:44 PM
robingranny59 wrote:In my inventory I have a gallery painting, electricity sign, a witch sign, butterfly sign, a compass sign, a star sign, orpheus sign I have tried talking to the keeper no luck, what did I miss<

Thank you all for helping me try to find the tape.

Well, at this point you might want to go around and talk to everyone again, just to see if anyone has any kind of reactions you might have missed that would trigger the Keeper to say something different.

Have you tried the Hint button on the inventory bar, yet? Where does that point you?
 
 
 posted in Agency 33 on Sep 25, 14 4:31 PM
Just because you repair a bridge, does not mean that everything will unlock in that area. Hidden object scenes unlock by level and the Portals (like the Paris Cemetery) unlock at different points in the story line.

All this tells you is that the Paris Cemetery is not a place you should be yet, so don't worry about getting there. For now, you need to focus on opening the Mansion doors. I'm going to assume that one of your tasks at this point (since you need the A symbol) is to assist Dr. Mensa with finding "Proof of the Apocalypse".

What is it about the Symbol A that it won't let you create?
Which items are you missing to craft it?
 
 
 posted in Agency 33 on Sep 25, 14 4:24 PM
dk413 wrote:Where is it? THX

Actually, this is a mistake in the verbiage of the task and the Fireplace Room should be the scene to complete.

If you're not certain, you can click the "Go To" button on the task window and it will take you to the correct scene.
 
 
 posted in Agency 33 on Sep 25, 14 8:16 AM
robingranny59 wrote:where do i find the tape?


Unfortunately, I do not remember how you acquire the Electrical Tape. I want to say it might be awarded either in a mailbox slot or I might have found it in the Dead End area by Dr. Mensa's home in the Town Square.

What items do you currently have in your inventory?
 
 
 posted in Agency 33 on Sep 25, 14 8:10 AM
mothergoose5 wrote:In Agency 33 it would be great if we would know where certain things go. Example to know where the griffin goes etc.

The game often awards you items much earlier than you are able to use them.

The griffin is one such piece. It's used in the Crypt in the Paris Cemetery.
 
 
 posted in Agency 33 on Sep 24, 14 6:49 PM
robingranny59 wrote:Been trying for past week to turn light on in secret room am on level 42 and have 6 signs ready to put some where. help, what good in creating all these items when there is no place to put them?

does anyone know where i can find out

thank you for any help you can give me

I believe turning the light on in the secret room involves using the Electricity "Warning" creation sign, but you also need the Electrical Tape to secure the exposed wires on the lamp. Do you have the tape in inventory?
 
 
 posted in Agency 33 on Sep 24, 14 6:43 PM
DivaDoodle wrote:Hi are there any other games made by the same developer? I really like Agency 33.

Agency 33 is quite unique and you won't find another game like it, but EleFun does does develop other series of Adventure/HOS games available on Big Fish:
- Fear for Sale series
- Mayan Prophecies series
- Witches' Legacy series (this one I greatly enjoyed)
 
 
 posted in Agency 33 on Sep 23, 14 9:21 PM
sexxygamma wrote:Yes it is Captains Cabin,

If I remember correctly, that bridge requires the following items to repair:
- Myfril Nail (From the Trickster)
- Mahogany (From the Faun)
- Fern Flower (From the Treant)

The challenge comes from collecting all the relics required to banish each monster from the map.

The Trickster should be straightforward. You banished him in the tutorial and you have access to the Bestiary Relic in the Gallery, so that will get you the Myfril Nail.

The Faun and the Treant need other relics to banish that I don't believe you have access to yet in the game. One is in The Alps' Town Square, which you may or may not have access to yet and another is in Dr. Mensa's home (also in The Alps).

At this point, I believe you have other things to do before worrying about this bridge. Eventually, you will gain access to the anomalies required to repair it, but for now, I would keep at the other tasks in the game. This particular task is a long-term goal and is probably not meant to be completed at this point in the story.

If you're stuck with other tasks on your lists, let us know which are available, as well as the items in your inventory and we can help you move forward.
 
 
 posted in Agency 33 on Sep 23, 14 6:34 PM
mohan73 wrote:how to create crowning disc relic Please explain

As the link napeon referred you to referenced, the Crowning Disc anomaly is located on the Steep Mountainside in the The Alps. You must gain access to this area before the game will allow you to create the relic. Getting there, however, can be a challenge.

You first must cross the canyon via the cable car. If you're having trouble in this area or gaining access to the cable car, let us know so we can be of further assistance.
 
 
 posted in Agency 33 on Sep 23, 14 6:29 PM
Calicohorse wrote:Hi, I'll post this to the technical thread too, but I've gotten a "fatal error" message twice now in trying to re-download the game post Sept 22 update. I seem to be the only one (?) re no others have commented.

Unfortunately, this is one of those instances where putting in a direct ticket with customer support is the best advice anyone in the forum can give. If you've updated your game before without issue, I'm not certain why this particular update would be giving you problems, but it's best to let support know so they can make a note of (or possibly even help you fix) the error.
 
 
 posted in Agency 33 on Sep 23, 14 6:18 PM
mcook247 wrote:There are other items in other areas that can't be selected. Like the Frog in the Fringe Hut...

They released an update yesterday, September 22, that should correct all of these "unselectable" items. If you're still having problems with the hidden object scenes, check for another update in your Big Fish Game Manager and download the latest version: 4.1.1.

To check for updates manually:
- Open the Big Fish Game Manager
- Select Options (at the top)
- Select Downloads tab
- Under Game Updates click "Manually"
- Then "Check for Updates"

 
 
 posted in Agency 33 on Sep 23, 14 6:13 PM
sexxygamma wrote:I am needing a pearl to fix bridge???

Which bridge are you attempting to repair?

Level 11 is pretty early in the game. Are you attempting to reach Venetian Street? The Captian's Cabin?

All bridges are repaired using the items received from banishing the floating enemies around the map and I do not believe you ever need a pearl to fix a bridge. The closest thing that looks like a pearl is a Water Sphere, but you will not need that until much later in the game.
 
 
 posted in Agency 33 on Sep 23, 14 6:01 PM
This, unfortunately, is a glitch. Placing the wine on the grating should cause the water level, and the golden spear, to rise to the top. The grate does not lift, but you can select the spear through the bars.

If you didn't get a reaction and it still will not let you collect the spear, you'll have to put in a ticket with support and let them know you cannot progress.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator