Posts created by shanyem

 
 
 posted in Rainbow Mosaics: Treasure Trip 2 on Feb 5, 18 9:34 PM
MACOS High Sierra 10.13.2 Desktop.

When the game loads, it shows on the screen in a window (not 'full screen'). It doesn't show everything it should in the title screen - everything is skewed to the right. I am able to attempt to change to 'full screen' but the size of the perimeter doesn't change (still a smaller window within the screen) AND everything inside the window is LARGER (as if it really was now full screen mode). Weirdly it also makes my tool bar go into 'hide' mode - every time! This all said, I can't play the game. One last 'it figures' thing....it started happening AFTER I purchased the game. Yup. Please advise!!

Just deleted/uploaded game. Still same problem. Deleted game manager, deleted game, uploaded both. Now the game seems as if loading but entire screen black. Cannot see cursor unless put at top of screen where a bar appears with red and green dot. Had to force quit.

 
 
 posted in Surface: Strings of Fate Collector's Edition on Oct 9, 17 5:00 PM
Just got the staff. When I went to the shipwreck to get the key, the staff is gone. Help!
 
 
 posted in World's Greatest Places Mosaics on Mar 16, 16 10:57 AM
BIG problem with this game in that it was developed for PCs and NOT MACs. It is available for MACs today and unfortunately the left/right click thing is not working. The MAC mouse does not have two buttons so that a right click will be a right click. It might (and often does) act as a left click. With this issue the game is pretty much unplayable as there are WAY too many mistakes notes - and mistakes that really are NOT mistakes. There have been other games with the same issue but seems no one cares. BTW - I would buy ALL these games as I love them....I have to pass on this as the frustration level is just too much for me.
 
 
 posted in Royal Trouble: Honeymoon Havoc on Mar 12, 16 2:02 PM
I'm at the carnival and I found the stick. I immediately combined it with the hammer. I THEN went to the game where I need to strike the red spot with the hammer - can't do it until the wedge is removed. Is there ANY way to remove the wedge at this point? In the walkthrough at Orchid Games, it says to use the stick to remove the wedge THEN combine it with the hammer. Any work arounds? Cuz this would SUCK to have to redo the entire game when I'm almost done. Thanks!
 
 
 posted in Christmas Griddlers: Journey to Santa on Dec 17, 15 9:00 AM
RiniW - THIS is the problem with this game! It was originally for PC users and they didn't change the game controls to that we MAC users can use it easily. Makes the gameplay difficult. I LOVE these games but won't buy unless the controls are MAC friendly.
 
 
 posted in Christmas Griddlers: Journey to Santa on Dec 17, 15 8:58 AM
I've been posting about the problems with MAC users having to right/left click. It makes the gameplay very difficult. I've posted a review saying I LIKE the game but gameplay is very poor and it was REJECTED. Funny....it fits all the requirements for a review as sent to me but it was STILL rejected. I think that a MAC game should be used as a MAC has to be used! I would have bought the game immediately as this is my favorite kind of game. Sorry but no thanks.
 
 
 posted in Magic Griddlers 2 on Aug 18, 15 4:50 PM
The first Magic Griddlers (for MAC) was GREAT! I love these games. Unfortunately the controls have changed. Since MAC's cannot use a reliable left/right click it is almost IMPOSSIBLE to NOT make a mistake - you cannot be sure if the mouse is actually clicking left or right. This makes the game VERY frustrating and MAC users shouldn't have to purchase a new mouse because the developers don't know the issue. I didn't buy the game because of this and usually I buy such games without even trying them! If the developers could change this ONE thing - I'd buy!
 
 
 posted in Fishdom 3 on Dec 24, 14 8:39 PM
How do you earn the last background and items? I've got 20 fishtanks, got most of the achievements, etc but don't know if I have to get to a certain level(?) to get that extra background. The achievements say there are 8 - I have 7. Also, it says that I haven't purchased all of the pirate items - I have unless there are extras! Don't know where/when I get these either! Any ideas?
Thanks!
 
 
Really had high hopes as I've had two purchased games not work this week - both CE's. I have 21 minutes left and was planning on purchasing it…when the screen froze. I'm going to persevere - I will uninstall/reinstall the game but I'm not that hopeful due to the problems going on. One last thing…if a game just won't work, you will be given coupon codes to 'make it right'. So here's the problem…you can't use coupon codes for CE's so you're OUT the money you spend!!! I have MANY coupons that expire because I purchase CE and nothing else is really any good. I play two other types of games that don't come with CE's but these come out VERY rarely. I - and I know others, have suggested that BFG make some kind of deal …so many coupons for a CE. Sounds fair to me especially if you are a person like me who has two codes expiring in two days, three which expired last month, etc. Thanks for letting me rant a bit!
 
 
 posted in Spirit of Revenge: Cursed Castle Collector's Edition on Aug 13, 14 11:25 PM
Before I purchase this game (I only have 7min left on the free hour) I want to see if the problems I and others have encountered actually were fixed! I have the 'pillow' that won't go away in the girl's room. I also hear there are other problems with the bonus game. Please comment so we all know what is going on. I'm a long time player (as many of us are!) and lately there have been several games that have these kinds of problems. I'm not going to be offered a game coupon that expires - yes, that is what they offered me for another game that just can't be fixed. It's just that just this year I've had almost 10 (yes, 10) coupons expire on me because we can't use any for CE's. I've suggested a few times that they change this - even if it's like 5 coupons or more!!! At least we'd have to option! Sorry for the rant…just a little frustrated.
 
 
I've tried updating both manually and automatically through the desktop app and NOTHING is available. I'm not sure if anyone else is being offered a coupon code with a two week expiration date as a way of appeasement. It's a joke really - I've had a TON of coupons expire as we can't use them for CEs and other games are pretty poor quality. I've been a member here for years (like so many of you) but I've been really disappointed with BFG over the last few months. The CE games are the only ones of quality - look at the quality of non-CE Alexander the Great: Secrets of Power and you'll see what I mean. BTW - I purchased that game with a coupon as I figured why not? The last two games I've bought that are CE cant' be played due to software problems…with NO FIXES in site! Sorry for the rant fellow members/players but it's getting ridiculous.
 
 
 posted in Spirit of Revenge: Cursed Castle Collector's Edition on Aug 11, 14 5:53 PM
I have the same problem with the picture of the cushion not going away. I've uninstalled/reinstalled - nothing. I have 7 minutes left on the free hour and will NOT be purchasing this game as I'm sick of purchasing something then can't play it. Just happened with another game and I just sent an email to Bigfish. Hopefully something will be done with this game because I really wanted to purchase it!
 
 
I (and others) am unable to use the aspects of the game we paid for due to a glitch in the extra game play. In the last HOP, there is one item left - a gong, which is NOT on the screen. Pressing the hint button just creates a message that there is 'nothing more to do here'. Using the bubble shooter just results in a never ending bubble shooter episode! I've uninstalled/reinstalled to no avail. I also have followed the instructions on manually checking for game updates - there are none available. I would appreciate a response to this discussion as there have been NO replies in reference to this anywhere else- whether information that there is a fix, that we are out of luck OR that we will be reimbursed for our purchase as this game has a problem and no plans are in the works for a fix in development.
 
 
I also am unable to finish the final HOP as the gong can NOT be found. I even used the hint button - it says there is nothing to do! As this is the last thing in the game - I completed everything else possible but just need the item from this area, it is VERY frustrating as it is impossible to complete the game and use the extras purchased.
 
 
 posted in Dead Reckoning: Silvermoon Isle Collector's Edition on Jul 15, 14 1:07 PM
I played the game for quite a while - saved, played more, etc. Just tried to play again and as the file is loading to start the game, it says the saved game file is unusable and that I have to start a new game. I have a Mac - 9 months old and have NO problems at all with it. This happened AFTER I purchased the game. It seems that MANY problems occur at this time but RARELY if ever before purchase.
 
 
 posted in Tales of Terror: House on the Hill Collector's Edition on May 18, 14 2:19 PM
Ok, so this is embarrassing. I thought 'bear' meant the teddy bear next to the chest. It's actually the POLAR bear in the picture on the wall. So! I've had NO problems with the Mac version. Have fun!
 
 
 posted in Tales of Terror: House on the Hill Collector's Edition on May 18, 14 12:48 PM
I use Mac as well. I only have had one problem and that is in the extra content. I am unable to click on a bear in a hidden object area therefore I am unable to continue. I am in the process of uninstalling/reinstalling the game and hope for the best!
 
 
Glad to see I'm not the only one! I've played on 'hardcore' this time and can't skip.
 
 
 posted in The Great Gatsby: Secret Treasure on Jan 2, 14 10:08 AM
I was quite surprised that I enjoyed this game! I am NOT a 'Gatsby' fan (hated the book in high school, hated the Redford movie and refused to see the newer version as I also cannot stand DeCaprio). I tried the game just because I wanted to be fair. I will NOT review the story - bores the reader (we already READ the story line when considering purchasing/trying the game so don't waste my time!!!). While yes, the voice overs are lame - I don't care, I ignore them anyway. I music was fine - not noticeable actually as I can't remember any tune! I'm into the actual game play and this game is an adventure with some HO thrown in. So as I said - it was my type of game and I bought it. I liked the map feature and the interface. The screens were clear, HO not too jumbled/hard to see (I have a pretty large screen and sit close anyway). I also enjoyed that fact that you had to actually THINK once in a while (not too hard) to decide where to go next. This was a big plus for me. The MAIN problem with the game is the glitches in the system that I have and KEEP having. Several of us have found that we are UNABLE to continue playing the game as we cannot find ONE item (unable to click on it) and therefore cannot proceed. We are waiting (2 days at this writing) to hear from BF as the usual fixes of uninstall/reinstall, etc doesn't work for this. Do I recommend this game? Well, yes and no. If it WORKED I'd say a big YES. Unfortunately since there is NO fix in sight at this point (as of 1/2/14 1pm), I'd say do NOT waste your money until you know there is a fix OR you can take a chance and hope you don't have the problem I and others do. Good Luck!!
 
 
 posted in The Great Gatsby: Secret Treasure on Dec 31, 13 4:33 AM
I am having this problem as well. I've uninstalled/reinstalled the game twice with no help. One additional problem I am having is that my cursor disappears! I hope there is a fix to this problem...I really hate it when a game has a glitch that makes it impossible to play AFTER we buy it!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator