Posts created by LUCKYMOL

 posted in Mystery Tales: Eye of the Fire Collector's Edition on Oct 11, 16 7:03 PM
I also am stuck at the 'dragging game' and my skip button won't work. It's the first time I have tried to use it. I can only play this game so many times before I am pulling my hair out!! I bought this game after the Sept. 30th update, uninstalled it and BF game manager and reinstalled BF game manager and the game. I have taken off special effects and started a new profile and when I got to this game, the hint button still won't work.

Talk about frustrating! I am sorry I bought this game. I hope it gets fixed.

I can't, for the life of me, find the acorn in the archive. I looked at the S.G. and where it says the acorn is, there is nothing there. I have randomly clicked and can't locate it.

Would somebody tell me where it is precisely? Please. It frustrates me when I can't find all the collectibles or morphing items, etc. in a game.


 posted in Kingdom of Aurelia: Mystery of the Poisoned Dagger on Sep 8, 16 2:28 AM
I did it. I changed my cursor to the arrow instead of the grabby hand and was able to rotary dial. I got past the guard and am on my way.

Thanks so much for the rotary tip. That's about the only thing I didn't try.

 posted in Kingdom of Aurelia: Mystery of the Poisoned Dagger on Sep 8, 16 12:37 AM
How did you do it? I think it is with the telephone. I can't make the phone work to save my life. I just bought the game a little before I got really stuck here.

Please tell me what you did.

Thanks, Luckymol
 posted in Kingdom of Aurelia: Mystery of the Poisoned Dagger on Sep 8, 16 12:20 AM
I can't get the telephone to call the guard to distract him. I even changed the cursor to an arrow in case the other cursor was hitting the wrong number. Nothing happens. The hint button just keeps going to the center of the phone dial. I have pushed that, I pushed the green and the red lights and nothing is happening. What am I missing or doing wrong.

Please help as this is frustrating and I just bought the game.

 posted in Dark Realm: Lord of the Winds Collector's Edition on Sep 4, 16 1:23 AM
I can't seem to do it right. I am following the instructions to a tee (I thought), but I never can get the orange light to fill the center and then I guess the gate lifts and you move on. Anyway, I need some help from someone that has completed this part correctly to tell me what I am doing wrong and how to do it correctly.


The same thing just happened to me. I hit the reset button and all the chips said they were inactive. I hit reset several times with no difference. I finally skipped this game, which I don't like to do. To bad the game had this glitch!
 posted in Witches' Legacy: The Dark Throne Collector's Edition on Sep 10, 15 10:24 PM
No, I had a hard time figuring it out. I clicked kind of on the right (your right) of the high lighted piece that I thought was the dragon medallion a few times & something flew to the beakers where you make an acid to eat through the chain over the safe (on the right). The dragon medallion is then 'earned'

Good luck and hopefully, you too figured it out.
 posted in Witches' Legacy: The Dark Throne Collector's Edition on Sep 10, 15 10:20 PM
Thanks for your help. I finally got it.
 posted in Mystery Tales: Alaskan Wild Collector's Edition on Sep 9, 15 6:38 PM
I played the demo of this game just fine. Then I purchased it and now, when I hit play from BF apps it doesn't load and takes me to the screen that says 'Thanks for playing Mystery Tales etc. Play again. You own this game. I uninstalled it and reinstalled it, got the latest JAVA update and it does the same thing. How can I get this game to play, now that I have purchased it? I am playing on a PC with Windows 10. The Demo worked before on windows 10.


Luckymol (Not feeling so lucky right about now!!)

 posted in Witches' Legacy: The Dark Throne Collector's Edition on Sep 9, 15 2:39 AM
I went back into the game and found out the HOP is in chapter 5 Castle Courtyard. It is before getting into Wolfgang's office, because that is the objective at this point.

 posted in Witches' Legacy: The Dark Throne Collector's Edition on Sep 9, 15 2:32 AM
Hi 9otters,
I just found your response to my question about the Dragon Medallion in a HOP. There are no "chapters" but it is on page 25 of the strategy guide. You have to get it to get the wind rose to keep going.
Any help from you or anyone else would help a lot. I can't proceed without the medallion.
I did check the tech issues and there was no mention of this being a problem.

Thanks, Luckymol
Thank you all so much for your help. When I am done, I will go to souvenir room.

Have anyone of you played Witch's Legacy: The Dark Throne? I have posted there and have had several 'views' but no one is answering my question. If any of you have played it, please go to that forum and look for Dragon's Medallion.

Thanks a million.
I can't seem to find the souvenirs that are shown in the S.G. I have looked very carefully. This isn't the first game with souvenirs that I couldn't collect. it is frustrating.

Any help would be appreciated.

When and how do I collect the souvenirs. I see them in the S.G, under Collectibles & Souvenirs, but I never see one in the scene the S.G. says they are.

This is not the first game with souvenirs that I can't figure out how to collect them.

Any help or suggestions would be most appreciated.

 posted in Witches' Legacy: The Dark Throne Collector's Edition on Aug 27, 15 1:22 AM
I too cannot pick up the Dragon Medallion in the HOPS scene. The S.G. just keeps circling the medallion. I have clicked all over the scene to find something to attach it to or whatever. Not having any luck. Can't proceed without this item!!
Please, someone, help me out.
Thanks a million

Why won't anyone this question? I see someone asked about this before and has had 45 views and no replies. Come on you guys, help a fellow gamer.
I finally figured it out.
I am to the point where I was pushed or fallen out of Falconry window, where you have to find all the chain links. I did. Now the hint button shows the pry bar and the chain together. I cannot get the pry bar to stay or do anything on/with the chain. Where do I put pry bar? The S.G just says find all the chain and take the spyglass, which I don't see. I assume it will show up when I get the chain part figured out.

Thanks for any help from anyone!!
 posted in Maestro: Dark Talent Collector's Edition on Sep 12, 14 4:19 PM
Thanks DragonLadyOz. I found it and just finished the demo.
 posted in Maestro: Dark Talent Collector's Edition on Sep 12, 14 4:17 PM
Thanks so much MDB 76. I found it and just finished the Demo
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator