Posts created by baymerlou

 posted in Maze: Nightmare Realm Collector's Edition on Aug 16, 17 11:49 PM
I finished the game went on to do the bonus and did the HOPS but the last three are still locked, why?
 posted in Maggie's Movies: Camera, Action! Collector's Edition on May 6, 17 4:39 AM
I don't see the issue I'm having, no sound at all and only have question marks for every customer can't see the product they want. Windows7 64bit
 posted in Maggie's Movies: Camera, Action! on May 6, 17 4:34 AM
I have no sound and only have question marks for every customer. Impossible to play the game.
In extras, achievements, when I click on one of the puzzles to get the clovers I missed the game closes, I've completed the game but want to complete getting all the clovers and other stuff I missed in the game.
 posted in Spirit of Revenge: A Test of Fire Collector's Edition on Jan 21, 17 6:38 PM
I can't finish the game the crystals HOP won't let me find all the matching crystals, I'm on the lavender crystals and there is no match
 posted in Weather Lord: Royal Holidays Collector's Edition on Nov 13, 16 11:40 AM
marilyne1 wrote:Level 22 need 100 coins to open house but the coin building is locked and there is only 2 gold vases worth 60 points how am I supposed to open house?

if you open the decorative light you can get more coins by using food and purple gems
 posted in Chase for Adventure: The Lost City on Oct 30, 16 5:41 PM
Any tips on how to get 3 stars for this level? I've found a walkthrough on you tube but even they didn't get the 3 stars.
 posted in Sea of Lies: Leviathan Reef Collector's Edition on Jun 6, 16 5:00 PM
I posted on the other forum (not CE) june 5th. Game is too short, started and finished in one day and even had a nap inbetween. Great game though. However, I'm stuck on the bonus game can't finish a puzzle and can't see the strategy picture since it won't enlarge to see the solution.
 posted in Sea of Lies: Leviathan Reef on Jun 5, 16 3:50 PM
I started today and finished today, fun game but way too short.

I'm on the bonus game and can't finish the last stage since I can't see the pattern on the strategy screen to help me out.
can't pick up hammer to form spoon, I used the hacksaw already for the pointed stick to get the 1/2 butterfly. Is this a glitch? Can't go any further until I play the butterfly game.
I have tried the combination that is in the strategy guide with no success, there is no reset for this I have to exit the game and go back in everytime I need to reset. Anyone else have an issue or another solution?
MarkAlan wrote:Cannot exit or escape the credits.
Just scroll up with your mouse, this speeds up the credits and you get out of it fast.
Nagster wrote:I'm missing 2 items in Paige's room: Unlock All Products & Unlock & Collect Everything. I have completed all the levels with 3 stars, all the mice, and all challenges. I've triple checked all restaurants and there are no Unlocked Food Items so I'm not sure what I'm missing.
I also am stumped here, don't have a clue what I could have possibly missed.
 posted in Delicious: Emily's Home Sweet Home Collector's Edition on Jun 28, 15 4:39 PM
I don't give the ski to the boarders and a few of the counter people who only ask for one item, this way I get my score gold award.
 posted in Delicious: Emily's Home Sweet Home Collector's Edition on Jun 28, 15 4:37 PM
Yes, you are correct. Thanks for hiding the spoiler for others.

BFFirefly wrote:Using baymerlou's Plane as a clue, I have finally found the secret game. Thank You so very much for providing the clue and finding it baymerlou! I am very grateful.

To find and activate the secret game...
Spoiler [highlight to begin spoiler]

On the Map.
Go to levels 28 to 30.
Tucked in between them is a small playground Airplane.
Click on the Airplane & Emily will fly across the screen in an airplane.
Click on Emily in the Plane, you must click on her as she flies across. If you miss her, click on the playground Plane again.
Once you nab Emily in the Plane, the secret game launches and begins.

End Spoiler & Highlight
I have yet to learn the mechanics but wanted to let others know where the secret game can be found.

 posted in Delicious: Emily's Home Sweet Home Collector's Edition on Jun 28, 15 6:21 AM
I found the secret game and am having a hard time flying the plane, any tricks to this?
 posted in Delicious: Emily's Home Sweet Home Collector's Edition on Jun 28, 15 6:19 AM
The games I like and miss are the high quality cooking games, running a restaurant with the food items being realistic. Anyone know of recent ones?
 posted in The Musketeers: Victoria's Quest on Mar 25, 15 6:37 AM
I have had the game lock up on me when I have received an achievement had to ctrl-alt-del to get out and of course lost what I had on that level. Also, it's very laggy on level 11, the prior levels they (the character) would hesitate at the tent and then run fast until they reached the goal then lag again. I've updated to the most recent upgrade but this level 11 is irritating. Feels like I'm playing on my old 8088 PC from the 80's.
 posted in The Musketeers: Victoria's Quest on Mar 24, 15 10:54 AM
mbmb6868 wrote:I headed for the bakery first. When I got to the first fork in the road, I added another worker. Then I used the two workers to clear the path to the bakery. Next I made my way to the sawmill and built that, then to the market. When I got to the market I couldn't build it yet so headed to the elevator. Was able to build the market right about as I got to the elevator, so built that and then the elevator. Then made my way to the carpenter. Then I made the chairs and gathered resources until I could upgrade the manor. I played it by ear with the bonuses, using whichever was needed as they came up. Got 3 stars with plenty of time to spare.
This was perfect for me, did it with plenty of time left. Thank you so much. Lost count of how many times I tried this level.
 posted in The Emptiness on Feb 8, 15 8:56 AM
peacefrogdd1 wrote:I can't find the glass to fill with water so I can "quench" the fire and take the letter Does anyone know where to find it?

This is in Etranos not in the Exronis chapter.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator