Posts created by SherriesMomma

 
 
I almost feel like I'm wasting my time posting here, because most of the times I have, nothing has ever been resolved and I sit with several games that I'm unable to play. Anyway, because of problems previously, I now play the trial game before I consider buying. I played this game successfully for almost the entire 60 minutes and really enjoyed it. Then I purchased it. Within an hour, I tried to continue on with the game, but when I open it, I just get a white screen no matter what I've tried. How can a game work just fine and then when purchased, suddenly doesn't?? There is no reason for me to ry any of the setting changes suggested since it worked just fine for almost an hour. I am on a brand new iMac with the latest operating system. Not sure what the worth of the half price specials are when you can't play one of them.
 
 
 posted in Vacation Adventures: Park Ranger 6 on Jun 14, 17 2:07 PM
Same issue as Showgirl 2. I'm also playing on a MacBook Pro with the most current OS. Can't plan any of the scenes after a certain point. Right arrow no longer moves the scenes along. Just finished Park Ranger 5 and issues with it, too. Doesn't help to trial a game anymore. Still problems, just later on in the game. And when I wait quite awhile to try a game after it's first come out, there are still issues...long after all should have been fixed. I'm beginning to wonder if the developers and perhaps BF just don't care if "most" of your members don't have a problem or don't report it. It's very frustrating. I've been a member for at least 6 years and don't remember this number of games having problems most of the time. It's not even rare anymore, but seems to just be something we should expect and put up with now.
 
 
 posted in Vacation Adventures: Park Ranger 5 on Jun 14, 17 8:02 AM
Same problem with missing pieces in jigsaw. I'm using a MacBook Pro current OS. After putting in lots of enjoyable time realized there were either 6 or 7 pieces missing or they were behind the puzzle with no way to retrieve them. Finally just gave up and skipped the puzzle. Very frustrating. Also very frustrating to see people having similar problems and nothing is done to fix them. This is a series and if a problem occurred in a previous game in the series, I wouldn't expect to find the same problem in a more current one. I also have Park Ranger 6. Sure hopes it's not repeated in that. Sounds like same code being used in their games to save development time.
 
 
 posted in Vacation Adventures: Cruise Director 3 on Sep 10, 16 8:38 AM
It's been a month since the first issue was first reported. The main problem seems to be the game screen being so large, we can only see the top left-hand corner of the game, so the game can't even be started. Seems to me that over a month is sufficient time for the developers of this game to have resolved the problem, if, in fact, one or 2 developers are focusing on this problem for the number of members who are having this problem. Although it's been a long time since I retired from IT, I wouldn't have kept my job if I had taken this long to have resolved a problem. And, like many others, I used a "Free Game Code" to purchase this game. It's hard enough to find good quality SE games to use the codes with that we haven't already purchased the CE version on. So, BF, please, make more of an effort to get the problems resolved in a more realistic time frame. I am currently waiting for 2 games to have fixes applied to. And unfortunately, this seems to be occurring more and more with BF, making me hesitate to purchase more games. I've been a member for several years and it's really getting old.
 
 
Same problem, Nail file has disappeared so I can't open the box. I'm on a MacBook Pro running El Capitan 10.11.6.
 
 
Same problem, so I can't open the box. I'm on a MacBook Pro running El Capitan 10.11.6.
 
 
 posted in Vacation Adventures: Cruise Director 3 on Aug 11, 16 5:03 PM
Same problem as other Mac users. I've never had any problems with the other Vacation Adventures games, so didn't run a trial. Trusted BigFishGames again. Only get top left corner of the main game screen and have to restart my system to get out of it.

Please let us know when this has been fixed. I used a Free Game coupon for this and sure don't want to have to request a refund in some manner.

Thank you.
 
 
 posted in Spirit of Revenge: Gem Fury on Jan 25, 16 12:38 PM
I'm still in Rebecca's Room on my MacBook Pro. I can't solve the magnet game. I am definitely clicking on the arrows in the same sequence the game lights are lighting, but they just keep repeating the same sequence. Has anyone else had a problem with this? Is there something obvious I'm doing wrong? I've notice with other games not working, that I have to put my cursor in a really odd spot for the game to recognize it. Strange.
 
 
I am having the same problem with the missing curser in the bailiffs office. The screen frozen and I powered down my Mac and then powered it back up. When I opened the game again, my cursor was back, but I'm unable to slide the swords back. They make a noise like they are sliding, but nada.

Could we possibly have an update on the cursor problem that will hopefully fix the sword problem, too.

I am running on a Mac under El Capitan 10.11.1
 
 
 posted in Dark Parables: The Little Mermaid and the Purple Tide on Dec 29, 14 5:48 PM
tribby wrote:My problem is in Calliope's room at the sailboat scene. I enter the puzzle and get only a dark screen. If I move my mouse on the screen, it creates multiple images of the pointer. I can not work on the puzzle and therefore I can not get the silver seahorse. Very frustrating and very disappointing.
Running OSX 10.9.5


I am having the same problem in Calliope's room; however, I am running OS X 10.10.1. I haven't seen this same problem with the CE forum entries and only this one other entry by Tribby. I can get further, but need to get the silver seahorse.

Thank you
 
 
 posted in Ominous Objects: Family Portrait Collector's Edition on Aug 4, 14 8:27 AM
I deleted the game from my computer. Even emptied the trash. Downloaded again and still doesn't work for me. Was the new code for Windows only or also Mac?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator