Posts created by condorcandi

 
 
 posted in Sir Match-a-Lot on Apr 1, 18 12:12 PM
I figured you'd have something going for Easter, so I wasn't surprised to see a holiday event today.

What I was surprised was to see a goofy vampire and a pumpkin. Halloween being in the season of the autumn equinox and all. I think someone clicked the wrong switch.

I find this rather hilarious myself.

Just thought you might want to know.
 
 
As a note, the earliest I was able to access this achievement was after you get kicked out of the manor and gain access to the lighthouse. I used the map to return to the car several times and it wasn't until after the lighthouse and Lena's ghost that the Master Thief achievement popped up.
 
 
Joe
 posted in Mystery Case Files: Return to Ravenhearst ™ on Jun 12, 16 10:35 PM
That and the general store have me wondering just how many people besides Rose and the twins did those nutcases imprison down there.
 
 
 posted in Mystery Case Files: Return to Ravenhearst ™ on Jun 12, 16 10:29 PM
The skeleton key shows up just before you need to use it. I'm afraid I don't remember where exactly.

The r button will show up in an HOS in the toy store, the one with the creepy dolls. You don't find that until just before you need to use it, too.

If you mean the doors to the cellar to the left of the school it's a randomized pattern on the stove top. You need the potholder to turn the temperature to the number scratched on the door, then note the pattern of the circles.

The phone number is randomized and on the back of a poster in the kids' closet.
 
 
 posted in Sir Match-a-Lot on Jun 12, 16 10:18 PM
Thanks muchly! I was wondering where the butterflies were too!

That's why I like the forums. :p
 
 
 posted in Wanderland on Dec 2, 15 9:20 PM
Thank you! That helped.

I also noticed something else when I went back in the game: I had the silver and green scarab, which was missing before, and I could place jewels on the third square up in the left-hand column now. So I think I was getting a massive glitch on top of everything else, and closing the game earlier and reopening it a few minutes ago sorted it.
 
 
 posted in Wanderland on Dec 2, 15 11:46 AM
Sunk cost fallacy -whether time or cash- is a big part of it.

Also, I play many games for the story. Where is this headed? What's going to happen?

It's annoying to be stuck grinding when that's what I'm interested in.
 
 
 posted in Wanderland on Dec 2, 15 11:24 AM
You get shells from beating up imps (the pointy-eared green guys). You get potions to beat up the imps from sending the ship (sometimes) or from activating collections.

Hang on to the shells unless you're gifting them; you may not have used orange this time, but you probably will within three mermaids. Don't sacrifice them on the altar.

I've got all the gems and am trying to figure out the puzzle. These things NEED instructions!

Edit: One thing I've noticed: you can't place anything on the third square up on the last column to the left. And you're missing the silver and green scarab.

Okay, this puzzle NEEDS instructions. I've tried solving it according to about five different types of similar puzzles, and zilch. Nothing. Not even a glimmer to show that I'm at least on the right track. NOTHING.

This is incredibly frustrating. A clue, please? Something?
 
 
 posted in Wanderland on Dec 2, 15 11:15 AM
Level 46 here, player name Liyana.

The majority of the puzzles need some kind of instructions. Half the time the only reason I know what to do is because of similar puzzles on other games, and it still takes two to five tries to figure out which variety it is.

The other half, I just fiddle around and guess. Time-wasters do not make good gameplay.

Most of the reason I've gotten as far as I have is that I snapped up the Ruby Dragon last spring when it came up for sale. So far, I have seen not-thing that makes me want to spend more money on the game. If I wasn't so interested in where the story was headed, I'd have given up by now.

On a similar note, could you please rethink the whole "activator" concept for collections? I've got half a dozen quests up at the moment that need collections activated, and the only thing holding me back is the activators are such a pain to get. (Just spend rubies? What about next time?)

I know that making things easier by paying up is the point of an FTP game, but if I wanted endless grinding, I'd buy WoW.
 
 
 posted in Gummy Drop! on Nov 7, 15 8:34 PM
I received the "Download error. Please try downloading again." message when trying to unlock Paris. After checking things out on my end (because bandwidth issues), I came here.

Judging from other messages on this thread and forum, it might eventually work. I just want to note that this is something they might want to look at, and to make a reference point if it doesn't work in the next 24-48 hours.
 
 
 posted in Awakening Kingdoms on Oct 1, 15 8:53 PM
I would like to state that a little while ago, I had only 18 blue gems to go to buy the Elixir that upgrades you to two-minute recharge permanently. I was considering just buying the things. Then I learned of the decision not to continue the game. I decided just to earn them.

I also decided not to buy the other games in the Awakening series, even though those are not FTP games, because I don't feel comfortable buying them from a company (the developers not Big Fish) that lacked foresight to at least end at a chapter and leave the game at a clean cutoff point, such as happened with Agency 33.

This probably means very little to the developer, and none at all to Big Fish, since I will still buy other games via them, but it is important to me.

With the prevalence of Kickstarter and other such sites, and the prevalence of game mods by fans for so many other games, I find the decision to cut off Awakening Kingdoms and cease updates very unreasonable in today's environment. There are so many options, and they have taken none.
 
 
 posted in Wanderland on Sep 26, 15 10:54 PM
I was considering whether to upgrade my ruby dragon today after getting 120 rubies. Allowing myself to get sidetracked (glares at cats), I foolishly did not watch where I was clicking to leave the screen and "upgraded" it.

I use the term loosely, since I went from getting a ruby every 12 hours to getting one every three days. Which makes no sense, since on initial purchase of the thing I got a ruby every 24 hours.

Could you please fix this? At least to put it back to every 12 hours? I don't want compensation, I just want it fixed.

Player name Liyana.

Edit: Something's fixed; I just picked up a ruby today instead of two more days from now. Thank you!
 
 
 posted in Midnight Castle on Sep 24, 15 7:47 PM
Liyana -423683. Please friend me.

@empress: My way of handling gifts is to record who sent me gifts, then send back in order from oldest to most recent. You may not get a gift back from me immediately, but you will get a gift!
 
 
 posted in Midnight Castle on Sep 24, 15 7:43 PM
Eh, I find the new crypt suitably creepy.

But I find the upper left corner to be a pain in the tuckus. It's bloody hard to see anything up there. I only found the angel because I was expecting it from the old layout.

I have a different perspective because after Mystery Case Files and Dark Manor, just about anything is easy. Plus I have a stupidly good visual memory, so the new/unlocked HOS renewed the challenge for me.

(Really, check out about level 6 and up of the Dark Manor HOS, especially the ones in the lower right of each page, and you'll be shocked at how easy MC is in comparison.)

The big thing I don't like is so. many. quests. clog at just one point. Both or all three need the Mosaic Panel, or the Gaming Table, or the Crypt, or... it's.... argghh! Once in awhile makes sense, but repeated it just seems like game padding. And I detest padding.

The new scenes are interesting, but often they have me glad the rounds aren't timed like Wanderland or Agency 33.
 
 
 posted in Wanderland on Sep 24, 15 7:33 PM
Before the update today, my ruby dragon said that if I upgraded, I would get a ruby every six hours.

Now it says I'll get it every three days. Considering I get it every twelve hours now, that makes no sense.

Please tell me this is just a cosmetic mistake and not a programming glitch. I'm thisclose to upgrading -four more rubies!
 
 
 posted in Gummy Drop! on Jul 26, 15 2:39 AM
Swapping the lightning bolt with the paper worked for me. What was a pain was getting the piece of paper and the bolt together, considering how fragile the paper is and volatile the bolts are.
 
 
 posted in Gummy Drop! on Jul 14, 15 8:32 AM
(Facepalm) I feel silly... Thank you.
 
 
 posted in Wanderland on Jul 6, 15 5:40 AM
@ILOVEUANGELBABY: The "cloud" is the Fog Curse. You can either invoke it with the right talisman, or wait for it to show up.

I found out by accident, leaving the game up when I went to bed, that leaving the game open for an extended period of time is a great way to get curses. Whether they're the ones you need is another story.

@Big Fish/Wanderland folks:

Thank you thank you thank you for making it easier to get quest items with these last couple updates!

Before, it could take me upwards of twenty rounds to get quest items from various sites and bad guys. (My son told me what programming/algorithm cycle type was used, but said he'd have to look at the coding to see the exact number of cycles, and neither of us wanted to bother.)

But now, I'm getting items between eight times and the first time. It's made a frustrating game much more enjoyable. As in, I'm actually considering spending more money on it besides what I spent for the ruby dragon.

I'm also enjoying the redone pier, huntersman's house, and sage's library locations. The pier especially is just gorgeous. I love all the textures and detail in the new look of the sites.

One question: Was the swamp background supposed to update along with the objects? Right now, the objects have the new look, but the background is the same. This makes the objects cartoonishly large against the background and way too easy to find. (Except for that bloody peacock feather.)

Thank you again!
 
 
 posted in Wanderland on Jun 23, 15 2:34 PM
Yay! The Wanderland update appeared in my BFG app! Downloading now!

Edit: And I'm in! (Grabs ruby and starts searching.)
 
 
 posted in Wanderland on Jun 23, 15 12:55 PM
Aaaand it's saying it needs an update again.

I understand about minor automatic updates -heck, Dark Manor always checks for them upon loading- but I'd like to know why the switches aren't flipped properly. Coding error? The wrong box checked?

On the plus side, I found a Gummy Drop! update available when I checked manually for them.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator