Posts created by Rhea509

 
 
 posted in Queen's Garden Sakura Season on Dec 18, 17 5:19 AM
I am up to L56 and have completed all mini game so far. Each time I am awarded 50 flowers but when I try and buy some plants there are only 15 flowers available so I cannot buy.
 
 
 posted in Silver Tale on Nov 25, 17 7:51 PM
This keep happening on previous levels that I replay. It gets to the last board and my moves have run out so it asks me to buy boot/20 extra moves. I repeated buy them with the gold, until the gold has run out, then I have no more gold and cannot continue playing.
 
 
 posted in MatchVentures on Oct 18, 17 11:44 PM
Stuck on Level 4 Battle Room. Every time I play it, it takes me to the same battle room I have to use task bar to end the game.
 
 
 posted in MatchVentures on Sep 30, 17 10:57 PM
Cannot find the web potion. How does this appear.
SOLVED. Went on to the next stage and it appeared so went back and used it.
 
 
 posted in Antique Shop: Lost Gems London on Sep 30, 17 1:45 AM
The game freezes for me too. I have had to use Task Manager twice.
It is also missing the match when I click them.
The Developer should issue an update on this, I had enough with issues with The Enthralling Realm - Curse of Darkness.

That makes two games I have recently purchased that are full of faults.
Does somebody test these games before we purchase them?
 
 
 posted in Cursed House 4 on Sep 28, 17 1:20 AM
I am stuck on BK35, cannot blast the wall or get at the magnet, even blasted all the rocks away.

Help please.
 
 
 posted in Cursed House 4 on Sep 26, 17 1:45 AM
FRHgames wrote:BonusLevel31:
guide the fire from the right torch to the left one, melt the snow, then guide fire to the middle bottom line of torches.
that's it.


Sorry I don't understand. There is a torch on the right but no torch on the left. I have dragged the fire to the snow but it will not melt

Have just worked it out. Many thanks.
 
 
 posted in Cursed House 4 on Sep 26, 17 1:23 AM
I am stuck on BL 31
The fog will not go with a match or dynamite and the coin on the right hand side.
Help would be appreciated.
 
 
 posted in The Enthralling Realms: Curse of Darkness on Sep 12, 17 1:23 AM
This game is driving me mad!!! Everything is in slow motion. I have it set to Relaxed Mode but this is a joke!

I have never played a M3 game that has been so slow, I have to wait for the icons to drop down slowly.................

Hopefully we will get an update on this game, otherwise we should get our money back.

Have just changed the user name to see if that would give me the choice of timed mode. Nothing! Still the same old slow motion.
 
 
 posted in Atlantic Quest 3 on Mar 20, 17 10:32 PM
Cannot move past L6, there are no more tiles to get but cannot get past the level.
 
 
 posted in Jewel Match Royale Collector's Edition on Dec 9, 16 11:54 PM
If I have to no lives I have to trade gold for moves.
The tiles left are 0 but I still have gold boxes to match on.
Barring the initial 7 lives when I began, I received no more therefore having to use gold which I had accrued to buy more moves
Also the room keeps freezing after a move.

Now I have noticed that I have suddenly acquired 7 lives - but this is on the bonus level.

All of this has happened since I installed the update.As I am so near to finishing the Bonus Games I will wait until then to replay the game.

Many thanks for your help, much appreciated.


 
 
 posted in Jewel Match Royale Collector's Edition on Dec 8, 16 8:21 PM
I am running Windows 10 on a year old HP PC.
The level that was most obvious was L103.
I did notice that there were no more lives for quite a while, also on Level 120 there were no more tiles left but I still had not finished the level, also had 40 moves left.
The actual game keeps freezing when I move a M3.

I updated the game about 5th December and all this has happened since the update.

I am on level 126 at present and have 13,940 of gold but no lives.

Thought about reinstalling the game but having come so far I thought I would see it to the end, then maybe try it again.

Intel Celeron J1800@2.41 GHz
4.00 GB RAM
64-bit Operating System
 
 
 posted in Jewel Match Royale Collector's Edition on Dec 7, 16 3:36 PM
I get this on every level. It tells me that I have only 9 moves for two rooms and when I buy extra moves, either with lives or gold, it finished the level.

It seems to me that there are three games in each level. Is this so?
 
 
 posted in Jewel Match Royale Collector's Edition on Dec 6, 16 9:06 PM
I keep getting a message when my moves are low (about 9) that says do I want to pay 300 gold for more moves as I only have so many moves in two rooms. When I say Yes, it then finishes the level, even though it had said there was another room.

With 9 moves left I could have finished that game and saved the gold.
 
 
 posted in Silver Tale on May 10, 16 11:24 PM
I cannot get rid of the red tiles behind the bush that opens with a hatchet. Any suggestions please?

Also how can I get more bombs?
 
 
 posted in Silver Tale on May 4, 16 8:32 PM
I have bought shields etc. and playing in relaxed mode but still running out of gold and moves, am only on level 49.
I get the message red square completed and go onto clear the board.
When I go back to the map to cash in resources for gold it takes me back to the beginning of the level.
Just about tearing my hair out at the moment!!
Help appreciated please.
 
 
 posted in Sable Maze: Forbidden Garden Collector's Edition on Oct 8, 15 9:38 PM
Getting really fed up with this game. Have restarted it four times under different user names and each time something else goes wrong.
The boxes on the table of Fergus's office have to be moved and the walkthrough says the suitcase appears on top!!! No suitcase so cannot go any further as I need the 3/5th Scepter part to proceed.
Any help would be welcome.
 
 
 posted in Mahjong Detective: The Stolen Love on Jul 10, 15 12:26 AM
Downloaded this game twice but still have found nowhere that the instructions are. Can anybody tell me please.
 
 
 posted in Jewel Match IV on Jan 30, 15 7:25 PM
I am on Level 63 but since Level 50 have not encountered any of the pictures that you have to match. All I am doing is just matching 3. Should I reinstall the game?
 
 
 posted in Jewel Match IV on Jan 29, 15 5:49 PM
The arrow keeps pointing at the blue keys over the blank spaces. I have no more keys to open these keys. Any suggestions please?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator