Posts created by Tea93

 
 
 posted in Sally's Salon: Beauty Secrets Collector's Edition on Nov 24, 17 4:55 AM
i cannot get the trial to download..... it goes to error 6 ... I have tried to re download it I have gone through and checked everything that it suggests.... I have no problem downloading anything else.... just this game.... and it's sad... I was really excited about a new Sally game....

can't get past 0%

running windows 10
 
 
 posted in Family Vacation 2: Road Trip on Aug 28, 14 5:23 AM
can anyone tell me where the step stool is?
 
 
 posted in Lost Lagoon 2: Cursed & Forgotten on Jan 5, 12 5:50 PM
i didn't have a hanky..... but i can't find the damn parakeet.... have the seeds.... but where's the bird???
 
 
 posted in Our Worst Fears: Stained Skin on Apr 18, 11 6:08 PM
thanks it worked now.....
 
 
 posted in Our Worst Fears: Stained Skin on Apr 17, 11 6:04 PM
I'm having the same problem..... the toner powder is sitting on the table.... but I can't pick it up.... therefore... i can't move foreward in the game.....
 
 
 posted in EcoRescue: Project Rainforest on Sep 6, 09 10:41 AM
Hi all!

I totally agree.... this is for grade 1 and under..... I finished in 26 minutes of the demo...... not 26 minutes left.... finished in 26 minutes.... and only used 2 hints... there's a lot of dark scenes where its hard to see anything too. Not worth 2.99 let alone 6.99...... jmho though......
 
 
 posted in Sprill and Ritchie: Adventures in Time on Aug 30, 09 8:01 AM
Hi everyone...

I'm really enjoying this game.... but i'm at the repairing the generator part, and i'm collecting the pieces....

i've used a hint to find the last piece and i need to use the screwdriver to get it... problem is... it's right inside the twinkling area, so i can't get it..... any suggestions?

thanks for your help!!

 
 
 posted in Antique Shop on Jun 7, 09 2:51 PM
you need to put the slingshot together with the suspenders first, then put the meat in the slingshot....... now i'm off to figure out the rest of this level......
 
 
 posted in Adventures of Robinson Crusoe on Jan 24, 09 7:52 AM
I had trouble with the match too....

If I recall it was in the upper right area and yes a little bubble popped up to say "Match" the the fire of course is the lit lamp.....

 
 
 posted in Adventures of Robinson Crusoe on Jan 24, 09 7:26 AM
Hi everyone!

how do you figure out the order of the captain's treasure in the captain's room?

thanks for your help!

 
 
 posted in Natalie Brooks: The Treasures of the Lost Kingdom on Jan 21, 09 4:46 PM
Hi everyone!

I'm enjoying the game so far and think i will buy it too....

how do you get the stairs to come down inside Big Ben?

thanks
Tea
 
 
 posted in Adventure Chronicles: The Search for Lost Treasure on Dec 20, 08 10:02 PM
Thanks! And Thanks for answering so quick.... do you know what area it's in? i've pretty much clicked everywhere and can't see a necklace anywhere... accept the purplish beads on the right hand side, but nothing happens when i click them... this is the only thing left for me on this level....

thanks again!
 
 
 posted in Adventure Chronicles: The Search for Lost Treasure on Dec 20, 08 9:52 PM
Does anyone know what the geocache is for the last tomb This once adorned Cleopatra's neck?

I've tried the asp, and there's no jewelery that I can see..... anyone?

thanks!

 
 
 posted in Adventure Chronicles: The Search for Lost Treasure on Dec 20, 08 7:41 AM
Hi.. I'm loving the game but I'm stuck...I'm in the Empire State Building and can't find the big iron key or the alien key.... any suggestions?

Thanks! Happy Holidays!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator