Posts created by acter

 posted in Dead Reckoning: Lethal Knowledge Collector's Edition on Dec 25, 17 4:25 AM
Mare_Ika wrote:Where is morphing object in mountain HOP?

It's confusing because in the Extras section of the game, under HOPS, the mountain appears to have a morph. However, if you go to the actual HOP, you will notice there is no pulsing "morphing here, getcher mophing he-yar" think in the bottom left near the tablet.
Edited: Never mind -- it's one of those where you have to find things to put in the slots, then actual hidden object quarry are revealed.


Um... ??? What the heck are you supposed to do?! I can find the items that are shadowed, but ... then what? I can't find any place on the page that has gears, I can't swap jars. I am really stumped.

Any help is appreciated.
Showgirl25 wrote:Is there any way of winning this game? In the reviews, it says the computer eventually lets you win, but how long does it take? I tried to win for over an hour, but no luck so had to skip it. Really annoying when you are trying to complete the main game without skipping the puzzles!

I never found one.
While I don't love the dark, creepy graphics, they are not the thing that irritated me about this game.

There were TWELVE collectibles, no morphs, no souvenir room, nothing to make this worth the price of a collector's edition (never mind the big ol' runtime error so many of us have got).

The bonus game was okay, but I really buy CEs for the interactive things. The early games in this series were kind of thin, then the last few had been beefed up, and now we are back to pretty thin.

I rarely complain about games, and I have hundreds, but this time.. I was disappointed.
tookat wrote:oh......
I should have just played the game.

Oh, thank you. I started the demo, and got frustrated at the continuity. Now I will forge ahead.
 posted in Tiny Tales: Heart of the Forest Collector's Edition on Jul 26, 17 12:35 AM
Is there a strategy guide for this game? It's not readily apparent.
 posted in Dark Realm: Lord of the Winds Collector's Edition on Jul 18, 17 3:37 AM
I have clicked OFF "objectives" in the options, but they still kept popping up.
 posted in Myths of the World: The Black Sun Collector's Edition on Apr 12, 17 7:58 AM
So, there isn't one in the book, even though it shows up as the third HOP and has the black sun in both the main game and the post-bonus game?
 posted in Myths of the World: The Black Sun Collector's Edition on Apr 12, 17 7:41 AM
Edited: Never mind - I clicked and clicked and clicked all over the screen, and finally got to the actual scene.

I'm in the terrarium, clicked on one of my missing lizards (as opposed to leaping lizards), and I now have just a coach with spinning wheels. sigh.

It's the balcony lizard.
 posted in Myths of the World: The Black Sun Collector's Edition on Apr 12, 17 12:30 AM
I always turn the music down to 0 in the Options menu.
 posted in Cadenza: Fame, Theft and Murder Collector's Edition on Mar 31, 17 12:56 PM
I agree. Exponentially. This is the kind of thing that should be fixed with a bit of code!
 posted in Midnight Calling: Jeronimo Collector's Edition on Feb 7, 17 4:02 AM
I don't understand why Big Fish locks discussions so quickly -- this game is less than a year old!

The bug in the jail needs to be fixed -- people should not have to keep restarting a game because of a bug.
I'm playing on Win10, most up-to-date-version, and up-to-date hardware.

I was not having trouble with the game until I got to the island, and got the tower door opened. From that point on, if Louis is needed the close up window freezes once he has done his part, and the whole game freezes.

I have to close the game from the task bar and start over. VERY frustrating. The suggested tips are not working. It is clear there is a bug in the game that needs to be patched.
 posted in Nevertales: Hidden Doorway Collector's Edition on Oct 20, 16 12:29 AM
have clicked near the top of the ladder on the right (where the SG point to) and nothing.

Yeah, the strategy guide is wrong. It does show the morphie being in the first scene of that particular HO, but in reality it's in the same position on your screen, but in the fourth scene. I was SO frustrated.
 posted in Mystery Tales: Eye of the Fire Collector's Edition on Oct 4, 16 2:37 AM
This is the review I posted on the game's page.

"Making a "fun" game out of a terrible time in history"

It was bad enough when the "witches" were actually bad people, but when I got to the hidden object scene in the iron maiden, I was appalled. First, torture is just not fun. Second, the fact that there were Pears of Anguish to be found... wow.
Bad. Just really really REALLY bad.
I had the same issue as this one from the 'tech issues' discussion. I did not see any response. Has anyone figured this out?

"I can see that others have managed to finish the bonus chapter, but for me after I've gotten the children out of the cage and Gwen appears nothing happens. I checked out a "play-through" on Youtube, and it seems there should be a conversation between Rita and Gwen followed by a portal opening, but none of this happens for me. Has anyone else encountered this problem? I'm pretty sure it's a glitch, but just in case it's me, I have the locket, teddy bear and ribbon in inventory, was I supposed to do something else to trigger the transition? "
 posted in Danse Macabre: Lethal Letters Collector's Edition on May 20, 16 2:14 AM
I can't find but one little mushroom in the town center. Has anyone seen a walkthrough that includes the bonus section?
 posted in Danse Macabre: Lethal Letters Collector's Edition on May 20, 16 2:12 AM
Could it have had its name changed to "Danse Macabre: Crimson Cabaret"?
... so I can get Basil down?!!?!? I have tried dropping them everywhere, the hint keeps telling me that is what I'm supposed to be doing now, I have all 3, but I can NOT get them to "stick" to the location.

I just keep being told I don't have everything I need. ARGH.
 posted in Final Cut: Fame Fatale Collector's Edition on Jun 15, 15 4:05 AM
Look on the shelf where the two hats and mask are located.

jaxxgirl wrote:I'm down to needing to break the parrot so that I can get the lollipop, but can't find what to use to do so! Tried a hint, and was told to "move along." Played the Match 3 for about 10 minutes, removed over a dozen Eipix tokens, but the blue item (lollipop) never was removed. I can see that, at the end, I will get the third bird for the tree emblem, but can't get past the parrot and the lollipop. AARRRGGGHHH!
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator