Posts created by crypsynight

 posted in Lost Grimoires 2: Shard of Mystery on Mar 14, 18 9:12 PM
I have the recipe and the ingredients. I also have the medical bag in the bottom left corner.
Yet when i click onto the Alchemy, it tells me i should focus somewhere else.
When i select Help it points to the bottom left corner.
But it just wont open for me.
 posted in Vermillion Watch: In Blood Collector's Edition on Mar 4, 18 10:34 PM
Ahhh...figured it out. Doh! LOL
 posted in Vermillion Watch: In Blood Collector's Edition on Mar 4, 18 10:28 PM
Not sure if this is a tech issue or if i am doing something wrong.
I've solved all three door puzzles, and opened the first two doors. But the third one just comes up with a [?] icon, and something about not getting mauled by wolves.
I have the sausages, so how do i throw them in the door when it wont let me open it?
The first in the series was enjoyable. The second much the same as the first, making it less appealing, By the third game it becomes a bit tedious. Nothing original. Puzzles and hidden object were very mainstream and average.
Think i will give it a miss.
 posted in Lost Grimoires 2: Shard of Mystery Collector's Edition on Feb 20, 18 5:29 AM
I am somewhat on the fence with this game.
Beautiful graphics on the plus side.
But yet another game where the voices dont match the characters. I sometimes wonder if they only have one female artist to do all the voice-overs as they all sound the same to me.
The story line itself is very ho hum. And very slow....just seemed to drag along.
You have a character about to be King repeatedly saying "what shall we do now Auntie?" like a little child.
There wasnt a lot of challenge to any of it either.
Think I'll wait til the SE and give it another shot then.
 posted in Shadowplay: The Forsaken Island Collector's Edition on Feb 2, 18 5:03 PM
The cog sliding puzzle to get into the cupboard in the bonus chapter...
to solve it you need to cross over closed cogs, not follow the path you are meant to
 posted in Noir Chronicles: City of Crime Collector's Edition on Jan 18, 18 4:44 AM
You'll receive the clue from the pocket watch. Then allocate each cat with the number shown on the clue.
 posted in Noir Chronicles: City of Crime Collector's Edition on Jan 16, 18 7:25 AM
In the casino to join the card game i need 3 chips. Dude at the table said he would give me a chip to start with. But i never received it. Screen just partially froze. Pausing got me out of it, but without the chip. And all that happens now is that he says i need 3 chips to join in.
 posted in Noir Chronicles: City of Crime Collector's Edition on Jan 16, 18 7:20 AM
Same thing here. He said to take one to start off, but i never received anything. Screen just partially froze. Paused game got me out of it, but now i dont have the third chip.
When i've played and then exited the game, my games manager has also closed.
Doesnt matter how many times i click it on or tell it to open, it refuses to.
The only way i can get it to show again is to reboot.
"Your profile data has corrupted and been reset".
So have to start all over again.
Why do these things happen near the end of the games
 posted in MatchVentures on Sep 27, 17 7:27 AM
I loved Runefall and Silver Tale. But finding this one sadly lacking.
It is somewhat repetitive, without the challenge of the extras (such as earning upgrades).
There doesnt appear to be a map to go back and replay a level.
Each level is just more of the same. Without new challenges with each level.
Overall am rather disappointed with it.
 posted in MatchVentures on Sep 27, 17 4:23 AM
That is a shame. In the previous one in the series you could.
I hope there is a way when you reach the end
 posted in Tiny Tales: Heart of the Forest Collector's Edition on Aug 11, 17 1:40 PM
This game has commenced installing and has come up with
Microsoft Visual C++

Repair - Uninstall - Close

Help! All gobbledygook to me. Which do i want it to do?
 posted in Shadowplay: Whispers of the Past Collector's Edition on Jul 29, 17 1:42 AM
Ahh...ignore that. Apparently screws undo with a wrench.
Thought i had tried that, but it worked this time.......strange screws
 posted in Shadowplay: Whispers of the Past Collector's Edition on Jul 29, 17 1:40 AM
I've gone to the shrub and used the wrench on the valve, but that only tightened it, not given me the valve?
Also SG shows that the back plate is opened, but i need a screw driver for that but dont have one......what have i missed?
 posted in Marie Antoinette's Solitaire on May 17, 17 4:17 AM
Cards are too small, and the images on them to indistinct to see properly - unless your nose is right up close to the screen. When sitting a sensible distance from the screen you cant make out the numbers to know what each one is.
The two minutes of playing before i gave up was very ordinary and run of the mill.
I give it 1 out of 5 stars (and apparently something in the above does not meet BFG review guidelines and was rejected. Must have been the rating )
 posted in Dark Dimensions: Vengeful Beauty Collector's Edition on May 9, 17 10:02 AM
The tiles puzzle on the machine in the secret lab - i've completed the puzzle (have red left, green right, blue top, yellow bottom),,,,,,but nothing is happening.
What am i missing?
 posted in Dark Dimensions: Vengeful Beauty Collector's Edition on May 9, 17 9:54 AM
You just have to stay one square away from them.
When you look like you are going to collide, move one square south (with the one near the flower i was moving up to get away and it was getting me boxed in - you need to move down).
 posted in Tales of Terror: Art of Horror Collector's Edition on Mar 30, 17 8:15 AM
I dont know about grainy - i would have said it appeared drawn by crayon instead of pencil (if that makes sense LOL), and had no trouble with the puzzles - thought they were quite basic. HOG were some what interactive and again very easy.
But I'm not feeling the game.
Just all seemed very basic to me - go into a room/scene, do two or three things then onto the next one. Seemed designed for a younger player, but then had some rather adult concepts. And too much hand holding as well.
Think I'll wait til the SE comes out (which is something i rarely do).
Oh, and if there is one thing that bugs me in some games - like this one, it is the absurdity of some of the tasks ie unscrewing something with lipstick when you have a perfectly good set of pliers on you. Just silly.
And double oh, i got sparkles even though i selected the hard level. Not much can turn me off a game quicker.

Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator