Posts created by pnk96722

 
 
 posted in Immortal Love: Black Lotus on Apr 22, 18 12:56 PM
Full screen isn't full screen. No buy.
 
 
 posted in Immortal Love: Black Lotus on Apr 22, 18 12:55 PM
After I use up my game coupons I'm leaving anyway.
 
 
 posted in Mundus: Impossible Universe on Mar 19, 18 2:20 PM
skpjazz wrote:pnk96722:

The same message popped up when I downloaded, and the same thoughts were going through my head as you! I just closed-out that message -- and the installation was completed. I also have Win 10 and the simple trick is to ignore the message and (like I said) just close it out! I decided that it's not worth wondering why it happens, when getting rid of it works! LOL Try it over again and good luck with the game!


Thanks, I tried that twice and each time I get the game intro then a black screen and I have Control/Alt/Del to sign out in order to get rid of it. I've uninstalled and re-installed the game though not the Game Manager yet.

I very kind fishie has given me two other things to try one of which is a a long technical method which I just too tired to try right now. I'm not sure if the game is really worth all this. Maybe first thing tomorrow when I'm all bright-eyed and bushy-tailed :-)
 
 
 posted in Mundus: Impossible Universe on Mar 19, 18 1:57 PM
MrPuzzler wrote:pnk96722, you have to contact Customer Support Team, see links at top messages.


I'll give it try with a Dr. Felix report
 
 
 posted in Mundus: Impossible Universe on Mar 19, 18 1:40 PM
Downloads but won't complete installation due to this error: "Please Resolve the Following: "A newer version of Microsoft Visual C++ 2010 Redistributable has been detected on the machine".

Why is that? Considering that this game just came out today, shouldn't it be new enough to have been updated to work with the newer version by the dev.?

Haven't decided if I want the hassle of climbing into my time machine to try to find the older version this game wants, especially since it doesn't say what that version might be.

Just clicked on Microsoft Visual Studio at the bottom of the error box and after searching around on that site for the 2010 version to download, I tried to download it but I'm told there is no download for me. I guess my 2017 Dell computer with Windows 10 is too new for this developer.

Tried the 2013 and 2015 versions to no avail as well. I'm very disappointed. I'm going for a swim...
 
 
 posted in The Unseen Fears: Outlive Collector's Edition on Dec 31, 17 9:32 AM
Just swimming by to remind you that the purpose of the end-of-month sales isn't to help members fill their punch cards but to encourage non-members to become members.

You need a better strategy, like double punch Mondays and the twofers they have during the month.

 
 
 posted in Cursed House 4 on Dec 19, 17 2:35 PM
Have the key just to the right of the red square but can't get the key over the red square to the lock. How do I get rid of the red square? Bombs don't work and TNT doesn't work.
 
 
 posted in Hidden Fears on Nov 8, 17 11:27 AM
Haven't tried the game yet but on the game page in the description list it says, "Get ready to be scarred!"

Judging by the tech problems and the reviews, I'd say that was not a typo.
 
 
 posted in Crossroad Mysteries: The Broken Deal on Oct 29, 17 12:48 PM
How does one put out the fire or get out of the room that's on fire? There's nothing on the screen but the room on fire. Had to use the Window key to get out of the game.

Thank you.
 
 
 posted in Grim Facade: A Deadly Dowry on Oct 28, 17 10:16 AM
Game says "No sound Card detected. Game will continue without sound". All other games have sound.

Have uninstalled and reinstalled both the game and the Game Manager to no avail.

Also installed the trial of the Collector's Edition which has the same problem.

 
 
 posted in Holiday Jigsaw Halloween 4 on Oct 25, 17 9:18 AM
I can't seem to find a way to change this to windowed mode in the Options menu. Is it possible?
 
 
 posted in MatchVentures on Oct 12, 17 6:04 PM
Why is this game using over 40% of my of my CPU?

What's up BFG? Answer please.
 
 
 posted in Lost Lands: Ice Spell Collector's Edition on Oct 4, 17 8:50 AM
Trying to buy this game today but it keeps telling me that 50% of $13.99 is $9.99. Half of $13.99 is $6.99.

What's going on?

I see, it means 50% off the Retail price! I object! Won't be buying any games today.
 
 
 posted in Rescue Quest Gold Collector's Edition on Jul 15, 17 9:26 AM
Have been noticing Match 3 games coming out as Collector's Editions. Why? Judging by all the level questions in the forum, having a Guide doesn't help. Why else pay additional for a Guide and a Bonus Chapter for a Match 3 game?

Seriously curious here.
 
 
 posted in Nevertales: Forgotten Pages Collector's Edition on Jul 14, 17 3:10 PM
Have all the ingredients in the pot to return the witch to human form. I cannot remove the ladle from the hook on the side of the fireplace. If I click on the pot I'm told it's just waiting for the potion ingredients which are ALL already in there.

Any suggestions would be greatly appreciated.

My bad! I completely forgot to put the brass bullet casings in! Tech issue with my my brain!

Thanks for all the offers of assistance, though.
 
 
 posted in Dark Realm: Guardian of Flames Collector's Edition on Jul 10, 17 11:36 AM
Can it not be skipped?
 
 
 posted in League of Light: Edge of Justice Collector's Edition on Jul 7, 17 9:23 AM
Sniet wrote:
irenaga52 wrote:I am playing on Windows 10 pc. I have not even gotten out of the room because it will not let me pick up the umbrella. Keeps telling my it is too high. I have tried clicking all around it.


I did not need the ambrella (keeping telling it's to high here too). I found the little helper, who climbed up the cupboard and gave something other (forgotten what it was, not the ambrella). After that, I was asked, if I want to play with the helper or not. Seems to me, that you need the litte Helper one time and after that you can choose to play the rest of the game with or without the littel Helper.

HTH, sorry for my english, I'm from germany.


Your English is wonderful! Much better than a lot of Americans!
 
 
 posted in Ghost Files: The Face of Guilt Collector's Edition on Jul 5, 17 4:59 PM
Nolaj wrote:I have clicked on everything in the scene and can not find anything to brake his cracked head with to get the last star. When I hit the hint button it only shows his head not what to hit it with.
thanks


Didn't know if you ever found out how to get the final star. I had the same problem, even tried the video walkthroughs to no avail. I was just about to ask for a game credit because of not being able to go beyond this point but decided to try one more time by clicking on his helmet-thingy again and lo and behold the helmet went back down on his head and the last star showed up on the box lid. Why there was absolutely no way to logically find that star or find out via the hint or walkthrough is beyond me.

I'm actually loving this game so I wrote to Boris, the developer, to mention our problem right before my last and successful attempt. I'm hoping he'll figure out a way to help if others are having the same problem since I don't know if the moderators will leave this in.
 
 
 posted in Ghost Files: The Face of Guilt Collector's Edition on Jul 5, 17 4:39 PM
Hi, Boris. Loving this game! Pt's my new favorite. But I just can't figure out how to get the last star on the figures cracked skull. Without that I can't proceed. I tried video walkthroughs online but couldn't find it. Can you help me out please?

Thank you.
 
 
Aerosage wrote:
suniris wrote:only played demo seems a bit "old school" and reminiscent of "Indiana Jones"
Not sure its a buy for me but definitely worth checking out the demo


As far as I'm aware there's no Indiana Jones 'flick' about a dystopian world, even the Indiana Jones 5 movie that's supposed to be in the works.


I think they meant Indiana Jones-type. Sheesh!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator