Posts created by GillyAlice

 
 
 posted in Fable of Dwarfs on Feb 28, 14 4:14 PM
I'm so glad you posted this. I don't know how may times I have restarted, and was ready to give up. Doesn't help that i have an abcessed tooth and am in a bit of pain.
Thanks again
 
 
 posted in Fable of Dwarfs on Feb 27, 14 3:54 PM
Okay, here is what I did. Knock down that generator thing, build market and buy 500 food, pay off mermaid. Cut down trees ,build villa. As you get the cash buy food and build 3 more villas ,one on the market site. Then hit those pods to generate extra cash . I actually got it in gold time, too.
 
 
 posted in Fable of Dwarfs on Feb 27, 14 3:43 PM
I'm having the same problem, but I just knocked down the resource generator , and got more gold.Try that and see if that's the trick.
 
 
 posted in Build-a-Lot: Mysteries on Aug 11, 13 3:40 PM
Thanks for coming to my aid. I will try it tonight.I just played the level and got it in blue ribbon time! thanks again
 
 
 posted in Build-a-Lot: Mysteries on Aug 9, 13 4:54 PM
Help. I get the houses but not the rent, and that annoying pseudo-vampire keeps popping up to tell me to hurry.
 
 
 posted in Times of Vikings on Aug 5, 13 5:02 PM
Should have read all the posts first. Thanks fishies.
 
 
 posted in Times of Vikings on Aug 5, 13 4:58 PM
Sorry I read stars for level.
 
 
 posted in Times of Vikings on Aug 5, 13 4:57 PM
Build the fire ,and build the house, then what? The game won't allow you to start the next fire and illuminate the rest of the screen. Can anyone help? Am I doing something wrong?
 
 
 posted in Farm Up on Jun 7, 13 3:19 PM
I made the Queen's path and then sold the tiles right after, because I thought they looked ugly!
 
 
 posted in Egypt: Secret of five Gods on Mar 14, 12 6:59 PM
This game is slow to load , but does it eventually HOWEVER, a lot of the graphics are broken up into squares and rectangles.Especially the award pages, but specifically the graphics on the puzzles that you need to complete in order to move on in the game. So now I am stuck. Any one else have this problem? Any suggestions??
 
 
 posted in Sale Frenzy on Jan 31, 12 7:16 PM
I can't believe how crappy this game is! i think I played for about 10 minutes,if that. No instructions, so I lost the second level and didn't even know the 0 score was me!!!
I just had to laugh. And I agree with you Catweiss, all the characters looked like street walkers.
 
 
 posted in Royal Envoy 2 Collector's Edition on Dec 28, 11 3:30 PM
Customer service did a Dr. Felix on me. Turns out I don't have enough ram . I hope I will have enough to be able to play and purchase the regular edition when it comes out. So mystery solved.....(big sigh)
 
 
 posted in Royal Envoy 2 Collector's Edition on Dec 24, 11 3:59 PM
I contacted customer service yesterday after posting the above. As far as i know , one other person has the same problem. So I will just have to wait and see what CS has to say after the holiday.
 
 
 posted in Royal Envoy 2 Collector's Edition on Dec 23, 11 3:28 PM
SoManyCrimes wrote:The problem is that that is so alien to my experience that I don't understand how to answer the question. Either something is wrong with your version of the game or you've misunderstood one of the mechanics. Either way, it's hard to visualise what your difficulty is.

The 'smoke' clears as you light the lanterns. When you light one, a patch of land, usually circular, should clear up. Anything that was in the smoky area is now accessible. Graphically, it should now be as bright as on a normal "smoke-free" level. By the time you've lit all the lanterns, the only smoke should be around the borders of the play area. Is that not happening?

The only trees you can ever clear are the ones lying across the road or the small patches of more cartoony fir trees. From "clicking like mad" it sounds like you're trying to find hidden trees that just aren't there. The ones you can clear are obvious.

I just re-read your message. The light does not show a lit up area around it once it is fixed. Instead , the smoke thickens and covers more of the screen. I re-installed and it is still the same.
 
 
 posted in Royal Envoy 2 Collector's Edition on Dec 23, 11 3:26 PM
In the game I am playing , the smoke get thicker as I re-build the lanterns. Only then can I click on empty spots. fallen trees etc.and get the job done. The screen is black with swirling smoke.
 
 
 posted in Royal Envoy 2 Collector's Edition on Dec 22, 11 3:30 PM
What I am asking is: Does the smoke clear after all the lanterns are lit? I have demolished the sawmill and built a market , and have clicked like a fiend to find the trees to be cleared. Am I missing something? Was I away from school the day they covered this
 
 
 posted in Royal Envoy 2 Collector's Edition on Dec 21, 11 3:43 PM
Can anyone tell me if Level 9 is supposed to be covered in black smoke? I have tried to pass it about 15 times and always run out of time, as I am frantically clicking to get the trees cleared and the last cottage built. It was like this with the demo. I just assumed i was a bit incompetent , but I bought the game and now cannot proceed. I am desperate. Can any fishy help me???
 
 
 posted in Royal Envoy 2 Collector's Edition on Dec 20, 11 9:35 PM
Like you, MAXBSMOM, I haven't been able to get past level 9. I repeatedly run out of time and the screen is just black except for when the the resources appear. It gradually gets darker the more lanterns I manage to repair. Help !!!!!!
 
 
 posted in 7 Wonders: Magical Mystery Tour on Oct 31, 11 4:11 PM
I liked this game but I finished it in an evening. I think it is too short!
 
 
 posted in Tricks and Treats on Oct 30, 11 4:20 PM
What happens if your drivers are up to date, and the screen is still black?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator