Posts created by edmontonborn

 
 
I am playing this game on a PC running Windows 7. I get a runtime error after installing the electric motors on the machine by the ship at the docks.
 
 
I get a runtime error at the docks area of the game after I install the electric motors.
 
 
I completed the HOP but it didn't give me the wire puppet. Now I cannot move on in the game. Did I do something wrong? Do I have to restart the game?
 
 
 posted in The Far Kingdoms on Dec 12, 13 8:06 AM
Thanks again jcsgame. I have current drivers and the latest edition of the game. From other posts regarding this problem it is obvious BFG has no solution to the issue.
 
 
 posted in The Far Kingdoms on Dec 11, 13 9:47 AM
Thanks jcsgame, but the walkthrough is not helpful at all. I have done all the steps necessary and have the chest key in my inventory. The inventory bar, amulet and spell bottle are not there when I enter the caravan.
 
 
 posted in The Far Kingdoms on Dec 10, 13 9:30 AM
I am also having problems with the chest key. I noticed that not only do I not have the key in my inventory when I enter the caravan, but the amulet and spell bottle also disappear.
 
 
 posted in Dark Canvas: A Brush With Death Collector's Edition on Jan 17, 13 9:20 AM
I keep getting access violation notices and then the game terminates. The access violation does not happen at the same point in the game. Each time I restart the demo, I get a little further before the error occurs.
 
 
 posted in Time Relics: Gears of Light on Nov 10, 12 2:12 PM
Can't even start the demo. The game crashes and reboots my computer. Tried uninstalling and re-installing, but get the same problem.
 
 
 posted in Mystic Diary: Missing Pages on Jul 25, 12 10:26 AM
I had the same problem. I have a work around that worked for me. Perhaps it will work for others as well.

1. Click on the "Start" button in the lower left of your screen
2. Click on "My Computer" then select "Local Disc (C "
3. Double click on "Documents and Settings"
4. Double click on "All Users"
5. Now click on "Tools" at the top of the window
6. Select "Folder Options" then click on the "View" tab
7. Make sure "Show hidden files and folders" is selected in the list below, click "OK"
8. Now double click the faded "Application Data" folder
9. Double click the "SunRay Games" folder, then the "MysticDiary_MissingPages" folder

Then go ahead and delete all the files and folders inside that folder and give the game another try please!

 
 
I didn't have any problems getting the game to open. My problem started when I tried to play. The game was extremely slow to respond to changes in locations within the game. Whenever I tried to move to a new location, the game froze for a couple of seconds and then was very slow to respond to mouse clicks for a few seconds after that. As long as I was in one scene for awhile the mouse movements and clicking were very responsive.
 
 
I am about half way through the game and now the game is refusing to load. My computer clicks like it is changing the screen resolution and then the screen goes black and stays that way. I have to CTRL+ALT+DEL to get out,
 
 
 posted in Mystical Island on Jan 10, 12 10:02 AM
Boring game. I lasted until the end of the demo only because I hoped it would get better (it didn't). I found the grammatical errors to be very annoying. Definitely will NOT be buying this game.
 
 
 posted in Treasure Hunters on Mar 14, 11 10:05 AM
Having a machine that is running XP is no guarantee that the game will work. I tried it on an old computer running XP and had the same problems with crashing I had on my newer computer.
 
 
 posted in Treasure Hunters on Mar 13, 11 12:45 PM
Hazel53Xby wrote:I started well with this game. Got my name in ok. Got to hidden object game ok. Doing well. Got to 1st puzzle and ski ing went well. Down through the maze. Terrific. Then it started to load next bit and guess what, IT FROZE. I tried escape button, Nothing happened. I tried Control Alt delete, Nothing happened. I had to turn off computer to get out of the game. Guess I will never know if it is a good game.
Yet, another game to add to my Can't Play List.
All I seem to do is moan lately. That is not really me, honest. I would love to do a good review on a game that i can play all the way through. LOL
Hazel


Same problem here. Uninstalled and redownloaded. Wouldn't even take me to first screen. Had to reboot my machine because I couldn't even get CRL ALT DEL to work. Needless to say, I am not going to be playing this demo.
 
 
 posted in Dr. Jekyll & Mr. Hyde: The Strange Case on Mar 6, 11 3:44 PM
Played the entire hour of the demo hoping the game would get better--it didn't. Only redeeming feature in my opinion was the ability to magnify the **** scenes and then the magnification wasn't enough to see the teeny weeny items. Another game for the trash can!
 
 
 posted in Reading the Dead on Feb 14, 11 1:39 PM
Just like so many other fishies the game downloaded just fine, but wouldn't open. Had to restart computer before I could uninstall the game. Reinstalled, but still had the same problem. For sure I won't be purchasing this game.
 
 
 posted in Ancient Spirits: Columbus' Legacy on Oct 11, 10 11:50 AM
Tried playing this game on my laptop. Lasted 10 minutes and quit. Cursor wandered randomly around the screen making it all but impossible to play the game.
 
 
 posted in Incredible Adventures of my Mom on Oct 4, 10 3:55 PM
I have to place myself firmly in the "not for me" category. I played about 25 minutes of the demo and deleted the game. Boring in the extreme. If my mother was this interfering, I would lock her up and throw away the key!
 
 
 posted in Doors of the Mind: Inner Mysteries on Mar 13, 10 12:48 PM
I can not get beyond the opening scenes. The scenes play fine, but the game crashes to desktop immediately after.
 
 
 posted in Cassandra's Journey 2: The Fifth Sun of Nostradamus on Dec 19, 09 3:35 PM
I also had a problem with the game freezing. Now I get an "Access Violation" error when I try to leave the kitchen after making the food. I have tried rebooting and it gives me the same error.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator