Posts created by bajacalla

 
 
 posted in Kaptain Brawe - Episode I on Nov 15, 10 1:48 PM
I was having such a great time in the demo that I decided to go ahead and buy it for my Mac before the 60 minutes was up.

alas, once purchased and installed, it now crashes while loading. : (

per the usual recommendations, I did the Apple upgrades, but it's still not loading. bummer bummer.
 
 
 posted in Time Riddles: The Mansion on Oct 25, 10 6:17 PM
I bought the game, and really enjoyed it at first, but it is so repetitive and the story is almost incomprehensible that I started feeling irritated. I may continue playing it from time to time, but it's definitely not one I'd recommend very highly.
 
 
 posted in Sinister City on Oct 19, 10 7:09 AM
yeah, me, too. crashes as I begin to search for the clock - all of 10 minutes into the game.
 
 
 posted in The Seawise Chronicles: Untamed Legacy on Sep 27, 10 3:03 PM
Shannon282007 wrote:Is it just me or does this game not start for anyone else? It goes through all of the beginning credits for the creators and then when the game is supposed to start all i get is a flying fairy and two balls of light shooting to a bridge over and over....then nothing. HELP! I've tried uninstalling and reinstalling but no luck...


I have the exact same problem, but I had to force quit the game just to get out of the demo so I could uninstall. I'm on a Mac, and this is the first time I've ever had this problem with a Mac version of a game from Big Fish. and I would contact technical support on it, EXCEPT I haven't even been able to get into to even see if it's one I'd be interested in playing, much less buying. that much trouble just isn't worth it.

but I am still waiting for fixes to A Gypsy's Tale and Redemption Cemetary - which I did buy after the demos, only to run into glitches that made them completely unplayable beyond a certain point. this one lost its opportunity at first click.
 
 
 posted in Lost in the City: Post Scriptum on Sep 6, 10 11:17 AM
I am *really* having trouble with this - what exactly do we do here? I can move the mouse slowly enough to get to a word, but how do we *catch* it? yes, I'm using the net, but clicking on the word with it doesn't do anything, and if I move the net even a skosh, it sets the words to flying again. what am I supposed to do to catch the word?
 
 
 posted in Time Dreamer on Aug 14, 10 7:15 AM
shorenuf wrote:
bajacalla wrote:I'm having the same exact problem, which is a bummer because I also purchased A Gypsy's Tale and am unable to continue playing that (the orchard glitch) as well. doubly unfortunate is that both these games played so beautifully through the demos and are exactly the type of games I enjoy most.

I have sent word to Customer Support.


bajacalla, WilJul, DariusThe3rd, bridgetaida -- Did any of you quit and try to restart during the demo? At least 2 others of us could not continue when we went back to finish the demo. The game restarted but hitting "Play" to continue caused the game to quit while loading.

The more info we can collect for customer service the better, so thanks in advance for your replies.

EDT: for clarity (I hope)


no, I played the demo straight through on both games. I'm pretty addicted to these games.
 
 
 posted in Time Dreamer on Aug 13, 10 4:25 PM
I'm having the same exact problem, which is a bummer because I also purchased A Gypsy's Tale and am unable to continue playing that (the orchard glitch) as well. doubly unfortunate is that both these games played so beautifully through the demos and are exactly the type of games I enjoy most.

I have sent word to Customer Support.
 
 
 posted in The Crop Circles Mystery on Aug 9, 10 5:21 PM
I have tried 3 times to download the Mac version of this game - it gets to about 33% downloaded and my computer locks up and I have to do a hard reboot. this is the second game this week that locks up my computer completely and I can't play.

not good. not good at all.
 
 
 posted in A Gypsy's Tale: The Tower of Secrets on Aug 8, 10 5:31 PM
I'm having the exact problem: released the squirrel, and the game freezes. reboot, and it opens in the game, in the same scene - can't get out. have to force reboot, but opening the game takes me right back to the squirrel in the orchard and I'm frozen again.
 
 
 posted in Elixir of Immortality on Aug 1, 10 7:24 AM
beautiful, beautiful game. more, please.
 
 
 posted in Romancing the Seven Wonders: Great Pyramids on Jul 12, 10 7:33 PM
I really, really, *really* wanted to like this game. unfortunately, I couldn't even finish the FIRST HOG scene - the items were so small, the scene so dark, no hints, and the penalty for wrong clicks so heavy, it wasn't a "game" at all for me, it was that nightmare "final exam in the class I forgot I'd registered for" all over again.

 
 
I've downloaded the demo, and it looks like a game I'd really like, but it keeps crashing on me at the house looking for the spare car keys.
 
 
 posted in World Mosaics 3 - Fairy Tales on Jul 8, 10 5:41 PM
I had never played WM 1 or 2, but this one has my whole-hearted allegiance! I've just finished The Monkey King, with only 3 stories left, and am finding my brain very pleasantly challenged. I will definitely keep an eye open for future editions!
 
 
 posted in King's Legacy on Jun 27, 10 9:42 AM
I was really hoping to like this game, since it seemed to be a little bit like Fairy Godmother Tycoon, but I'm pretty disappointed. the graphics are adorable, the music isn't annoying, and the mechanics of building, etc., are pretty intuitive.

but it's just awkward to play - the interface is much too clunky and takes *far* too many clicks, which is not good for my wrist. wish it ran smoother.

so, I won't be buying it.
 
 
 posted in Dream Chronicles: Book of Air Collector's Edition on Jun 24, 10 10:53 AM
I am having difficulty completely filling the fuel tank, playing in "challenging" mode. I cannot get enough stones into the grid to fill it up completely, and if I try to fill the tank with the grid incompletely filled, I cannot fill the tank. if I return to add more stones to the grid, it wipes out the ones still in the grid (whether used or not), and again incompletely fills the grid with the new stones - I cannot get the top 3 rows to fill with stones. if I have made matches with the stones to fill the tank, but it isn't completely filled, and if I go back to get more stones, not only does the *grid* empty, but the *tank* empties. so I can never fill either the grid or the tank.

do I need to start a new game on the easier mode, or is there something I am missing/doing wrong?
 
 
 posted in The Legend of Crystal Valley on Jun 1, 10 8:15 AM
did you try double clicking on the flashlight?
 
 
 posted in The Legend of Crystal Valley on May 31, 10 9:20 AM
once you have the crystal from the giant, go back and talk to Melvis again.
 
 
 posted in The Legend of Crystal Valley on May 30, 10 9:34 AM
re refunds on non-working games: I've never had a refund, but BFG has always given me a credit for a different game.
 
 
 posted in Matchmaker: Joining Hearts on May 25, 10 6:32 AM
I enjoyed this game for the same reason I enjoyed the movies "Innocence" and "Letters to Juliet" - it's about finding love past the "OMG!!" stage.

 
 
 posted in My Beautiful Vacation on Apr 30, 10 5:53 AM
for some reason, I just couldn't get into this game, didn't even finish the demo. it seemed slow and repetitive to me, and did not hold my interest.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator