Posts created by Rob_Blake

 
 
 posted in Haunted Train: Clashing Worlds Collector's Edition on Nov 10, 16 1:18 PM
I didn't play in Expert mode, but I also did not skip any puzzles and I didn't use any hints on the HOP puzzles, but Achievements said I was short one of each. However, as I was playing the last couple of chapters and the bonus chapter, it kept saying I was short one of the Collectible items, even at the end, but when I went to Extras it said that I did find all of them and it let me play the extra puzzle. Seems to be definite glitches. I don't like letting an HO puzzle sit for over 10 minutes, just to get that Achievement. I have never understood why they have one like that in any of their games. So, I knew there were 2 Achievements I wouldn't get for sure, but I should have still gotten the ones for no Skip and no Hints used. I rarely play the games twice either.
 
 
 posted in Haunted Train: Clashing Worlds Collector's Edition on Nov 10, 16 1:08 PM
Yeah, I played it a couple times according to the SG instructions and finally figured out that they left one move out. (O - N) should be done either right before or right after (M - N), then you can do the rest of the moves. I didn't write it down, but if Before doesn't work, then After will.
 
 
 posted in Mystery Tales: Eye of the Fire Collector's Edition on Sep 29, 16 7:58 AM
Just to expand on other responses. Yesterday's code was 2FOR1 and it was only for SE games. GAMECLUB was code last week.
 
 
I am wondering about this too, as I didn't play any of the Pair Matching during the main game, and wondered if I will get both Achievements (Pair Matching and Hidden Objects) if I replay the game, and play the Pair Matching puzzles instead.

I replayed the whole game and played all of the Pair Matching puzzles, instead of the HO puzzles. It kept all my previous Achievements and I did get all 3 of the Pair Matching Achievements. I also found the rest of the Morphing items that I had missed the first time. The strange thing about replaying and finding the Morphing items was that I only missed 6 of them the first time I played the game, yet several of the ones that I did find the first time were still there during the replay, but not all 21 of them, and yet I still got the Achievement for finding all 21.
 
 
All of the locations for the morphing items, feathers, and flowers are shown in order at the end of the Strategy Guide after the Bonus chapter.
 
 
 posted in The Disappearing Runestones on Jul 20, 16 7:32 AM
Thank you for the quick response. I saw that as a possible option, but was hoping there was a way to change it without reinstalling Game Manager. I will go ahead and do that.
 
 
 posted in The Disappearing Runestones on Jul 20, 16 7:13 AM
I don't know where else to post this and Tech Support has not given me the solution yet. I ran Window 10 update the other day and Big Fish Game Manager asked me what browser I wanted to use for it. I chose Google Chrome, but I want to switch it back to Firefox. I can't find anything under Options or Settings that will let me do so. Can anyone help me? Thank you.
 
 
 posted in 7 Roses: A Darkness Rises on Jun 29, 16 6:11 AM
Yes, I know I needed to collect 3 spheres, but the other 2 were no longer there to collect. Neither the one on the left behind the bushes, nor the one to the right of the Elder.

I decided to start the game over last night with a new profile, and I was able to play the whole game with no problems. And, I also realized while re-playing the game, that I had originally gotten a lot further with the game than the Blue Spheres when I played the Demo on June 22. So, that means there was a glitch going back into the game under the same profile, after I purchased it on Monday, June 27, and went back into it to continue where I had left off at the end of the Demo. I hope that makes sense. I decided to play the whole game last night under the new profile, as I did not want to take the chance of exiting the game before I finished it and have the same thing happen again.
 
 
 posted in 7 Roses: A Darkness Rises on Jun 28, 16 4:15 PM
As I stated in my original post, I have one Blue Sphere, the machete, and the pendant in my inventory. I had the 2nd blue sphere, which I got by cutting the vines on the left, but it disappeared from Inventory after I exited the game and then went back into the game, and now the machete doesn't do anything. I have clicked on the Elder several times who tells me to open the gate, but there is no blue sphere on the right, and nothing to click on. I uninstalled and re-installed the game, but that did not change anything.
 
 
 posted in 7 Roses: A Darkness Rises on Jun 27, 16 6:28 PM
I found only 2 Blue Spheres needed for the gate in the big tree, which were then labeled in Inventory as 3/2. I got the 2nd one by using the machete on the bushes on the left side, but I cannot find any other spot to use the machete on, or any spot on any available screen that will let me click on anything. The only screens that I can go to are: the one of the tree and mountains, the one inside the tree with the wizard, and the gate with the 5 places for spheres. Only other item in Inventory besides the 2 spheres and the machete, was the pendant. After exiting the game and going back into it, I now only have one Blue Sphere, and the spot where I got the 2nd one before with the machete is no longer there. Can anyone help me find the other sphere(s), or what else I need to do? I will also try to re-install the game to see if that helps. Thank you.
 
 
 posted in Egypt Solitaire Match 2 Cards on Jun 13, 16 6:53 AM
PLAY for CE games
 
 
 posted in Black Swan on May 24, 16 6:33 PM
I am stuck on the puzzle with tiles of a picture of a fountain. I do not see any reset button, and the puzzle does not reset on its own after exiting the puzzle or the game. I found video walkthroughs in Russian, and I know how the puzzle can be easily solved, but I would need to reset it to do so. I don't understand developers leaving Resets off mini puzzles.
 
 
The locations of the Collectibles are listed under Chapter 8 in the SG, and Chapter 7 is actually the Bonus Chapter.
 
 
 posted in Secrets of Magic: The Book of Spells on May 16, 16 12:21 PM
I don't see Bonus Punch Day advertised today (Monday) on the Main page, or on my Game Manager, so I hope I am not missing out, and that it will be tomorrow (Tuesday).
 
 
 posted in Dark Romance: Kingdom of Death Collector's Edition on Apr 26, 16 10:18 AM
I completed the game and bonus chapter. Where and how do you defeat Hades in order to get the Stronger than Gods Achievement?
 
 
 posted in Demon Hunter 3: Revelation Collector's Edition on Apr 23, 16 8:43 PM
Hello Boris,

I enjoyed the game, but I do wish that if we missed or could not find a collectible, we could still go back and find it after finishing the game, under Extras. Or, don't block off any areas in the game, even if they are no longer needed, which would allow us to go back over every area near the end, if we see that we are short a collectible or two. I didn't get the portrait of Joseph Adams, and I have no idea where it was located, or how I missed it. I also did not get the "find 5 in 5 seconds", and I agree that it would be good if we could still achieve it when replaying the HO puzzles under Extras. Thank you.
 
 
I think you have to click on it as soon as you go to that scene, but I waited and then it wouldn't let me. After you finish the game, you can still get that bat in Extras, under Collections, and you will still get the achievement for finding all the bats.
 
 
It's 304, but you have to click on each of the 3 shape drawings around the area with an object (I forget what the object is) first, to get the # for each shape, or it won't work.
 
 
I was able to play the mini-game in the Psychic's House, and then I quit the game for several days. Now, there is no one in the room to talk to, no objects to take, no HO puzzle to play, and Hint button tells me there is nothing to do in any of the 3 open areas. I only have Arlene's Diary and the unfinished jewelry box in Inventory. I have uninstalled and re-installed, but that did not help. I have not tried a new profile, yet. Has anyone else run into the same problem?

Started over this morning with a new Profile, and I was able to play the game with no problems. This has happened before with a few games, where a new profile worked.
 
 
It worked for me, too, just now.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator