Posts created by VickyS82

 
 
 posted in Midnight Castle on Mar 28, 15 1:30 PM
TiramaSue wrote:
athwick wrote:Airships give you coin! I'm being cheated. And don't hate the crafters; we're having fun too.


I don't hate the crafters, however, crafters shouldn't expect the game to be redesigned to suit their style of play. Play the way you want, but own the consequences.

If you don't watch your stamps, you will not have any for the things you have to craft for quests. I don't craft for coins, and I have close to 2,000 plain stamps (I'm on level 55). So clearly, the game is giving them.

The airship gives you coins at the time you load the items on it. It's the same amount as if you had sold those items. Watch you coin total the next time you load an airship.



You're correct about the game being redesigned. And had that been the issue due to crafting for coin, your point is valid. In my case, it is not. I do not craft unless it's for a quest. But thanks for the input.
 
 
 posted in Midnight Castle on Mar 28, 15 1:20 PM
TiramaSue wrote:WE are not out of stamps, you are.

I'm going to guess that you like to craft for coins. There are many threads about crafting for coins and the consequences of doing so.

Those of us who don't craft for coins, or who once did but stopped that practice once the first stamp 'shortage' was reported, don't run out of stamps.

The hidden object scenes give an airship item 100% of the time. In addition, 50% of the time, the ho's give one of the following: a stamp, pet food, gift for a friend.

Airship items may be low on YOUR priority list. Other routinely send the ship because doing so gets them...wait for it...one to three stamps and one pet food.

rosiebvt has given you excellent advise. Forget about the quests and crafting, even when you get the minimum amount of stamps you need to move on, and build up your inventory. Once you build up your reserves, when you craft, keep an eye on how many you have and never let your total fall below a set amount, no matter how anxious you are to move forward.

The games has an interesting balance.

HO's give you coins, airship items, stamps, and pet food.
Airships give you coins, stamps, and pet food
Pets give you coin, stamps, and crystal balls and wands.

While you don't need to send airships or feed pets, ignoring one facet of the game can deprive you of items needed.




Actually, I do not ever craft for coins. I had a steady supply of 300+ plain stamps, so it never occurred to me that the supply was dwindling until I could not craft a QUEST item. So my original post was taking into consideration that 300+ in inventory should really never completely deplete given that they are used only for quest crafting. Good guess, but no.....

I am aware of the different facets of the game and the rewards. In fact, I send airships daily, as my inventory of those items is several hundred each. And I do feed pets, especially when coins are needed. Again, thank you for your input; however, my main point was that to go to zero from 300+ plain stamps indicates that they are not being replenished as I assumed they had been.
 
 
 posted in Midnight Castle on Mar 11, 15 5:50 AM
This idiot is out of control!
 
 
 posted in Antique Road Trip: American Dreamin' on Jan 31, 15 8:32 AM
I've installed all updates, waited half my life for the new building to finally get done (hundreds of hours), and still NO new quests. I can see many with the same issues, but I have not found any feedback from developers. I cannot do anything in the new section, and all I get is one daily quest, either a mini game or win something at auction. No building or plane quests. If they don't address this soon, I'm going to uninstall. I hate to do that, because I've been playing since the game came out.
 
 
 posted in Antique Road Trip: American Dreamin' on Jan 9, 15 5:49 AM
april3850 wrote:*****POSSIBLE SPOILER*****


Ok, here's what I did to get the quests, just in case someone hasnt found them yet. Once I fixed the plane and visited the countries (You have to do this first), I customized the AES Museum to the Pirate theme. I did NOT wait the time to build it, I just paid the 152 gold to do it. Once inside, there is puzzle right above the door on the left side of the paintings. I selected it, then I got a WHOLE BUNCH OF QUESTS from Fatima!!!! I mean, I had to play a bunch of mini-games and visit a bunch of cities/countries to find the parts to the sign above the door. (Note: Some of the quests are designated as 'Auction Quests' but you dont have to do the auction unless you want to. You can do either the auction or play the mini-game that contains the collectible it asks for.) Once I had the parts, I had to put the sign together. Once I put together the sign, that opened up a new mini-game where you put together the sign a bunch of times, and it also opened up a storage room. Once the sign is together you can click on the door on the left and enter the room. Once I entered the room, there is a book on the table, I selected it, and that opened up a BUNCH MORE QUESTS!!! I think these quests will lead to the buildings being built, but I havent got there yet.

And that's where Im stopping for now. Im going to bed, it's the wee hours of the morning here. I hope this helps someone.



A lot of us do not even have the airplane quest......
 
 
 posted in Antique Road Trip: American Dreamin' on Jan 9, 15 5:47 AM
1.804 and only have the auction quest
 
 
 posted in Antique Road Trip: American Dreamin' on Jan 9, 15 5:44 AM
I am also only getting auction quests. Not sure if BFG is even addressing all the quest issues. I see thousands of issues with no replies.
 
 
 posted in Antique Road Trip: American Dreamin' on Jan 9, 15 5:42 AM
I do not have it either. I also do not have the "building quests" that are supposedly needed in the new area. I stopped playing for a while because there was nothing new to do. But now it appears that I'm also stuck.
 
 
 posted in Awakening Kingdoms on Aug 10, 14 8:34 AM
I just installed the update, went to play, and was told that my profile could not be found and that I have to create a new one. Meaning I have to start from square one. Nope. Quests got to be ridiculous, and having to constantly give away items instead of applying them to collections was already frustrating to the point of considering quitting playing anyway. My decision is now an easy one.
 
 
 posted in Midnight Castle on Jul 17, 14 9:08 AM
awalkinglady wrote:Would love to follow the suggestions of location where you have gotten unique stamps. However, I have played over 400 HOS and not earned even one of them. This is so totally ridiculous!!! BFG and Elephant Games have effectively ruined this game by making it almost impossible to earn these stupid unique stamps.


I agree 100%. I don't mind having to "work" for them, but I'm now on a quest that needs 4 of them. I've had 0 for too many days to count. I was really liking the game, but since quests are the only way to advance levels (mixed emotions on THAT), I'm afraid this one will have to go on the back shelf, similar to all the other free-to-play games that do the same thing. Shame, as this one had the most potential of them all.
 
 
 posted in The Tiny Tale 2 on Jun 13, 14 5:25 AM
I am also on Level 19, requiring two gold mines and two taverns be fully upgraded. I've played the level twice. The first time, only one tavern would register as complete. The second time, only one gold mine and one tavern would register. Cannot proceed, since the level will not complete.
 
 
 posted in Midnight Castle on May 20, 14 9:49 AM
Please add me if you need friends. Code 269882. Thank you in advance!
 
 
 posted in Antique Road Trip: American Dreamin' on Feb 10, 14 6:31 AM
COOLAZTAB wrote:
DivaBarb wrote:I installed the update and now I get an error message and can't play it at all.
It says:
Cannot find import; DLL may be missing, corrupt, or wrong version
File "d3dx9_43.dll", error 126
Not sure if anyone can help


I am having the same issue



Same error here......
 
 
 posted in Found: A Hidden Object Adventure - Free to Play on Dec 5, 13 6:19 PM
Same as previous posters.... I FINALLY got an ice chest. The two amulets from it disappeared upon opening the game again.

I charged the Christmas Collection THREE times..... all awards from that are gone, and the game is not registering that I charged it at all.

I had already maxxed out the elf, so I will see if I get awards for bartering with him again - LOL.

I'm also a bit frustrated that ALL Halloween awards disappeared with the Christmas update.

It's not like BFG to release something with so many problems.
 
 
 posted in Found: A Hidden Object Adventure - Free to Play on Jul 19, 13 3:23 PM
cherdoll8 wrote:HELP!!!!
I just went to play my game and it said my profile has been corrupted and the game will start all over!!!
I am finished all the quests and was playing for the sake of the collections
Is there ANY way I can get back my profile, status, and levels??????



Same thing happened to me a while back.......... had to start from the beginning.
 
 
 posted in Found: A Hidden Object Adventure - Free to Play on Jul 5, 13 8:07 PM
The bartering/banishing has become useless. Given that the quests frequently rely on those exchanges, it is more frustrating than fun. Especially when using coins to barter/banish and only receiving in return a couple experience points a a few coins.

The amulets' running after quitting the game is really not fair. The locations use outrageous amounts of energy; we're lucky to play for more than 15-20 minutes with full energy. The 100-minute amulets are useless beyond that 15-20 minutes. I get that BFG wants us to spend real money, and I completely understand that those of us who do not want to spend money on the game (I spend plenty on games and the Game Club on the site) will have to wait longer to finish quests. However, BFG is making it so that basically if you don't pay, you really cannot accomplish anything.
 
 
 posted in Found: A Hidden Object Adventure - Free to Play on Jun 21, 13 4:30 AM
Yep - Using 90 energy points to gain a tube of glue is not acceptable. Not a machete to be found anywhere, and one of my current quests needs 20 or 30 of them. Will let energy fill up (should take about 2 days) and hope the non-existent items in the locations and floaters issue gets fixed. Wish I hadn't installed the update.....
 
 
ergaster wrote:
cnbmimi11 wrote:same thing happend to me ...had to start game over..did not appreciate having to do this..


Yes, I had the exact same problem, I am highly annoyed at having to cover all that ground again!

Fix please. Ruins an otherwise good experience.



The game completely locked up on this puzzle, and I wound up having to manually restart the computer. The game opened back up at the same place, but was telling me to insert the slides, which were then missing from inventory. I am not starting over. Too much back and forth to begin with.... I have no intention of replaying the first two chapters. I sent an email to Customer Service. Would rather have a credit at this point........
 
 
 posted in The Agency of Anomalies: Mystic Hospital on May 14, 11 1:42 PM
pinkpetunias wrote:Game will save if you go in when opens and make your profile ( took me 3 times of starting all over to realize that)but I also have no pistol. Starting over again!


I did that immediately upon opening the game for the first time, played for two hours, and it did not save. When I reopened the game, the only profile was "guest" and I was back to being locked outside the gate.

Update: The game progress does not save even if you simply go back to the main menu. You do not even need to exit it completely to lose all progress. It still shows your name at the top, but when you attempt to go back into the game, you are again outside the gate. I've uninstalled, reinstalled with the same issue.

And I can't find the pistol either.......
 
 
 posted in The Agency of Anomalies: Mystic Hospital on May 14, 11 1:34 PM
Same here Cinder..... I played for TWO hours. When I reopened the game, it reverted back to "guest"; my profile was not even saved, let alone game progress.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator