Posts created by MarieNomad

 
 
 posted in Psych on Mar 28, 14 9:42 AM
I loaded the DVD into Gus' laptop but it stopped after that and I can't get the clue I needed to move it forward.
 
 
 posted in Astral Towers on Sep 26, 12 9:03 AM
How can I get the fire tower? No matter what I try, I can't seem to defeat the wave.
 
 
Wow, so Angela was dead all this time? That's a twist I didn't see coming.
 
 
For some reason, I can't use the clippers to strip the wires. I used the hint system and I kept on clicking on wire point seven but nothing.
 
 
I am missing the Coral Goblet. Help?
 
 
 posted in The Chronicles of Shakespeare: Romeo & Juliet on Oct 5, 11 8:27 AM
I got the game after I was finished with the trial and now it won't start again. All that showed up was the menu, the inventory, and the little girl.
 
 
 posted in Dark Dimensions: City of Fog Collector's Edition on May 30, 11 6:22 AM
I don't know why but I tried to use that ladder at the tree house but it won't let me.
 
 
 posted in The Stroke of Midnight on Jan 22, 11 7:37 AM
I managed to cleaned up the dining room but then the game stopped on me because my sixty minutes were up. I bought the game and when I tried to start again, I can't get into the kitchen. The door stayed as a mirror. I don't know what to do.
 
 
 posted in Once Upon a Farm on Jan 2, 11 7:30 AM
I was intrigued when I read the game and I thought that it could be fun. I was confused when a pipe is listed as a tube and an alarm clock as a watch. I winced when I saw the agent posing as a Mexican immigrant worker with the sombrero and mustache. It's so insulting to Hispanics. After calling a maple leaf was listed as a 'sheet', I decided that I had enough and uninstalled the game.

Don't buy this game.
 
 
 posted in Royal Trouble on Sep 11, 10 6:15 AM
This game is very fun and engrossing. I found myself playing right through the demo and not realize an hour had passed.

The puzzles are challenging but you can skip them if you want. It's also pretty funny and light hearted. I hope there is a sequel.
 
 
Pliers. Use it to straighten out the coat hanger.
 
 
Put the stick and the razor on the bench and click on the razor once to unfold it. Then drag the razor on the bare end of the stick and then drag the string onto the razor and stick. Use the razor stick to cut the leash.
 
 
I'm nearly finished but I need to know how do I get rid of the moss on the fountain?
 
 
 posted in Hidden Expedition ® - Devil's Triangle on Dec 23, 09 6:06 AM
I can't do the chapter five puzzle game either without freezing. It's frustrating.
 
 
 posted in Gemini Lost on Oct 22, 09 5:56 AM
I like the game. It was short and the married couples make the babies automatically which makes things easier. It's a little too short but at least you didn't get bored with the game.
 
 
 posted in Hostile Makeover on Oct 18, 09 5:29 AM
I have an issue! I am looking for a pair of scissors in Lacy's Office but I can't find it. The hints aren't helping at all. I keep on looking and clicking at an area that the hint pointed to but nothing.
 
 
 posted in Millennium: A New Hope on Oct 12, 09 8:15 AM
I am stuck on the first part. I don't know how to get past the Temple and out to Grandpa's house. The walkthrough was no good.
 
 
 posted in Aveyond: Gates of Night on Aug 8, 09 9:33 AM
Where's the crown?
 
 
 posted in Aveyond 2 on Jul 5, 09 12:48 PM
I can't seem to get Emma. Every time I talk to her at the castle, she said that she will graduate early. No matter how often I return there, I keep on getting the same response. I'm up to the part which I got the pirate ship. Ideas?
 
 
 posted in Aveyond: Lord of Twilight on Jun 17, 09 3:53 PM
When will the next Aveyond game be up?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator