Posts created by lovetoocraft

 posted in Golden Trails: The New Western Rush on Mar 15, 18 6:49 PM
It appears the missing scissors has been a problem for years...why hasn't it been fixed? I have had this game for a long time but haven't played it much until now. I'm stuck because I do not have access to the scissors. What can be done?
The only thing I can think of is to create a new profile before replaying the game.
 posted in The Secret Order: New Horizon on Jun 4, 14 11:08 PM
Did you get the one from the HOG just after leaving the window washer lift? It took me forever to find the last item in this puzzle and there wasn't a picture in the WT. This is the first time I ever encountered this problem.

WT instructions for the HOG and how to solve the puzzle on the door were, for the most part, non-existent.
 posted in The Secret Order: New Horizon on Jun 4, 14 10:47 PM
You have to assemble the telescope first. After the telescope is put together, adjust the focus and you will see the code. You must complete this task before the code (as seen in the WT) will work.
 posted in Dark Romance: Vampire in Love on Mar 20, 14 10:03 PM
Unfortunately I've not seen a walkthrough for this game.

A few times when I switch characters, the map doesn't show the next active place to visit. When this happens, I click the hint button and it usually guides me in the right direction.

If you are where I think you are, take the BAS RELIEF detail once the grave is open.
Go to the cabinet.
Place the BAS RELIEF in the niche.

Good Luck
 posted in Grim Tales: The Wishes Collector's Edition on Mar 17, 14 4:37 PM
For clarification...once you get to Brandon's bedroom, turn right and go through the closet and passage way. You will find the tree house just as you exit the passage way and enter the forest.
 posted in Grim Tales: The Wishes Collector's Edition on Mar 17, 14 4:22 PM
At first I had this same problem, then discovered there are places for 2 totems (at least that is all I've found so far). Place the first totem in the upper left of the room. After that, move your curser over to the right side of the room near the top and you will find a place for a second totem. Open this active area (you probably won't have the 2nd totem yet) and the dove is sitting on the shelf.

 posted in Mystery Tales: The Lost Hope on Mar 8, 14 11:43 PM
The version of the game I purchased was the CE.

I enjoyed the game as far as I was able to play, however, there are to many technical issues.

Twice I had to uninstall/reinstall to resolve a problem.

Numerous times the game totally froze the entire computer and I had to do a hard shut down then restart the computer. This isn't worth the risk of totally crashing my computer for good.

Will be asking for a return of my credits.
 posted in Mystery Tales: The Lost Hope on Mar 8, 14 5:02 PM
There are only 2 suggestions that I can think of.

1. Uninstall/re-install the game. You will not lose your place in the game. Sometimes this resolves problems.

2. Start the game over. I already had to do this with another problem.

Hope this helps.
 posted in Living Legends: Frozen Beauty on Jan 19, 14 8:52 PM
In different scenes I am finding and collecting coins that go to the Pet House for my squirrel. The WT does not mention any of these coins nor anything about why they are there.

I clicked on "go to the pet house" after collecting some coins and it looks like the pet is a squirrel.

Can anyone shed any light on the subject. What's the purpose here?

 posted in Otherworld: Omens of Summer on Apr 6, 13 10:37 PM
I'm in the 2nd portal with the Nyx trying to make the crown. The coral is already collected and in the tray and the plankton are in the flask. The purple stalagmite is in the mortar with the pestle, however it will not grind. Using the hint, I was able to get 2 grinds done, but am unable to grind it the remaining 3 times.

It makes no sense why I am not able to make the final 3 grinds...nothing happens. Am I missing something?
 posted in Otherworld: Omens of Summer on Apr 6, 13 2:27 PM
Hi myeeyore,

I was having a problem here also and just figured it out.

I understand you dug up the first seed from the small mound and probably planted it back in the same mound. If this is correct, you did in fact only get about half a vine that did not need to be watered.

Continue playing the game until you can assemble the fishing pole with the fish hook attached.

At some point you will get an eye mask which you attach the elastic band for a face mask. You should be at the stream. Click on the multi colors in the water and a mini game will pop up. Put on the face mask and comlete the mini game.

Once the mini game is complete, a statue holding a pouch will rise up out of the water. Use the fishing pole to retrieve the pouch from the statue. When you click on the pouch, you will get another beanstalk seed.

Go back to where you planted the first seed. On the left side of your screen, move your curser along the side of the trail next to the mountain at the bend. Plant the 2nd seed there, and water that seed. That stalk will grow all the way up. Go over to the smaller beanstalk and climb that one to get to the top of the mountain.

Hope this helps.
 posted in Inception of Darkness: Exorcist 3 on Dec 21, 12 4:32 PM
You also need the boulder from the cave in.

Go back to where the rocks are from the cave in. On one of the rocks there is an active area that states you need to use the bucket of water on the cave in...this is a do not need water.

Move your curser to the right of the water glitch. When you find an active area, use the pick ax and break off a piece of rock. This is the 4th weight.
 posted in Inception of Darkness: Exorcist 3 on Dec 19, 12 11:55 PM
At last I figured out how to enter the old man's cabin. Cleared the attic and retrieved the 5th crystal from the basement. Now I have no idea where I am supposed to go. About the only thing the hint leads me to is the old broken bridge. Just before I get to the pile of sand with the sifter on it, I click on the hint button. Once I click on the hint, I am directed to the place under the bridge, however, there is nothing active there.

In my inventory I have a stick, 5 crystals, oil can (the one I used for the train), and the kettle of red molten glass. What do I use these items on?

 posted in Inception of Darkness: Exorcist 3 on Dec 19, 12 11:41 PM
Correct. You will receive a knife, but it will be quite awhile before you obtain it.
 posted in Inception of Darkness: Exorcist 3 on Dec 19, 12 11:38 PM
Use the pick ax just to the right of where you are told to use the bucket of water. Keep inching to the right a little at a time until you hit the rock that needs to be hit by the pick ax.

A piece of rock will fall off after you use the ax. Pick up the rock and use it as a a weight in another chamber.

You do not need a bucket of water here.
 posted in Zodiac Prophecies: The Serpent Bearer on Nov 25, 12 3:02 PM
It appears that not being able to move the fish to obtain a piece of the scepter is a common problem. Last night I had that problem and there are other posts in the forum with other people having this very same problem.

The problem I encountered was not being able to move the fish bones. Everything else moved but the fish bones. I uninstalled/reinstalled the game and neither the fish bones or a starfish would move.

I shutdown the computer last night. Today when I fired up the computer, I went back into the game to try again and the fish moved...YES!

If you run into this problem, I recommend you uninstall/reinstall, then restart your computer.
 posted in Zodiac Prophecies: The Serpent Bearer on Nov 25, 12 2:47 PM
I had the same problem last night. Last night I had the same problem and I uninstalled/reinstalled the program 3 times to no avail. Before going to bed, I shut down the computer.

Today when I fired up the computer, I went back into the game and the fish moved with no problem. I suspect all I needed to do last night was do a restart.
 posted in Zodiac Prophecies: The Serpent Bearer on Nov 25, 12 2:40 PM
Hi Poppy,

Try doing a shutdown/restart. Last night I was unable to move the fish bones. I uninstalled and reinstalled the game 3 times last night before finally giving up. Once finished playing games, I shut down the computer for the night.

A few minutes ago I fired up the computer and tried to move the fish bones worked

Hope this helps.
 posted in Zodiac Prophecies: The Serpent Bearer on Nov 25, 12 2:34 PM
YES! I guess I needed to do a shutdown/restart which I did not do last night. When I finished playing last night, I shut down the computer. Just now when I fired up the computer, the fish bones moved with no problems.

Thank you for your suggestions.

I'm a happy camper
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator