Posts created by mamapolo1951

 
 
 posted in Rooms of Memory on Nov 27, 17 3:56 PM
I am using a long-in-the-tooth- MACbookPro- and still getting the 'game unavailable message.'

Am I missing something? is it fixed for some and not others?
 
 
 posted in Rooms of Memory on Nov 23, 17 12:08 PM
Bless you! I wish I were Russian (in this particular instance) so I could friend you!

It blows my mind that people play this and other games, participate in chats and forums and the like and still erect barriers and paint stereotypes.

I used to play bridge on MSN Zone and like you, had beloved friends from many nations, all of whom were unique and all of whom were HUMANS.

Keep being an ambassador. The world needs you and many more like you. I recently read this, a quote from, of all people, Jimi Hendrix.

"When the power of love is greater than the love of power, the world will know peace."

 
 
 posted in Rooms of Memory on Nov 2, 17 6:41 PM
Is it only me, or is this quest extremely difficult,relatively speaking.

Due to an injury, i'm in a chair or in bed, and i have been depending on ROMs to keep me sane,but now it's driving me crackers. Just collecting the necessary items from friends' places and the phantom conquistador on my place has taken me most of a full day and I'm still 15 items short.

Argh!!!!!!!!!!!!!

Thank you for listening.
 
 
 posted in Rooms of Memory on Oct 21, 17 1:19 PM
Whut?

I don't get it.

I got all the ground(hog) work done - got to the autumn and winter labyrinths, was nonplussed as to how to find them (still am) and finally used crystals to buy the keys.

So now I am mandated to find the spring labyrinth and walk through it.

I dunno where it is. I can't find a clue.

I don't get it.

Whut?

 
 
 posted in Rooms of Memory on Sep 25, 17 8:55 AM
I think this is a technical issue. I was in the process of completing the mission of the Musketeers - I organized the expedition and my friends generously contributed and the expedition was over...except, when I tried to enter the Port Tavern or whatever it's called, I got the 'organize expedition' screen again.

Anybody else have this problem?


Mamapolo
 
 
 posted in Rooms of Memory on Aug 13, 17 12:34 PM
Thank you for saving me from my own dufous-osity.

I have finished the Police Station.

You are my hero.

Thank you, thank you.
 
 
 posted in Rooms of Memory on Aug 13, 17 12:21 PM
I need only the Golden Seal Ring to complete the expedition.

If I get anywhere, I'll let you know.
 
 
 posted in Rooms of Memory on Aug 13, 17 11:52 AM
Just to be clear - I have finished the scene. Lowest time was 1:37. I have finished the scene a minimum of 100 times.

I need only the very last item to finish out, and I just can't get it.
 
 
 posted in Rooms of Memory on Aug 13, 17 10:57 AM
I am on my (I'm pretty sure) FIFTH try to finish the Police Station expedition. My friends have been ever so generous, although I imagine they wonder what I'm doing.

My question is, what am I doing wrong? What's the objective I'm not reaching?

Mamapolo
 
 
 posted in Rooms of Memory on Mar 26, 17 10:51 PM
Nothing has changed on my end, but as of this afternoon about 2:00 pm, I can't connect to Rooms of Memory. The loading bar goes to 89% and sticks - for hours.

Anybody else having issues? I admit to having a dinosaur computer - old MAC - but up till now it's been working great.

Anybody who understands game addiction will know how I'm feeling just now. I know it will eventually pass....

Mamapolo
 
 
 posted in Rooms of Memory on Jan 26, 17 9:50 PM
A friend of mine asks that I send her silicone flints, which she says she can't put on her wish list.

I'm happy to do it but don't know how.

Somebody help? And did I post this the wrong place?
 
 
 posted in Rooms of Memory on Jan 17, 17 9:41 AM
Kind of interesting, actually. My image of chaos is constant crazy motion - can one TAKE a picture of chaos?
 
 
 posted in Rooms of Memory on Jan 16, 17 1:05 PM
Anybody know where to find this little gem? (Other than inside my car)
 
 
 posted in Rooms of Memory on Dec 26, 16 1:13 PM
Thank you, Pufferfish. I might inquire why you chose a poisonous sea creature for your handle, but then, it's probably none of my business.
 
 
 posted in Rooms of Memory on Dec 26, 16 10:39 AM
Dear Fellow Time and Dimension Travelers:

First of all, I hope the merriness of your Christmas will be exceeded only by the excellence of your New Year, bringing exciting new prospects, delirious joy and thrilling good fortune.

I'm still trying to figure out this Rooms of Memory stuff and have a general question. If one does not complete the Christmas tasks by the time this period of opportunity expires, do you not get another chance until NEXT Christmas? Same with Hallowe'en?

I do love this game but I didn't realize it's SO much like life that you never - quite - catch up! And you keep a worried eye on four hundred and seventy two different purses. And hope the elves and their compatriots don't freeze to death before you can get there with the rescue equipment.

Again, the most extraordinary best wishes for your coming year.

Mamapolo
 
 
 posted in Rooms of Memory on Dec 24, 16 2:36 AM
Thank you, Sir.

You are indeed a scholar and a gentleman, not to mention a knight!

I appreciate the information.

Have a wonderful Christmas and a better New Year.
 
 
 posted in Rooms of Memory on Dec 23, 16 9:09 PM
Once you've built the Christmas present artifact, where does it go? I've done about 8 but I can't find them, even though they tease me with the "30 useful items."

Or am I walking right into "You can't open presents until Christmas!" ???
 
 
 posted in Rooms of Memory on Nov 3, 16 6:27 PM
Hello, all:

I, too, cannot go visit my friends. Emotionally, it's no big deal, because I never see them there anyway, but it means my energy drains fast and there's no fix without investing a kazillion dollars.

It's been about three days now since it worked right. I use Firefox on my iMac laptop.
Have good internet connection - Hidden Express works, Cubis 2 Gold works, a word game on another site works, too. One day I did get to about three friends (think that was day before yesterday) but then it hung up on the waiting icon. Once I let it run all night, curious to see if it would connect, but it didn't. I cleared my history, cache, everything recommended.

Also, about three-quarters of the time, when I try to load the game, it hangs up at 89% loaded and will go no further.

Unfortunately, it's a terrific game and I'm hooked. Can anybody help me?

Mamapolo

I figure the game owes me about three days' worth of experience and coins!

I hope.

mamapolo
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator