Posts created by bevaa72

 
 
 posted in Viking Brothers 3 Collector's Edition on Dec 28, 17 1:35 PM
I have Dell XPS with Window 10. I cannot open this game at all. the error message said: Switching to resolution 1920x0 failed, trying lower one
Switching to resolution 1920x0 failed, trying lower one
All resolution switches have failed
Screen: DX11 could not switch resolution (1920x1080 fs=1 hz=0)

So what can I do????
 
 
 posted in Surface: Lost Tales Collector's Edition on Jul 9, 16 4:42 AM
I have Window 10. Every time I get some problem (like glowing stones, placing bird, using staff against crabs, etc.), i had to close the game and went back to continue without any problem. Do I have to do that every problem??? I DO HOPE NOT!!
 
 
 posted in Sweetest Thing on Oct 6, 15 6:11 AM
This is a cute game but..... there are some issues to deal with.
1- Blank goal was given and we had to figure out what is the goal?
2- Ants? There are no ants to deal with until level 3 or 4?

This game should have a test before releasing to us. I would like to buy this for my grandkids but only after these issues are dealt with first.

I would recommend this game to younger kids and young minded grandmas!
 
 
 posted in Redemption Cemetery: Clock of Fate Collector's Edition on Sep 26, 15 6:11 AM
I downloaded the game with no problem, BUT.. when I played, the screen went black!!! I have windows 10 in my DELL XPS. I shut it down and played again.. same problem. I undeleted the game and reinstalled. same prooblem.
 
 
 posted in Gnomes Garden on Aug 19, 15 11:09 AM
Tried to find more jewels for tree growing, but WHERE???
 
 
 posted in Brownies on Jul 15, 15 7:30 AM
[Removed by Moderator]
 
 
 posted in 12 Labours of Hercules III: Girl Power on Jan 9, 15 1:49 PM
I tried to build a bridge to the island with tooth and steak, but i discovered that i am 3 wood short... where can i find them? trees that had to pay with food are gone.
 
 
 posted in Forgotten Kingdoms: Dream of Ruin Collector's Edition on Sep 22, 14 9:35 AM
I am deaf. This game is NOT for deaf people to play. I understood there are talking but no subtitles. Not very user-friendly, either. Hard to figure what is the next step to play!!! Hate to click on GUIDE. Definitely NOT to buy!
 
 
 posted in Entwined: The Perfect Murder on Sep 2, 14 8:59 AM
No need for leg work. Just head and arms need to be moved.
 
 
 posted in Insane Cold: Back to the Ice Age on Aug 29, 14 6:39 AM
This game is one of few games I wish I didn't buy. There is no map to jump. The developer needs someone who can help him with English. Tired of using hints too often. The ending of the game needs to be fixed. The hints gave us wrong directions. I don't recommend this game unless they fix the problems.
 
 
 posted in Weather Lord: In Pursuit of the Shaman on Aug 18, 14 4:36 AM
Never mind! I should read the building choices more careful!
 
 
 posted in Weather Lord: In Pursuit of the Shaman on Aug 18, 14 4:27 AM
Sun tower??? where do I build it?
 
 
 posted in 12 Labours of Hercules II: The Cretan Bull on Jul 22, 14 5:23 AM
Or, at the front menu page, click triangle shaped object at the lower right corner, unclick the "game cursor".
 
 
 posted in 12 Labours of Hercules II: The Cretan Bull on Jul 22, 14 2:40 AM
Level 1.5 - puzzle is on top of mountain at lower right corner
 
 
 posted in 12 Labours of Hercules II: The Cretan Bull on Jul 22, 14 2:34 AM
I understand that there is a place that offers a list of puzzles. it is in http://forums.bigfishgames.com/posts/list/289249.page but I dont think it is complete?

If you prefer to find it yourself, that is fine with me. I wanna to save my eyes!!!
 
 
 posted in 12 Labours of Hercules II: The Cretan Bull on Jul 22, 14 2:30 AM
it is very difficult to find it. Let me give you a hint: underwater!
 
 
 posted in 12 Labours of Hercules II: The Cretan Bull on Jul 21, 14 11:23 AM
I had to replay just to find those almost impossible pieces. Only 2 levels are the good examples. Level 3.3 and 3.7... where are they???
 
 
 posted in Paranormal State: Poison Spring on May 6, 14 8:29 AM
Windows 7 Home x64
Intel Core 2 Q8300 @ 2.50 GHz 2.49 GHz
6.00 GB RAM
2 TB hard drive (1.37 TB free)

Error message: "error this is "null"" and then asking if I would like to debug. No matter whether I click yes or no it goes right back to the black screen with the debug message. sigh.. I was about to enter the excavation site next to Forester 's Lodge, the picture started to fuzz and got that message.

Any suggestion?
 
 
 posted in Farm Mystery: The Happy Orchard Nightmare on Apr 30, 14 3:43 PM
I just say I hate it. Not user friendly! No help or map! Terrible Help guidance!
 
 
 posted in Gardens Inc. 2: The Road to Fame on Mar 24, 14 4:40 AM
I love it!!! Great improve from the first game. Can't wait to finish it. Thanks!!!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator