Posts created by 88blyth

 
 
 posted in Vacation Adventures: Park Ranger 5 on Nov 15, 16 1:34 AM
love this series, played demo for 5 minutes..just to make sure it worked ok..then i hit that "buy" button.... same things to do as usual but i dont care..i love it...thankyou big fish
 
 
 posted in Clutter VI: Leigh's Story on Nov 8, 16 12:58 AM
YAY ....love this, i have all the clutter games....endless fun.... thankyou
 
 
 posted in Queen's Quest 2: Stories of Forgotten Past on Oct 19, 16 4:20 AM
hi fishies..well i played the whole demo, which is something i dont usually do, i enjoyed it, the colours are bright,..i dont play with sound so i cant comment on that, i will more than likely buy this game, i will leave it to other fishies to do a better review than me...the hint system worked well and i didnt have any tech issues
 
 
 posted in Surface: Lost Tales Collector's Edition on Jun 16, 16 2:20 AM
THANKYOU. roxycavalier..code worked for me
 
 
 posted in Invasion 2: Doomed on Jun 6, 16 8:45 AM
same as andymac50... black background, cannot see the game...windows 7
 
 
 posted in Backstreets of the Mind on Jun 1, 16 1:52 AM
[Removed by Moderator]
 
 
 posted in Big City Adventure: Shanghai on Nov 4, 15 4:28 AM
[Removed by Moderator]
 
 
 posted in League of Light: Silent Mountain Collector's Edition on Sep 10, 15 3:09 AM
hi fishies...game froze when trying to exit the barn, had to ctrl alt delete to get out of the game....
windows 7
 
 
 posted in Dracula's Legacy on Aug 11, 15 2:23 AM
same here, hint button suddenly stopped working
 
 
 posted in Dracula's Legacy on Aug 10, 15 1:35 AM
windows 7
cant even get the game to download, keeps coming up as ...failed.
i have tried about 10 times so far
 
 
 posted in Invasion: Lost in Time on Aug 7, 15 12:56 AM
thankyou
 
 
 posted in Invasion: Lost in Time on Aug 4, 15 1:06 AM
hi fishies, anyone know the appox length of the game yet?
thankyou
 
 
 posted in Invasion: Lost in Time on Aug 3, 15 1:54 AM
thankyou..yes, i did manage to complete it eventually
 
 
 posted in Invasion: Lost in Time on Aug 3, 15 1:12 AM
hi fishies, i am on the trial period, and on the book puzzle, i have spent about 20 minutes trying to get the books in order....there is not a skip button and, for the life of me i cannot complete it...any help?
thankyou in advance
 
 
 posted in Sacred Almanac: Traces of Greed on Jul 26, 15 1:25 AM
ok...first 3 minutes into the trial, i pick up the hooks off the table to use with the screen.......no hooks in inventory....good start!!!
windows 7
 
 
 posted in Beyond: Light Advent Collector's Edition on Jul 25, 15 1:28 AM
cannot even get the game to play, alli get is a black box, but it is still counting down the time...windows 7
 
 
 posted in Vacation Adventures: Cruise Director 2 on Jul 2, 15 1:53 AM
hi everyone, i uninstalled and re-installed 3 times...third time lucky!!, the game now plays
i DO hope everyone else has luck with this game
i played for ten mins, then stopped then played again and it is fine still, off to buy now [ fins crossed]
i also had the little oblong box appear but that disappeared and the game played
 
 
 posted in Vacation Adventures: Cruise Director 2 on Jul 1, 15 1:32 AM
same problem here, avast is blocking the game, no problem with the first game, downloads fine but will not play...HELP

i have even unintsalled and re installed game manager to see if that helps, but it did not
using windows 7
 
 
 posted in Vacation Adventures: Park Ranger 3 on Mar 24, 15 1:43 AM
hi everyone, i LOVE this series of vacation adventures, demo-ed for 20 mins, stopped to buy,
enjoy your day
 
 
 posted in The Curse of the Werewolves on Dec 19, 12 3:24 AM
thankyou

 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator