Posts created by forensicMD

 posted in Mystery Seekers: The Secret of the Haunted Mansion on Mar 10, 11 11:25 AM
I am having a ball doing this game. I have hit a major problem for the first time. I am not asking for help, merely saying I am stuck. I have not really been stuck before except that finding gems and keys can be quite difficult. The picture puzzles are difficult, but if you look carefully they all have tattered edges or have borders and using those as guides makes putting the puzzles together much, much easier.
 posted in Maestro: Music of Death Collector's Edition on Feb 18, 11 3:01 PM

 posted in Maestro: Music of Death Collector's Edition on Feb 18, 11 3:00 PM

 posted in Reading the Dead on Feb 14, 11 7:03 PM
Count me as someone who did not finish the demo. The game had horrible graphics and even when I knew what I needed to click on, the game would not let me on too many occasions to count. This game is truly bottom of the barrel. I hope something better is in the offing before the week is out.
 posted in Stray Souls: Dollhouse Story Collector's Edition on Feb 11, 11 4:13 PM
The following comments do not refer to anything already written in this thread. Many gamers are faster because they are very good gamers, read more quickly, are excellent at doing the puzzles, or as another example, on some games folks with a music background have a bit of an advantage. I read various numbers which many times influence whether to get a CE or wait. However, there are times when my credulity is stretched beyond the breaking point. Everyone good at games is saying it takes, as an example 3-4 hours to complete a game and then there is always someone who has completed it in 1 hour and 15 minutes, stating he or she had read all the dialogue and done all the puzzles!!! I do use the figures listed by the most folks as a realistic length of time. Then I sit and laugh about some posts I have read. Keep those accurate figures coming as many of us use them as a guide to whether to buy or not. Thanks
 posted in The Secret Legacy: A Kate Brooks Adventure on Jan 30, 11 2:29 PM
I downloaded this game to give it a try despite the negative reviews I was reading. Once it had downloaded, I immediately got a message that my time had expired. I might have tried this game before and forgotten, but the way it was presented on the home page, I thought it was a new game. Has it been available for play before or did I just get a message I should not have gotten?
 posted in Mishap 2: An Intentional Haunting on Jan 28, 11 3:40 PM
I played the first section of the game, but I find it to be tedious and the instructions are unclear to me. Maybe I am the problem and the game isn't! I won't be buying this one.
I bought the CE of 13th Skull. All was fine until two needed objects that had been in my inventory were gone. I had bought the game on Dec.23. BFG was great, but we never arrived at a really good answer as to what had happened. I finally opted to get a refund as I was afraid the glitches might still be there and I was not enthusiastic about starting over anyway. However, now I am playing the newest CE, Shadow Wolf. I went to the forum where someone had asked whether folks would recommend Shadow Wolf or 13th Skull. There were so many positive points raised about 13th Skull, that I am reconsidering and may buy it again. But the big question remains. Are there any remaining glitches or not? (Funny thing happened. I had typed gung followed by an "h" and an "o" and I was not allowed to use the second half of the saying. Pretty funny, I think!)
 posted in The Stroke of Midnight on Jan 26, 11 7:24 PM
Try saving the post for the last thing to be done. When you have it in hand, I believe you must move it "behind" the place on the piano where it seems to go. Move the pin back farther and not on the spot where it belongs, to get it to drop into place. It seemed like I spent an hour on this one thing. I hope my description helps. It is difficult for me to describe what you have to do. It can be done though so keep trying!
 posted in The Stroke of Midnight on Jan 26, 11 7:11 PM
You have to click on the lid and it will move and slam loudly if you don't get the stick in!
So, quickly click on the lid and then on the post (which should be there at the piano as it does move to the piano so it is available to use.) Then you should be able to go on from there. Good luck!
 posted in The Stroke of Midnight on Jan 26, 11 1:58 PM
I am really stuck here and hope someone has an idea to help me. I picked up the whisk broom off the shelf in the armory hall. Not realizing for what it was needed, I continued on and did something else in the hall. Now I need the broom to clean the room. It is visible, although very tiny, there on the shelf, but I cannot seem to get closer to those shelves so that I can make it larger so that I can click on the broom. I have tried to click on it when it is very small and the game won't allow me to pick it up then. What do I do? All suggestions are gratefully appreciated.
 posted in The Secret Legacy: A Kate Brooks Adventure on Jan 23, 11 7:47 PM
My hour was just up and I am in her Grandmother's bedroom. I do like the game although I could live without the silhouettes, but am hesitant to get it because others have thought it too short. I guess I'll decide tomorrow. It is getting fairly late so I am going to quit. Even though the screen did not indicate that my prior post made it to the board, it did. Sorry for the repetition.
 posted in The Secret Legacy: A Kate Brooks Adventure on Jan 23, 11 1:23 PM
I am unhappy to learn that the game is short. Perhaps some of us, and I include myself, will take longer than the really good puzzlers. I might get it anyway, as I do like the game with the exception of the silhouettes which have never been something I liked. They seem much easier than others I have solved, or maybe I am finally getting better at doing them!
 posted in Spirit Seasons: Little Ghost Story on Jan 22, 11 3:15 PM
This seems, from the play I have done, that it is mainly hidden object, which I really like. Of late, the hidden object games seem to be only a part of what is more of an adventure game. I am most interested to find out the length of the game if anyone knows. Thank you.
Thanks for the suggestion, but I did scroll through the inventory and still no scissors and no key. I might add that the box in Magnolia's bedroom is still there, but the left side of the box where the key had been is empty! The right side still shows the newspaper clipping.
I had the key from the puzzle box which I had opened the first time I was in the room back in the beginning of the game, but it is no longer in my inventory. Also I do not have scissors to get the fourth key in the foyer. I did have scissors at one time, can't remember but must have used them and they did not go back into inventory. In other games these types of problems tended to somehow correct (another pair of scissors in some scene, for instance) but what do I do? Must I start over? I hate to, but having paid for the CE, I just can't give up, although I dread starting all over. Does anyone have any suggestions?
I am amazed how many folks dislike this game. I happen to think it is the best one yet! It just goes to show that is why there are different flavors of ice cream, doesn't it? I thought the actors were very good. The clues were there and you could choose whether to play blindly or use the hints available. I certainly disagree with the statement that this was thrown together between Thanksgiving and Christmas (I think that was what was written) as this clearly took a lot of time and effort. Big Fish is to be congratulated for continuing to vary the games, locales and story lines and I am certain tremendous effort went into creating the finished product. I did not like Madame Fate and was not crazy about Dire Grove, although it obviously took tremendous effort also. Still, I would recommend those games to folks who love computer games, just as I will recommend this one. I certainly strongly disagree with the statement that it is the worst MCF ever!
I have now gotten the parrot from Cotter's wife about 10 times, but I cannot keep it in inventory. It disappears as soon as I get to the graveyard on my way back to use the parrot against the snake. I apologize if this has already been asked and answered but 60 some pages of comments are more than I want to read through if I don't have to. Thank you in advance if you can help me.
 posted in Drawn: Dark Flight ® Collector's Edition on Dec 19, 10 4:35 PM
I bought the Collector's Edition of this game without playing the demo first, something I really have only done about three times since I have been downloading games. Wouldn't you know that the game appears and I can click play, but then the entire screen goes black and I cannot do anything except hit control and escape. I am really frustrated because these games are more expensive and this was my first try at a non-MCF CE. I guess I will contact tech services because I have no other idea about what to do!
I am with you waiting for multiple games, all that you listed soblessed 57, as I am unable to download any of them. Every one gives me a message of error downloading. I have tried repeatedly and have had no luck. I guess tomorrow I mist contact tech services, but problems with four games suggests to me some systemic problem.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator