Posts created by elmira78

 
 
Regarding the monkey game - I had the same issue of not being able to move. I finally realized that it's because if you are able to jump an opponent's piece the game won't let you make any other move until you do that. It tells you that in the instructions, but I had forgotten it until I played several times. I eventually skipped it also because I couldn't figure out how to win.
 
 
 posted in Dead Reckoning: Snowbird's Creek Collector's Edition on Dec 22, 16 5:57 AM
In the bonus chapter I can't pick up the crate in the warehouse. I've tried all the suggestions posted in the forum for this game, but none of them work. I'm running Windows 10 on a PC with an INVIDIA GEForce video card.
 
 
 posted in Dead Reckoning: Snowbird's Creek Collector's Edition on Dec 20, 16 2:03 PM
I've tried both Bartsister's and bobhillman's suggestions, but I keep getting the message that I need to pick up the man, and it won't pick up the crate. Has anyone else had this issue?
 
 
 posted in Dark Dimensions: Blade Master Collector's Edition on Jun 18, 16 6:29 AM
The number 2 candle on the gate in back of the restaurant doesn't respond when you click on it, so you can't solve the puzzle. All the other puzzles worked fine, so this appears to be a glitch in the game. I'm running Windows 10 with an NVIdia GeForce video card.
 
 
 posted in Imperial Island 3 on May 27, 16 10:12 PM
I got through the main game, to the point where I'd built all the buildings, with only a few problems, but now I'm on Level 237 and the board loads so slowly it's not worth playing. This started at about level 225 or 230 and has gotten progressively worse since then. I am running Windows 10 with a NVIDEA GE Force GTS 450 video card. I've updated drivers and restarted the computer with no effect.
 
 
 posted in Mystery Case Files: Return to Ravenhearst ™ on Dec 5, 15 9:41 AM
I can't make the key in the locksmiths cottage. I have the drawing and the blank key, the pieces are in the correct locations, but I can't access the handle to pull it. Is anyone else having this issue?
 
 
 posted in Clutter V: Welcome to Clutterville on Sep 21, 15 6:41 PM
I haven't had any issues until today. While playing Big and Small Mismatch I tried to use a hint and got an Access Violation error message. I rebooted my computer with no effect.
 
 
 posted in Amulet of Dreams on Aug 16, 15 12:11 PM
I recently installed Windows 10 and now I am asked for a registration key every time I try to play the game, which of course I don't have. I've tried uninstalling the game, downloading it again and reinstalling it but it hasn't helped.
 
 
 posted in Amulet of Dreams on Aug 2, 15 2:30 PM
When I played the HOP in the gazebo at the top of the stairs just after you go through the portal the item list went blank just as I was completing the task for the last item. Now when I go there I get the instructions for the flower wreath. I'm not sure what I was supposed to get from that scene, but I don't think I have it.

This is the second issue I've had of this type this week. I had a similar issue with Maze 360.
 
 
 posted in Maze: Subject 360 Collector's Edition on Aug 2, 15 2:03 PM
I got all the way to the end of the game with no issues, but now the shaman's dreamcatcher won't work on the last sleeping townsperson - the elderly man with a white beard and glasses. I'm running Windows 7 Home Premium with Service Pack 1, 64-bit on a PC with 6 GB RAM.
 
 
 posted in Surface: Game of Gods Collector's Edition on Dec 30, 14 7:27 AM
I have gotten to the ice cave but when I click on the note at the soul vial altar it refers to a plate which isn't there. I've tried exiting the game and going in again but it didn't help. It seems I need this plate to collect the pollen from the flowers that appeared when I collected Tom and Lila's souls. Is this a glitch, or am I missing something?
 
 
 posted in Paranormal State: Poison Spring on Aug 22, 14 4:38 PM
Regarding the map board, you attach maps as you get them, then click on the map for the area you want to go to - the parking lot, the dig, etc. It took me several tries to figure that out.

Regarding the blurred/frozen screen at the excavation pit - did you check to see if you can use one of the paranormal detection tools on it? Usually that blurred screen means you have to use the EVP recorder and go around the scene to find the hidden figures.

 
 
The main game played with no problems, but the bonus chapter has issues, the first being that you don't get the picture or the ingredients list from Andre. Per other users' tips the only way around this is to play the bonus chapter on casual mode. Very disappointing, as all the extra sparkles, etc in casual mode are very irritating to those of us who love a challenge.
 
 
Thanks for tip. However, very disappointed that you have to play in casual mode, as all the extra help is irritating.
 
 
 posted in Nightmare Adventures: The Turning Thorn on Jan 27, 13 8:08 PM
I'm sorry to say that none of the BFG responses so far address the issue that, according to many forum messages, uninstalling and reinstalling does NOT solve the inventory issues. BFG, please read ALL of the responses before posting your standard response that we uninstall and reinstall. In this case, the problem is with the game, and the solution needs to be a fix from the developers.
 
 
 posted in Nightmare Adventures: The Turning Thorn on Jan 26, 13 9:08 AM
I picked up the "A" key, but when I placed it in the keypad it disappeared! Not in my inventory, or on the keypad, or on the clipboard where I first found it. Also not anywhere in the scene. Judging by the other posts losing inventory items is a common problem. Since there's only 5 minutes left in my trial it's not worth uninstalling and reinstalling. I won't be buying this game until an update that fixes the glitches is available.
 
 
 posted in Exorcist 2 on Dec 30, 11 1:24 PM
I have the opposite problem. I used the torch to light the fire in the fireplace and got the hot coal, but no matter where I click on the snake or the fountain I can't get it to light. Is there a special place you have to click?

Also, is your torch gone, or did it just go out?
 
 
 posted in Bluebeard's Castle on Nov 21, 11 1:46 PM
I'm having trouble figuring out the date for the tombstone to unlock the unicorn and get the last key. I searched the game and tried all the dates I found, but none worked. Any suggestions?
 
 
 posted in Bluebeard's Castle on Nov 21, 11 1:42 PM
I'm having trouble figuring out the date for the tombstone to unlock the unicorn and get the last key. I searched the game and tried all the dates I found, but none worked. Any suggestions?
 
 
I've had the same problem. The first time I got to the right place with the metal detector I was able to dig, but all I got was one of those hidden gold pirate cards, no coins. Now the metal detector keeps going off in the same place, but it won't let me dig. Posted the problem in the tech problems thread (page 4), am waiting for feedback.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator