Posts created by jpabich

 posted in Big City Adventure: Rome on May 1, 17 10:14 AM
My game also shows up in a small "post-card sized" box. I am also on Windows 10. I have no problems with any of the other BFG games, so I'm assuming this is a problem with the game.

I would have usually just purchased this game without the demo, as I have all the other BCA games. I'm glad I didn't on this one.

Please fix this ASAP so we can go on this Roman adventure!
 posted in Cursed House 3 on May 25, 16 11:26 AM
I am experiencing very slow and sluggish mouse movement in this game that I don't have anywhere else or in any other game. I would buy it but I cannot take the mouse moving at a snail's pace.
 posted in Monument Builders: Rushmore on Apr 24, 16 10:49 AM
Devs -- Level 24, Miners is spelled wrong. It is not minors, its miners. Just before level 26, typo in newspaper. Mount Rushmore, not Mont Rushmore.
 posted in World's Greatest Places Mosaics on Mar 17, 16 8:30 AM
I'm playing in casual, usual mode and I keep seeing this timer thing pop up in the left corner counting down. There is no explanation of what it is and what I'm supposed to do with it. Do I have to finish the color by the time it runs out? I thought there was no timer in casual mode. Do you get extra points or something while it is counting down?

I gave it two tries in the demo, but I cannot believe that this will be a fun and relaxing gaming experience for me.
 posted in World's Greatest Places Mosaics on Mar 17, 16 8:25 AM
Thank you for that suggestion. When I started seeing the shapes on the third grid I was completely frustrated.

I'm still not sure I want to purchase it though, even in the usual mode.
 posted in Imperial Island 3 on Feb 26, 16 1:33 PM
We need a bug fix for this game. It continues to freeze up. I've uninstalled and reinstalled, but I keep getting an access violation and cannot continue.

Don't the devs read these forums? It is very irritating that I cannot continue with this game that I have purchased.

I doubt it is my equipment or OS as I have 100s of other games from this site where I experience no problems.
 posted in Lost in Reefs: Antarctic on Jan 24, 16 12:27 PM
I haven't seen any instructions at all on how to play or how it calculates that you get to three stars. I've been trying to watch the counts at the top change when I make a match, but I would love to know what my goal is so I can try to achieve it.

I'm still in demo mode, but if I can't figure it out before it's over, I won't buy this game.
I don't think the bonus levels have a puzzle piece.
 posted in Treasures of Egypt on Dec 1, 15 11:22 AM
I agree with the other posters. Graphics are really old school, but I could actually overlook that if there was some type of goal to the game. I didn't see anywhere that we were building a city or doing anything other than just clearing game board after game board. And it was not challenging at all. I never had to create a strategy to clear tiles. No buy for me.
Thank you cielle! I finally got it. And,I did figure out that I couldn't always "page" through the artifacts unless I clicked on the very edge of the arrow where you choose your three artifacts. When I just clicked on the glowing blue arrow, it wouldn't go to the next page. If I just barely click on the point of the arrow it changed.
On Level 17, the strategy guide says to use the Magician's Hat power up as one of your three choices to beat the level. However, I do not have the Magician's Hat. I didn't have it before Level 17 and I have finished the 30 Standard Levels and I still don't have it. I'm playing in Expert Mode.

Can anyone explain this or let me know why I might not be seeing the Hat? Thanks in advance!
 posted in Incredible Dracula: Chasing Love Collector's Edition on Oct 29, 15 6:23 PM
There is also a strategy guide with this game. That might help you too.
 posted in Forgotten Tales: Day of the Dead on Oct 21, 15 3:56 PM
When I played Chapter One, I did get the lollipop, but the book did not register that I had. So, I played Chapter One two more times and I never got the lollipop again.

Now I have a page that says Chapter One - Find Valencia's Lollipop on page 7 of the book.

Anyone else have this problem?
 posted in Forgotten Tales: Day of the Dead on Oct 20, 15 10:07 AM
Me too. Stuck on level 18. After I fulfill the goal and clear the cards in round 1, it doesn't go to round 2. Help! I want to keep playing!!!

I did click on the book when it flashes too. That doesn't seem to do the trick.

EDIT: Okay, I got out of the game and got back in and I was able to go to round 2 and finally finish that level. I would hate to have to do that on a regular basis though.
 posted in Monument Builders: Golden Gate Bridge on Oct 7, 15 2:17 PM
I agree with you. I'm frustrated because there is no way that I can see to get three stars per level without using all the bonuses which cost 9 jewels the last half of the game. So it's a no-win situation. I'm already going back to the early levels just to get enough jewels just to use auto-delivery, which I consider to be a must-have bonus.

I'm on level 31 now and I haven't gotten 3-stars on any level since level 18.

Can't we just buy jewels? Are we just supposed to keep playing level one over and over to amass enough jewels to get through the game? Arrrrrghhh!

 posted in Monument Builders: Golden Gate Bridge on Oct 6, 15 12:42 PM
I usually just buy these Monument Builder games without even trying them because they have been so consistent and fun. However, the last edition, Big Ben, had no auto-delivery feature (impossible to get 3 stars on all levels), so I was skeptical about buying this one without confirming that feature. Luckily, early into the game I found they had put the bonuses back in to purchase with jewels at the beginning of each level.

Now I will definitely buy it!

 posted in Hotel Solitaire on Sep 12, 15 2:04 PM
I'm having the same problem on room 105. I'm trying to figure out how to get more shuffle bonuses. I see that if I remove cards really fast, I get one when I fill up the left thingy.

I'm now wondering if I can replay the earlier rooms to get more shuffle bonuses. I'll try it.

Okay that worked -- I went to the first floor and build up my shuffle bonuses to 9 and then I went back to the room I needed to complete. I finally got past that level.

I hope that helps. Good luck!
mkastor wrote:Same as the first ones. Collect and build. Nothing new . We finally get a TM game and it's an overpriced Collector's Edition.

I agree. The only Extras are some wallpaper scenes and a guide which you don't really need. Why in the world would they think this is a CE?
 posted in 12 Labours of Hercules on Jun 21, 15 12:43 PM
I think I finally figured this level out. To get three stars, you need to eliminate all of the enemies before your timer hits the arrow. Even though I couldn't hit the large head with only one shot, I just kept hitting it until it was gone and before the timer went to two stars.
 posted in Viking Saga on May 31, 15 1:35 PM
Adding that third worker at the beginning made a huge difference. I made 3 stars with loads of time left once I did that after a few frustrating tries using the extra worker bonus. Good luck!
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator