Posts created by LadyBeth111

 posted in Ciao Bella on Oct 19, 16 9:40 AM
Hi! This is my third time through Ciao Bella. When I've started level four this time, I'm not able to get into the church at any point of the level. (It's a key part of the plot to repair the roof, etc.) It worked fine all the other times I've played it.

Any ideas how I can get past the glitch? I've restarted my computer, reopened the browser and game manager etc. I'm using WIN7 and it's worked on this pc before.

Thanks for any troubleshooting tips!
 posted in Farm Up on May 26, 14 7:37 PM
InterwebUser wrote:Thanks for the new update! I'm enjoying the new quests.

For some reason, the factories (milk factory and canned food factory) don't recognize that I have blueberries in my inventory so I can't make blueberry yogurt to finish the quest.

I am using the PC version on Windows 7.


I too am having the similar issues with making "blueberry jam" while using Win 7 & on a PC. I'm on level 30 and have recently upgraded to the newest version.

Has anyone found a workaround or effective bug solution?
 posted in Farm Up on Apr 26, 14 5:17 PM
Hi there!
Yes, I came looking for info about the fishing pond too. I'm on level 29 and wondering when we get to do the fishing quests. Thanks for posting your question! Maybe someone will help us...
 posted in Hidden Mysteries: Buckingham Palace ™ on Nov 9, 08 5:22 AM
The Buckingham Palace has a good storyline and graphics. However, there's a glitch in the scene with the "gates". There were two pocket watches to find and only one on the board. I tried to get help for the second one and it would not allow any clues. I also tried "rolling over" the board in case I needed to use a piece from the inventory. Nothing worked. I had twenty two hint credits left.

Overall the game is fun, but I had to quit 15 minutes before the trial was over. (I've deleted it now)
Thank you!
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator