Posts created by pysanky13

 posted in Lost Artifacts Collector's Edition on Oct 25, 17 6:46 AM
It just appears and runs around through the paths and leaves...doesn't seem to do anything. I'm on 44 and have seen it a few times. thanks. barb
 posted in Lost Artifacts Collector's Edition on Oct 25, 17 6:42 AM
wouldn't these be the men that wander in and steal your items?
 posted in Lost Artifacts Collector's Edition on Oct 25, 17 6:37 AM
there are several ways. your question is too vague for a definite answer. boards can be had by increasing the level of the workshop, chopping log barriers, and as a gift on altars if you have them. You may need to restart and not upgrade your base hut until you have a wood shop to replace the boards you use for an upgrade. hope this helps you out.
 posted in Lost Artifacts Collector's Edition on Oct 22, 17 3:41 PM
Thanks! that worked for me also. I forget that once you reach a goal, it is cleared and you can use those resources. Just made 3 stars. barb
 posted in Joan Jade and the Gates of Xibalba on Apr 20, 17 6:24 PM
I closed and restarted the game. the snake was gone and the handle was showing. sorry.
 posted in Joan Jade and the Gates of Xibalba on Apr 20, 17 6:21 PM
I think I am at the end of the game. the walkthrough doesn't list anything else to do except use the door handle. I don't have one. and at the bottom of the screen is still the snake as if I was still in the mini game though there is no Finish. if I click on the question mark, which gives you want to do in a mini game, I get the voice bubble from the beginning of the scene. It will probably be worked out if I did the game again but after going all the way through it over 2 days in my spare time, I don't really want to go through it yet again so close to the end. no one else seems to have had this problem.
 posted in Dark Parables: The Little Mermaid and the Purple Tide on Feb 26, 17 7:14 AM
I don't think so; it's not really an 'add on' type of upgrade.
I've only just started this game, and have 6 dark parable games so far. I would just like to say THANK YOU for the jump map! this is the first one I found it in, although the others did have helpful maps. I am not buying them in order and all are not CE, which I usually get. So far I like the game as well as any of them.
 posted in New Yankee in King Arthur's Court 2 on Feb 20, 17 5:24 PM
I realize this is an older game but it's new to me. Several levels have workers or the Knight frozen throughout the game and unable to continue. Level 32 needs three more workers after the other achievements are met (food and gold). There are no blocked workers and the houses cannot be upgraded so where can I get the additional 3 workers? TIA barb
This is very involved with rabbit holes, not my favorite, and they are switched from being laid out like where they go. One thing that helped was realizing that you do not need to bother with the elephant at all. The guide has you leave one cabin alone on Farm island. This can be the one in the swamp so you can skip the elephant all together.
I had to play twice to finish with 3 stars as I got a bit confused with the rabbit holes and playing with the elephant took up valuable seconds. it may help someone.
To get the 300 happiness score, you must do one of two things. The easiest is to be sure to build the sawmill by the beehive as it will not affect the happiness score. If you build the market by the hive, then you must pay off the pirate and build the beehive to get the happiness score for that cottage.

In the walk through, they do not say this specifically so you may make the same mistake I did and put the market on the bottom which you destroy and replace with a cottage.

Not a big deal but it does make a difference.
windows 7, 64 bit. no issues running any other games. No problems until level 4.10. I finally realized that the gold mine is not being picked up. The check mark is there with the cursor bubble saying 'on the way' but it is stuck and no workers come to it. I was able to pick up the single coins but once I upgraded the mine to 2 coins, they were never picked up. I also upgraded to level 3, and the 3rd coin appeared on the stack but, again, it was never picked up. The level cannot be finished without gold and I have already picked up all available from the dice.

Since this has not been reported, I am going to restart the level and see if it happens again.I am hoping it is just a minor glitch in my game play because otherwise everyone would be screaming! thank you. I will update if I find that the problem has cleared.

UPDATE: all worked fine after I restarted the level.
 posted in Dream Vacation Solitaire on Sep 12, 16 1:21 PM
I would like to request an Android version of this game. It is my go-to game and the only one I have found with the particular game play in their Australian solitaire. Other solitaires have something called Australian Patience but the game play is different. I would gladly buy this game for my tablet. I got the pc version with my initial signup for AT&T when I moved. Thank you. barb
 posted in Panopticon: Path of Reflections on Aug 25, 16 12:07 PM
I didn't find it at first either so I just 'x'ed out. on the top left of the screen, is a little scroll-that is actually the bottom of the menu tab. Just put your cursor near the top left corner and it should come down. It stays up out of the way.
tech support is always very helpful.
I agree. This is so annoying. I understand if there has been a controversy or if a thread is many years old but honestly, it seems the moderators do not want any activity even a few months old. The advice is always to start a new thread. sometimes you can find help by reading the locked threads but so many of the really good fishes watch to see if there are new questions and are willing to answer in an old thread. I don't understand it at all.
 posted in Big City Adventure - San Francisco on Jul 31, 16 10:55 AM
Several levels with the match game are horrific because of the placement of blank areas. level 54 took me 15 attempts to pass and level 58 is going on 18. I do realize this is an early game but, except for this roadblock in the game play, is a terrific game.

None of the other city games have this problem so I assume they learned from the first game. An update would be a good thing to have since it is a popular game. But if this is the first game someone tries, they would never buy any others.
 posted in Big City Adventure - San Francisco on Jul 31, 16 10:35 AM
just keep trying. I have done over 18 tries before passing but this is the only BCA game like this; all the others are much better.
 posted in Big City Adventure - San Francisco on Jul 31, 16 10:33 AM
none of the others are like this. it seems they learned a great deal from this one and added even better graphics, much better puzzles, and did away with this annoying match one. I have 15 plays for one round and at 18 for another. I came to the forum to see if there was an update but saw this first. I have all but 4 of the big city adventure games and this is the only one like it. you will love the others.
 posted in Hidden Expedition: Midgard's End Collector's Edition on Jul 24, 16 7:36 PM
you don't. that's the end.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator