Posts created by Kittyluvr22

 
 
I am at the forests' edge and need to place the statues to get the last piece of the hunter's horn, . . I have tried every placement possible, but I just get a thunking sound and the statue goes back on the ground. HELP!!!!
 
 
 posted in Laruaville 4 on Dec 15, 15 3:43 PM
How can I get rid of the three blocks at the top of the board? I have tried everything I can think of, and the help guide wasn't at all helpful on this problem. Any suggestions?
 
 
 posted in Laruaville 3 on Dec 2, 15 3:26 PM
I am having the same problem, and I am getting completely frustrated. I can get the fire down to the blocks at the bottom, but how do I break the blocks to get the ice coins? And how do I match the items on the sides behind the fire?
 
 
I also have several that will expire soon, and will give them to someone who wants them.
 
 
I also have several that will expire soon, and will give them to someone who wants them.
 
 
 posted in Witch's Pranks: Frog's Fortune on Jul 9, 14 6:22 PM
I've been reading the comments here, and like most of you, I am having the same problems with the floating cursor, delays between scenes and the game crashing. HOWEVER, I also downloaded the Platinum edition of this game from another game site and had the exact same issues, so I am prone to think it's an issue with the game and the developers, rather than BF. Too bad, though....it seems like a really good game.....cute, whimsical, and just challenging enough to be interesting. I also love to hear the froggie princes trying to talk. I don't know how the developers ever came up with those sounds, but they're adorable. Sigh.....what a shame. It could have been so much fun.
 
 
 posted in Mysteries and Nightmares: Morgiana on Jul 9, 14 1:01 PM
I have everything for the wand of fire except the gold. I have backtracked everywhere, the map isn't giving me any clues and the hint is virtually useless. HELP!!!
 
 
I am in the lab trying to make the antidote, and it appears that I have all the ingredients according to the recipe, but it won't let me make anything. It just keeps saying I need to find all the ingredients. What am I doing wrong?
 
 
 posted in Plumeboom: The First Chapter on May 5, 14 9:59 AM
I love this game, but I hate this game. My biggest objection, like you, is having to go back to the beginning if you lose all your lives. I have started this game over from the beginning so many times, I can almost play it blindfolded. I can agree with going back to the beginning of the level you are on, but the way this is set up.....no way!!. I FINALLY made it to level 22, then lost all my lives and now have had enough!! I am going to delete the game and go on to something a bit less aggravating, and will probably not buy another game from this developer . It's just TOO much to keep playing from the beginning over and over.
 
 
 posted in League of Mermaids on Apr 14, 14 6:03 PM
How can I get the green balls under the wheel, and the aqua balls in the bottom left pocket? The wheel only turns clockwise and nothing I have tried works. HELP!!!
 
 
 posted in Fear for Sale: Phantom Tide Collector's Edition on Apr 5, 14 12:51 PM
I'm having the same problem. I am now in the process of uninstalling the game, then will try to reinstall it to see if that helps.
 
 
 posted in Atlantic Quest 2: The New Adventures on Mar 8, 14 1:22 PM
What are we supposed to do on this level? There are falling tiles in the center and we are supposed to match tiles quickly to wake up Zombie fish. I have been matching tiles for a LONG time, but nothing seems to be happening. Apparently the zombie fish swim across the board and leave dirty tiles, but I haven't seen one yet...just falling tiles. What am I missing here?
 
 
 posted in Nevertales: The Beauty Within Collector's Edition on Dec 2, 13 8:35 PM
I'm having the same problem, and have also followed the directions in the guide with no luck. Wouldn't you know it...the one type of game I really HATE and apparently you can't skip the darned thing. So, I'm stuck and can't go any further.
 
 
You will need the fire for the Sun emblem that goes over the door in the temple. Put it in the fire until it glows, then place it in the slot over the door. After that you can water the plant underneath it.
 
 
 posted in Untold History: Descendant of the Sun on Jul 16, 13 5:54 PM
I don't know...I'm hoping someone knows the answer. Even more I'm hoping it's not one of those wierd glitches where you have to reinstall the game and start over.
 
 
 posted in Untold History: Descendant of the Sun on Jul 16, 13 12:08 PM
I used the garden shears in the swamp to cut the leaves I needed to get past the quicksand. Now, I'm at the wood nymph who is covered with vines. The walkthrough says to use the garden shears to cut the vines, but I don't have the shears anymore, and can't find another pair.. HELP!!!!!
 
 
Go to the tree with the honeycomb, where you used the twigs and pointed sticks to start a fire. Put the sun emblem into the fire until it glows. Then you can put it over the door and water the plant.
 
 
 posted in Christmas Tales: Fellina's Journey on Dec 26, 12 10:46 AM
Same thing happening to me...no Santa's star. Like you, I really don't want to start over, but I have been enjoying the game and DO want to finish it. Oh well.
 
 
 posted in Grim Tales: The Wishes Collector's Edition on Jul 19, 12 8:28 PM
I love this game, but my comment is atually a reply to cbtx's remark about the kitten. When I played his, my own kitten was asleep on the desktop in front of the keyboard. It took me several minutes to realize that the purring I heard was NOT my own little angel (?) Very realistic, and a really nice touch.
 
 
 posted in Titanic's Keys to the Past on Jul 18, 12 10:57 AM
I have to agree with Valdy......bad game. I thought I might buy it to get the extra game punch, but this game is not worth it, even for that. The graphics are nice, but that's just not enough to carry the game. Very disappointing.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator