Posts created by sarah451

 
 
 posted in Fetch on Jan 24, 17 7:50 AM
I can shoot the cop robots, but I can't find the "out" button. Is there one? Or am I just stuck there till I get a certain score?

Never mind. My speaker was in front of the x in the lower right corner.
 
 
 posted in Surface: Lost Tales Collector's Edition on Jun 19, 16 6:41 AM
Did anyone rescue Sleeping Beauty and Snow White?

My game didn't. Did I have a huge tech issue, or was that the way the game actually played?
 
 
 posted in Amulet of Dreams on Mar 13, 16 6:32 PM
I'm at the telescope in the desert. I know there is a lens to pick up in the oasis. I saw it while I was there the first time, but didn't pick it up with the other stuff. Now, I cannot get back into the zoom space where the lens is. I've run my cursor carefully and slowly over the entire scene, and the only close-ups I can get to are the tent and the chest/turban.

Also, the hint tells me nothing but, "there is nothing to do here" everywhere I've tried it, not just in the oasis. Also, there is nothing coming up on the map to indicate any location that has a task.

I'm going to send a Dr. Felix to Tech, but I really think you have a glitch here.

Running in Win 7.
 
 
The update is not showing in my Game Manager.
I opened Options, went to the Downloads tab, clicked on Manually, and got the response "No Game Updates Available"

So, where's the file?
Do I have to uninstall, download from my purchase history and reinstall?
If I do that, will I get the new version?
If I reinstall will I lose my progress?
 
 
The only things I can see from the game page descriptions are the wallpapers, strategy guide, and (possibly?) an extra bonus level.

Anything else in CE that's not in SE?

I'm trying to decide if the CE is worth the extra money to me.

Thanks much.
 
 
I know this has been mentioned in this thread before; it also has two other separate threads, but I've yet to see an update for the game to fix it.

In the bonus the key gets lost just when you get everything ready to open the airplane. The only "fix" I've seen is to replay the game and I'm just not going to do that. The game is OK, but not worth doing twice. If you could start over just the bonus, that would be acceptable, but you can't.

I truly expect better from MadHead. They must have bought this from someone else.

I'm not happy about this.

At all.
 
 
 posted in Rite of Passage: Heart of the Storm Collector's Edition on Jan 22, 16 12:37 PM
Add me to the list.
Win 7 Home Premium SP1
I got out of the game, out of BF, and turned off the PC.
Same problem after powering back on and reentering game.

Hey, Devs! Please fix! Can't finish game!
 
 
jazz2451 wrote:I got it! I was rotating the thing five TIMES around, then three, then seven. It's SPACES! Rotate 5 spaces, then back three the other direction, then seven spaces clockwise again.


Thanks so much jazz2451! You are dead on. All of us were probably trying full turns instead of spaces, I guess.

I must be having a "Monday moment."
 
 
 posted in The Happy Hereafter on Dec 1, 15 10:28 AM
I have the wood and the gold.
I have the planks.
I have no clue what the other item is because the stupid chain goes right smack through the picture and I can't SEE it. (Talk about poor programming.)

Can someone please tell me what that item is before I go nutz?
Thank you.
 
 
I'm not all the way through yet, but the only flower matches I've seen thus far were on the little flags in the courtyard. They were all there.

Where was the matching game you had problems with?
 
 
I agree. The devs did a lousy job with this one.

You have to pick up the brush where it rests on the box, nowhere else. Then you have to touch the cursor, not the brush bristles to the paint and the plate.

Very bad alignment made this an unnecessarily annoying and difficult puzzle.
 
 
No, Goodyear, I don't think your eyes are going. I haven't found one card since finishing the demo and continuing in the purchased game. I found one pair of shoes totally by accident.

This is not my idea of a well-executed game. I'm going to have to make a note of the devs involved and think twice before spending money on them again.
 
 
 posted in Claws & Feathers 2 on Nov 1, 15 8:08 AM
Thank you, everyone!

There are several very nice games in that roundup. Not exactly like C&F, but I wasn't expecting there to be.

I very much appreciate all your recommendations!
 
 
 posted in Claws & Feathers 2 on Oct 3, 15 7:10 PM
Other than C&F 1, does anyone know another game like this one?
Match 3, but with goals and puzzles?
I like these two, but haven't seen others much like them.
 
 
 posted in Redemption Cemetery: Clock of Fate Collector's Edition on Sep 25, 15 9:49 AM
I'm a fan of the series. Based on the demo, I'm not likely to buy this one, even on sale.

First off, I like fast hints and skips. My game play; my choices. In Custom setup I have to divide 60 second between the hint recharge and skip wait period. Can't set them both low. I very much dislike that. Probably the biggest reason that I'm unlikely to buy the game.

Second, I don't like having to play sections over again -- even with changes -- because of the clock. I get it. That's the theme of the game. Don't care, I still don't like it. Not my idea of fun.

Third, there's a lot of "cinematics" witch I also don't like. They develop the story, but take away from game play.

Last, I really, really, really hate the achievements that pop out and take up the whole screen. What a waste of my time, and how boring. I'm not a 5-year-old who needs clapping and shouting every time I manage to tie my own shoes. I never even look at the "achievements" in any game unless they are tied to more game play.

Normally, I would buy an ERS game with very little demo play. Not this one. This doesn't even feel like an ERS to me. Did they buy something from another outfit? A startup place that doesn't know what they are doing yet? Perhaps they got in a new head of production? Get the old head back.
 
 
 posted in Brownies on Jul 17, 15 4:07 PM
I've gotten to a level (sorry, don't know which, 3-x maybe) that wants me to clear the rubble from in front of a cave.
It wants a variety of things, including 3 acorns. I've been waiting for several minutes for the acorns to regenerate or something, but it keeps telling me I need one more.
Where are they? How do I know how many I have? They aren't in the list across the top with the food, wood, stone and gold.
 
 
Playing on PC: Intel Core i5-2320, 3.0GHz, 6G RAM, Win7 Home Premium 64-bit, SP1
I've installed the update to this game.

I can't tell you how annoying the cursor is.
It makes no difference if I have "custom cursor" turned on or off. Some things work better one way, some work better the other. Either way, the cursor on the screen looks the same to me.
I will hover over things, they light, but I have to click repeatedly for it to work.
I get into the SG and can't get back out because no clicks register ... anywhere.
I try to click on an item in the inventory, and instead I go back one room because I can't get the cursor to change from the down arrow back to a pointer.
The cursor "wiggles" around when I try to focus on something it as if it were a ball on an elastic string.
The "active" areas on things are not centered. Many times, the cursor is pointing at the center of something — an area of interest, the menu button, the hint button, you name it — and the click won't take until I move the cursor off and back onto the item.

I am truly appalled, because I have a number of Vendel games, and none have EVER been this poorly programmed.
 
 
 posted in Grim Facade: Hidden Sins Collector's Edition on Jun 25, 15 3:33 PM
"An outbreak of scurvy" caused the drawbridges to be raised?

Really?

Did no history teacher every explain why England's sailors used to be called "Limeys"?

Scurvy is not a communicable disease, Boys. Do your homework.
 
 
 posted in House of 1000 Doors: Evil Inside Collector's Edition on Mar 21, 15 4:59 AM
In the bonus chapter, if you try to "skip" the light gun puzzle to get rid of the purple goo, the game hangs.

The first two times I tried it, eventually, after a number of clicks in various places, it moved on. The third time, in the building after pulling down the tree and crossing the gulch, it simply froze. After 2 minutes of trying to get it to move on, I clicked the menu to back out, and that worked. However, when I clicked Play again, all I got was a cursor on a black screen.

I fully realize that error checking is tedious and time-consuming, but you have a glitch in your programming that never should have made it to market. Fix it and issue an update.
 
 
 posted in Shiver: The Lily's Requiem Collector's Edition on Feb 11, 15 7:30 AM
What, pray tell, does "It's working now. I'll check the fountain at the square" have to do with going up the stairs in the mansion? I got it several times in the living room when clicking for a hint.

 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator