Posts created by sedbee

 
 
 posted in Grim Tales: Graywitch Collector's Edition on Feb 2, 17 12:57 PM
Please help,
got the same problem as Mimi05 and mavisfern1....I got the bracelet once,but the game directed me back to the dead Emily and now I am stuck and can't go anywhere....Is it a glitch or am I doing something wrong??I really do love this game and would like to finish it
Thanks for any help you can give
Sed
 
 
am having the same problem. ...everything is gone...Running Windows7,and so far everything went smooth.System is up to date.please help...I really want to finish this game
Thx
Sed
 
 
 posted in Green Moon 2 on May 16, 16 4:21 AM
Hi there,
What task are you working on?I am trying to figure out task 10 and so far no snake venom was needed for any of the tasks....so just don't touch the reptile and happy gaming !
Sed
 
 
 posted in Green Moon 2 on May 15, 16 8:07 AM
Thank you!!
 
 
 posted in Green Moon 2 on May 14, 16 8:27 AM
Hi ya'll,
how do I get to the p. era??Is it one of the worlds I can travel too?
Any help is much appreciated
Sed
 
 
same here....I fed that greedy bugger every morsel of food(12) and I still can`t pick up the fuses....contacted Customer service,but no reply yet.....sigh
 
 
alright,I tried every suggestion ya'll posted(Thank you!!!),but nothing worked....I fed that greedy raccoon every morsel of food I could find(all 12 items and then some) and it still wants more....guess it's time to contact customer service....
Thank ya'll for helping!
Sed
 
 
Hi ya'll
I am stuck feeding the raccoon..can't seem to find the last food item....when I press the hint button it only tells me "there is nothing to do here at the moment".....
What am I missing??
Any help will be greatly appreciated
Sed
 
 
 posted in Nevertales: Legends Collector's Edition on Sep 18, 15 2:18 AM
Hi zuzu2,
I was stuck at the same spot....try clicking on the big Spider(the one you have to place puzzle pieces)...which should zoom out and you can then place the key
Hope this helps
happy gaming!!
Sed
 
 
thank you Euskalduna.....
what I meant is that I never got to the beginning of the game..it won't launch
 
 
I am happy für you!!
I never even got to he point where I could choose a name.How'd you do it??
 
 
same problem here ....please do something!!
 
 
 posted in Awakening: The Golden Age Collector's Edition on Nov 9, 14 6:26 PM
yippeeh!
and thank you very much Aprilsnar1...with your help I managed to finish the game
 
 
 posted in Awakening: The Golden Age Collector's Edition on Nov 2, 14 6:37 AM
let me join the club...I really liked the game..well until now
 
 
 posted in Dark Angels: Masquerade of Shadows on Jan 8, 14 6:40 AM
Hey ya'll
had the same problem and all I had to do was quit the game and when I restarted all the missing items were in my inventory .
strange....
Sed
 
 
 posted in Fall of the New Age on Jan 8, 14 1:34 AM
Hi jcsgame,
thank you soooo much, I am back in the game!
Sed
 
 
 posted in Fall of the New Age on Jan 7, 14 10:24 AM
Hi ya'll,
this is a cry for help to all of you fishies out there
I am stuck in the observatory. Found out that Bastark was born under Skull and my diary says .."I need to find it on the globe and figure out position data..."
Where is that globe?..I've been running back and forth to no avail..
Help please!!
Sedbee
 
 
 posted in Paranormal State: Poison Spring on Nov 3, 13 5:24 AM
THANK YOU !!!!
 
 
 posted in Paranormal State: Poison Spring on Oct 31, 13 11:12 AM
I am too having the same Problem and it's driving me nuts ...can anybody out there help please?
Thank you
Sed
 
 
 posted in Mayan Prophecies: Cursed Island Collector's Edition on Oct 5, 13 10:06 AM
It was a nice game but nothing outstanding.Way too many HOGs,and I was a bit dissapointed.Does not compare to the previous games,

 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator