Posts created by revtami

 
 
 posted in PuppetShow: Destiny Undone Collector's Edition on Apr 3, 13 2:30 PM
Please someone tell me how to set that darn clock to 10;10????
 
 
 posted in PuppetShow: Destiny Undone Collector's Edition on Apr 1, 13 4:29 PM
I spilled the water on the book and it only served to confuse me more because it refers to "binary time" with arrows that point to a couple of buttons on the contraption. I finally got the cursor to change to hands for the other clock but as someone else already said I can't get the clock set to 10:10 as the SG says to do. If I can't get past this stupid clock the games becomes not only a waste of time but a waste of money for me. Can someone please help me?
 
 
 posted in Ghost Whisperer™ on Jul 16, 12 3:03 PM
Most definitely need a walkthrough! I'm stuck with that stupid candle which I can't pick up. It tells me to light it but after I do it takes me back to Eli's office to "gather stuff to do a rubbing" only there's no stuff there and if I try a hint again it takes me back to the bedroom and the candle, which it tells me to light and then sends me back to Eli's office again. I'm getting dizzy on this merry go round pls somebody help me!!!!!
 
 
 posted in Emma and the Inventor on May 22, 11 6:27 AM
One of the things I've always liked about Game Fish is the fact that they give you plenty of time with each game to make sure it's a game you'll enjoy and one that's worth your money. In fact Game Fish prides itself on that one hour "try it" benefit it has. Well apparently the manufacturers of Emma and the Inventor don't agree with Game Fish's 60 minute try out time. The game cut itself off and presented me with a lovely popup that said thanks for trying the game, times up, buy or delete. Or words to that effect. Anyway there was still 18 minutes on the timer for this one. I've had a couple of other games do this too (cut off well before the allotted 60 minutes was up) but I've never said anything because I thought it was just some glitch and I ended up not buying the game anyway. I'm not going to buy this one either but I just thought someone should know about this if they don't already, and if they do know about it, why didn't anyone tell us. I probably would have tried it anyway even if I had know it wasn't going to give me the whole 60 minutes.

It's just the principle of the thing, don't tell me I've got 60 minutes if I only have 42. It's a lie and it puts a black eye on what is otherwise a great Game Fish reputation.
 
 
 posted in Dark Dimensions: City of Fog Collector's Edition on May 17, 11 6:50 AM
Don't feel bad, I came to the forum because I could not for the life of me figure out how to get into that doggone tree house! Thanks for the help.
 
 
 posted in The Tiny Bang Story on May 16, 11 5:57 AM
I never got off the first screen! Just too hard for this old head to figure out I guess. I wound up with what I think were 3 #'s on the plate in the tree but there was a triangle
also which can represent the #3 but nothing I tried in the machine at the bottom worked. It's probably a great game for someone who likes a real challenge but I just don't like not having hints (without catching mosquitoes first) or some kind of "help" menu that at least gives you some idea of how to proceed. Never did find all the handles or the wrench which I suspect would have come after getting that machine running. The long and the short of it is, I hated this game and I've never had that feeling about any game on Game Fish before. Deleted it when I still had 30 minutes left which shows you how frustrated I let myself get.
 
 
 posted in Mystery Valley on Nov 10, 10 7:55 AM
I wish I could say I was enjoying this game but I'm not. It was fine until I got to that darn fuse box for the elevator. First you put out the fire then you do a couple of hidden object scenes then you get to that darn fuse box which of course is locked so then you have to go find the key. Once you've got the key you open the box and guess what, there's nothing in there. It's slick gun metal gray nothingness. Of course the pop up says the fuse box has been so damaged by the fire that you'll have to repair it. So you need to find 5 fuses and 5 wires. There are only 3 fuses in that room and 4 wires but it doesn't matter anyway because there's nothing in that darn fuse box to fix!!! I am so frustrated and so very, very sorry I wasted my money on this one. It won't even let me skip this particular puzzle. I clicked like a thousand times on that skip button and nothing! I see how much you all are enjoying this game and no one else seems to have this problem, I must have gotten the lemon. Is there a lemon law for on line games? Somebody Help Please!
 
 
 posted in King Arthur on Sep 27, 10 2:50 PM
montqpr wrote:
granraven3 wrote:
montqpr wrote:The star is on the wall, right hand side of screen, between candle holder and window. It's small, but quite noticeable when you do locate it.


Thank you so much! I thought I was going to spend the entire hour looking for that stupid star!


My turn, now. Where are the scales? I've collected all the other stuff and do not see any sparkles. I feel as if I've clicked on every part of the scene without success. Thanks for any help.


Scales are on the front of the chest, you have to squint to see them, they blend in pretty well.

I spent most of the demo time looking for that stinkin star too. Errrrr.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator