Posts created by magskye

 
 
 posted in Ancient Spirits: Columbus' Legacy on Mar 11, 17 11:52 AM
This is the third time I have tried this game and still cannot get Carlos to take the ink, paper and pen. People have finished this game so somehow you must be able to do it. Help, please.
 
 
 posted in Myths of the World: Bound by the Stone on Jan 16, 17 7:29 AM
[Removed by Moderator]
 
 
 posted in Myths of the World: Bound by the Stone on Jan 16, 17 7:27 AM
[Removed by Moderator]
 
 
 posted in Labyrinths of the World: Stonehenge Legend on Sep 5, 16 4:04 PM
http://nutrahealthtrimsite.com/fierce-male-enhancement / Why is this in the forum for this game?
 
 
 posted in Aztec Venture on Jul 23, 14 1:11 PM
Thank you. Your explanation is great!
 
 
 posted in Aztec Venture on Jul 23, 14 11:48 AM
I cannot figure out how to play this one. Can anyone help? You have to knock the blocks out to get the balls.
 
 
 posted in Mysteries of Neverville: The Runestone of Light on Jun 15, 14 3:26 PM
Mine is black in the town square also. It does allow me to go into places though. When I move my curser around it tells me what is there eg. tower.
 
 
 posted in Hope Lake on May 22, 14 6:37 AM
I also stopped the demo there. It is too bad that this one got through the testing.
 
 
 posted in Hope Lake on May 22, 14 6:36 AM
Even without the full screen I cannot get it.
 
 
 posted in Hope Lake on May 22, 14 6:29 AM
I took it off full screen, found the ladle and could not get it. After clicking it a few times, I got a poof like a small bomb then I tried again to no avail. I sent the game to the garbage.
 
 
 posted in Black Rainbow on May 16, 14 12:05 PM
I cannot find something to use as a net to get the knife out of the water by the downed plane. I have the rod, rope and the hook. The hint sends me back into the plane but I have clicked on everything and cannot find anything to take.
 
 
I can't find it either and am giving up so I do not waste all of my hour looking for one thing. The strategy guide does not help me, nor does the hint.
 
 
 posted in Enigmatis: The Mists of Ravenwood Collector's Edition on Oct 6, 13 11:51 AM
All this does is bring up big fish and I end up back here. Are you sure the link is good?
 
 
 posted in Reality Show: Fatal Shot Collector's Edition on Dec 21, 12 8:53 AM
I played for all of about 5 minutes, then it closed and said my time was up. No matter how good or bad it is, this is definitely a no-buy for me.
 
 
 posted in The Otherside: Realm of Eons on Oct 9, 12 3:31 PM
My last one stays highlighted but does nothing when I click on it.
This is very frustrating.
 
 
Map
 posted in Nancy Drew Dossier: Resorting to Danger on Aug 1, 12 4:17 PM
I have not been able to find out where to find the map even in the walkthrough. I know that Nancy got one from Cassidy but I don't know where it is now.
 
 
Map
 posted in Nancy Drew Dossier: Resorting to Danger on Aug 1, 12 3:10 PM
How do I get to the map in this game? I cannot change from one place to another without it.
 
 
 posted in The Keepers: Lost Progeny on Dec 15, 11 4:10 PM
I liked the CE game and I like this one too. I agree with the colour blind thing-I too must be colour blind. The only thing, so far (and I have only done the demo) that I do not like is how long it takes to load some of the scenes. I find I lose interest quickly when that happens. I am not sure I will buy this but will certainly think about it.
 
 
 posted in Relics: Dark Hours on Dec 2, 11 4:38 PM
I, too cannot get beyond the door into the school. Not a game for me!
 
 
 posted in Spirits of Mystery: Amber Maiden on May 29, 11 4:24 PM
It is too slow for me too-I was looking forward to the game but cannot spend all my time waiting for the things that I locate to get to the list bar and for almost stopping when someone is talking. It did not start off that slow but after I got out of the house it was like I went into slow motion.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator