Posts created by lssubabe

 
 
 posted in Slingo Quest Egypt on May 4, 13 6:47 PM
Are there any levels higher than Nile Delta? I've completed all 4 so far and have gold stars in all, but I have hardly any awards and I am not progressing anymore. Is this it?
 
 
 posted in Haunted Manor: Queen of Death Collector's Edition on Dec 11, 11 4:16 PM
Hi......

I am stuck on the treehouse puzzle. I put the ball into the mouth on the top lt corner then I am supposed to make the ball move to the end, but I have no ball to move....

What do I need to do? Frustrated this far in the game...not good
 
 
If you are refering to the cabin it's 02141976 the date in the pic of Hamilton and Emily
 
 
I have done that twice and the hint keeps telling me to leave. I'll try it again.
 
 
Help me please!

I have the bucket of water and I am trying to get to the bucket of water to the drain in the basement to get the cork. When I use the hint button it takes me back to the boat house and canoe to patch it. I have the dropper w/ resin, but I need the cork to finish. About to tear my hair out here. Any suggestion?
 
 
SG?
 posted in Lost Souls: Enchanted Paintings Collector's Edition on Aug 29, 11 7:31 PM
Okay that explains why I don't have an SG. Thanks
 
 
 posted in Lost Souls: Enchanted Paintings Collector's Edition on Aug 29, 11 6:01 PM
At the risk of sounding like an idiot, I am not seeing one anywhere. I have looked in every nook and cranny in each realm I've been in. Can someone tell me where I am missing? Can someone give me a screen shot? I am not a stupid person, but I am about to tear my hair out because I'm looking left of the map under HINT, I've looked in the book.

I'm sorry to be blind, but I am a very intelligent individual and either I am blind or I have a bug. If someone can screen shot where the SG is, I would appreciate it.

 
 
 posted in Lost Souls: Enchanted Paintings Collector's Edition on Aug 28, 11 3:30 PM
I am at to where I need to put the amulets at the altars and I am putting them in the right slot in the right order but it keeps saying it's wrong. I've even hinted and it tells me the same place. Does anyone know of an SG or how the heck to do this. Very nerve racking.

Thanks
 
 
marciabb wrote:SPOILER ALERT

No problems with freezing here, but another problem :
I'm playing the bonus chapter and at one point you have to enter the castle with a gear-puzzle. I took the 3 gears from the gargoyles mouths, then placed them in the puzzle, but one dissapeared ! So I can't finish the game... Does anybody else had this problem ?


Has that exact same problem. Any solutions? I would love to finish this
 
 
 posted in Fallen Shadows on May 5, 11 1:29 PM
If there is an SG, I am not finding it. Where is it located?
 
 
 posted in Dark Parables: The Exiled Prince Collector's Edition on Mar 2, 11 3:03 PM
I, along with several others I've seen are having issues w/ finishing the game. I have found all 20 cursed items, gone through every area multiple times, and finished my objective of rescuing the girl several times. All I get is the final blurb about seeing the scary chick, then I get a sequence of rooms with a green check mark @ the bottom:

Cave
Shoe Closet
Snow White's Mirror Room

When I click on the check mark, it takes me back to the main menu and when I hit play, I go back to the final part. I do not have an option to play Hard Mode and my bonus game is locked.

This is ridiculous BFG! Get on the stick and find a way to fix this or people are going to stop buying your games!
 
 
 posted in Dark Parables: The Exiled Prince Collector's Edition on Mar 2, 11 2:56 PM
Aelfick_Wolf wrote:ok i have completed the game twice and told me both times the hard mode was unlocked. but when i press the play button both times, the crown was never in my inventory. Can anyone help with this dilemma?


I'm having the same issue. I've gone through each area several times to make sure I didn't miss anything. After the sequence of rooms after I rescue the girl, it just takes me back to the main menu. I hit play and I go back to the final objective, rescue. I have seen several people having this problem and the fact that we have not been offered ANY assistance on this is crap. If several people are having this problem, then it must be a technical issues because I doubt all of us are idiots.

Someone needs to get on the stick and assist us in fixing this so we can finish the game!
 
 
 posted in Dark Parables: The Exiled Prince Collector's Edition on Mar 2, 11 2:31 PM
amcvey wrote:Someone sent me a patch for the bonus game...& IT WORKED!!! YEA!! Thanks for everyone's help on this!!


If anyone can post that patch to everyone else having issues that would be really nice. bc I am having the same exact problem.
 
 
 posted in Dark Parables: The Exiled Prince Collector's Edition on Mar 1, 11 6:12 PM
Butterfly1117 wrote:
prpldva wrote:Sequence of events:

1. Play the game in regular mode.
2. Play the bonus round (or play it after the hard mode.
3. Play the game in hard mode where you are given the frog prince crown in your inventory at the beginning.
4. After placing the crown on the frog prince door, inside you will find the tree disc.

There is nothing wrong with the game.


I have "finished" the game in regular mode as I saved Marie by completing the puzzle. Note that and I had no inventory left. When I went back to the main menu to start playing the bonus games, they were still unlocked and there was a message saying 'Unlocked when main game is completed' or something like that. I tried to trace all the way back and I cross-checked with the strategy guide following step by step. Does anyone know how I can unlock the bonus round and continue playing? Thanks


I am having the same problem. I finish the game, then it shows me 3 rooms w/ a checkmark under them and when I click on one it take me back to the main menu. I have gone back to those rooms several times and searched them until my eyes and I can't change to hard mode and my bonus game is still locked. Surely someone has an idea here because if I wasted 13.99 I will be really ticked off
 
 
 posted in Dark Parables: The Exiled Prince Collector's Edition on Mar 1, 11 6:06 PM
Here is my issue. Someone please help me.

I was able to get the Prince's locket and brought it to the chancellor's daughter and bg. Used it to activate the puzzle, completed the puzzle, got the blurb about what she saw, then it goes to a series of repeating rooms w/ a checkmark on the bottom. These are the rooms that keep showing up in the series of shots w/ the checkmarks:

Cave
Shoe Closet
Snow White Mirror Room

When I click on the green checkmark, it takes me back to the main menu. When it is clicked on, my objective is the same......rescue the 2 people. When I get there, the puzzle I've completed has to be done again.

I've found all 20 morphing objects and gone through these 3 rooms w/ a fine tooth comb. Has anyone else had this issue or give me some insight because I'm about to give up on it. Obviously I am missing something, but what!
 
 
 posted in Dark Parables: The Exiled Prince Collector's Edition on Feb 28, 11 9:45 AM
Can ANYONE put a decent walkthrough? I have rescued the daughter & bg TWICE NOW and all I get are screens w/ a checkmark at the bottom showing a sequence of rooms over and over! I went back and got all the cursed objects but I can't get to the credits bc of that stupid sequence of the checks w/ the rooms. Someone help! I am getting really ticked off
 
 
 posted in Maestro: Music of Death Collector's Edition on Feb 19, 11 12:17 PM
Kelvarda wrote:
Old_Man_River wrote:O.K. Got me again. Good graphics, good game play, good grief another CE added to my computer. I'm running out of space on my hard drive.It would be nice if I could transfer BF Games to a DVD or CD instead of having to reinstall from the BF Site.I'll need to make a list of all my games.


@ Old_Man_River

Do what I've done, buy an external drive, and re-download all your purchased games to that. Please be aware though you have to uninstall from your C drive before you download to an external. Then re-install from your purchase history to the external drive. You cannot just move or copy the files across.

I've done 72 so far, only got 38 (I think) to go. Downloading Maestro now, but it's such a large file, started it at 6.09pm and it's only got to 40% an hour and a quarter later.......Might get to play it around midnight......

Kel

apologies for the hi-jack


So do you put several onto 1 DVD when you burn or just one @ a time? Just curious because I was thinking about doing the same thing w/ my BF games
 
 
Can anyone tell me where the string is for the magnet? I want to get the steel brush and I have the magnet but I can't find the string to tie to the magnet. Help please!
 
 
Thank god I'm not the only one. I've tried getting the lamp knob 3 times and it's not in the puzzle and the hints keeps saying nothing more to find and it's not in my inventory. What gives?
 
 
Finally got it fixed! Thanks a bunch all for your patience!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator