Posts created by dregester

 
 
 posted in Adelantado Trilogy: Book One on Sep 23, 13 3:21 PM
I finally figured it out.
 
 
 posted in Adelantado Trilogy: Book One on Sep 23, 13 10:07 AM
Has anyone figured out how to do this? I keep getting messages that I should upgrade, so I click on the building and that doesn't tell me anything. I've gone to the help screen, but that doesn't tell me anything either. Would appreciate having help.
Thanks
 
 
 posted in Alchemy Mysteries: Prague Legends on Sep 8, 13 4:15 PM
I just downloaded and tried to play, and I get black screen with a curser and music playing. I see this is a problem they've had for a year and still haven't fixed. I can't even see the options menu to do any tinkering.
 
 
 posted in Stray Souls: Stolen Memories on Aug 8, 13 6:07 PM
I agree, bring us a walkthrough and I will buy the game. Without one, never know when you might get stuck.
 
 
 posted in Dark Dimensions: City of Ash on Jun 30, 13 4:24 PM
Whoops, got my games confused. Sorry.
 
 
 posted in Dark Dimensions: City of Ash on Jun 30, 13 4:23 PM
Interesting that this happens on the day they are offering the game as the DD.
 
 
 posted in Redemption Cemetery: Salvation of the Lost on May 30, 13 8:45 PM
I have all the previous Redemption Cemetery games but will not be buying this one. I just found that the tedious mini-games to power the raven were just too annoying. I understand they can be skipped, but I don't like a game where I have to do that.
 
 
 posted in Nightmare Adventures: The Turning Thorn on Jan 27, 13 4:35 PM
I can't get the cup from the dumpster to fill with the flammable liquid so I can pour it on the bushes and set them on fire with the match. I've tried several times. Closed the game and re-loaded and it still won't fill.
 
 
 posted in 4 Elements II on Oct 2, 11 10:12 PM
Always relieved when I come her and find out everyone else is having the same problem as I am. Game shuts down at Pegasus. I also loved the first game and was hoping to play this one.
 
 
 posted in Voodoo Whisperer: Curse of a Legend on Jun 4, 11 12:40 PM
Brand new game and it says my trial has expired. Hmmmm!! I'm uninstalling and will try reinstalling.
 
 
 posted in Spirits of Mystery: Amber Maiden on May 30, 11 6:40 PM
I love coming to the forums and finding out that it's not my computer, it's the game. Very sluggish, it takes forever to clear a scene, finally gave up when in a HOG scene the items kept floating through the air. Too bad because this really looked like a game I would buy.
 
 
 posted in Legacy of the Incas on May 18, 11 9:52 PM
When mine shut down in the library and I had the two cursers, I couldn't get task manager to open but I was able to get out by hitting Esc.
 
 
 posted in Empress of the Deep 2: Song of the Blue Whale on May 9, 11 1:31 PM
I love the graphics in this game, but I am also getting the pink flashing screen and now that I've gone through the first door, the whole screen is pink. Hope they can fix this problem because I would love to buy this game.
 
 
 posted in Allora and The Broken Portal on Apr 30, 11 4:34 PM
The second time it worked. Now I'll try playing the game.
 
 
 posted in Allora and The Broken Portal on Apr 30, 11 2:53 PM
I downloaded game and it said my trail had expired. I uninstalled and now I'm downloading again.
 
 
 posted in DreamWoods2 on Apr 12, 11 9:20 PM
Same for me, a pink screen the color of Pepto, little snowflakes, and had to use task manager to close.
 
 
 posted in Wild West Quest 2 on Mar 30, 11 10:00 AM
Does anyone know if they fixed the hint problem? I don't want to buy, even at 2.99 it it's got a major glitch.
 
 
 posted in Jewel Match 3 on Mar 3, 11 4:06 PM
Thanks to everyone in the forum for your tips. I was finally able to finish the level by waiting until I had a hammer to smash the key before it changed into a wildflower.
 
 
 posted in Haunted Legends: The Queen of Spades on Jan 15, 11 8:59 PM
In the CE I couldn't even get past the gate it was running so slow, with this one I made it as far as the bottom of the stairs before I gave up. I'm going to uninstall both because obviously there has been no fix for this problem. I've been playing MCF 13th skull with no problems so I don't think it's my computer.
 
 
 posted in Awakening: Moonfell Wood on Jan 6, 11 10:23 AM
Now the game is being featured on the home page and they still haven't fixed the problems. I don't get it.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator