Posts created by JPCarol

Solved my own problem. I was looking in the wrong place for the rod
I did not get the rod from the front of the safe before opening it and now I cannot break the bottle to get the final piece of the key to the medical kit. Has anyone else had this problem? If so, how did you resolve it? Seems like a bug for the game to let me open the safe without having picked up the rod
 posted in Myths of the World: Love Beyond Collector's Edition on Feb 13, 18 11:08 PM
This game is very buggy and there is no help for those affected. I posted twice in this forum - once under tech support and once in the mail lst - detailing a problem with one of the puzzles. I finally had to skip the puzzle which totally ruined the game for me. Regardless of graphics, story, etc - if there is no support then the game is a big FAIL
 posted in Myths of the World: Love Beyond Collector's Edition on Feb 12, 18 4:33 PM
I am unable to complete the calendar puzzle in Cell #3. The Marble chip cursor does not react with anything on the screen. I got the image of the marble chip when I first saw the puzzle, long before I ever got the marble chip. This appears to be a bug in the game.
 posted in Myths of the World: Love Beyond Collector's Edition on Feb 11, 18 11:32 AM
I cannot figure out how to draw the lines with the marble chunk. I tried clicking on the points and tried dragging the marble across the lines and no response either way. Does any know the secret?
I think this may be a bug, because I got the image of the marble when I first saw the puzzle way before I ever got the marble. I really do not want t have to start over and see if it works with another profile
The first post re the Key mold issue was 07/06/2017 and I don't see any meaningful response from the devs or from Big Fish. Is there a solution in the works or should I just request my refund now?
Right now the game gets a big ZERO for a review because there is a glitch at the end that is keeping a lot of us from being able to finish it. I'm being magnanimous and giving the devs a week to get a patch out before I ask tor a full refund.
How about you forego the stock answer and get this bug fixed. A whole bunch of us using different operating systems are all stuck in the same place. Just do a patch and get one with it
Me too - got all the way through to the last item and now stuck
 posted in Silver Tale on Jun 4, 17 12:56 PM
In the level 40 mine, there is a chest that needs a silver key. Where is the key?
 posted in Yuletide Legends: The Brothers Claus on Dec 26, 16 8:58 PM
Exactly the same problem. Playing on Windows 8 desktop, so it is cross-platform. Is anyone monitoring or are we on our own here ??
Sam problem. It's very frustrating and makes me want to uninstall the game and forget about it. Seems like they could at least have a starting point, outline or something
 posted in Grim Tales: Threads of Destiny Collector's Edition on Oct 10, 15 10:10 AM
Same problem with musical note. I am very sorry that I purchased. Will ask for refund due to buggy game
NM - found it
I swear I looked everywhere and cannot find it. Can someone pointme in the right direction?
 posted in Final Cut: The True Escapade Collector's Edition on Nov 23, 14 8:59 PM
Having difficulties with the compass box at the beginning of the game. I found the N button in the martini, put it on the box, but the box did not open and the N disappeared. The game keeps taking me back to the martini to get the N button, but the button is not there since I already took it. No, it is not in my inventory. It is not anywhere. Has anyone else had the same problem? Does anyone have any suggestions other than replaying from the start ?
 posted in Echoes of the Past: Wolf Healer Collector's Edition on Oct 21, 14 8:14 PM
That was it. I totally missed the one on the beam. Thanks
 posted in Echoes of the Past: Wolf Healer Collector's Edition on Oct 20, 14 5:19 PM
I collected all the crystal balls as I went along, but at the end, the game reports that I am missing the one from the forge. When I click on the button to be taken to the forge to collect the crystal ball, it is not there (because I already picked it up) Has anyone else experienced this bug ? Has anyone found a fix ?
 posted in Claws & Feathers on Sep 20, 14 11:36 AM
I can do it in 25 turns, but see no way to complete the level in 23 for gold. Any hints or help would be appreciated.
ctitus wrote:I have opened the safe in the armory and am trying to "dress" the dummies in the correct armor. However, the greaves I took from the safe have disappeared. Cannot continue without them.

I finished the puzzle. Had all knights dressed correctly. Puzzle did the sparkly thing that indicates you have solved and then went back to the way it was before the missing armor pieces had been added. No new items in inventory. No new clues. No advancement in game and of course, all the armor pieces that were added by the player are now non-existant. This game is so buggy it should be withdrawn and money refunded.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator