Posts created by PENNYJS

 posted in Escape from Thunder Island on May 24, 11 5:53 PM
I'm in break neck falls and I can not get the sun key to go into place. I check the forum and did as it said and the lights just won't work. Any help out there. Would deleting it and reinstalling help? thanks Penny
 posted in Reading the Dead on Feb 15, 11 1:10 PM
snaffins wrote:where any how do you hide it?
any help greatly appreciated
 posted in Hodgepodge Hollow on Jan 11, 11 6:02 PM
I am in the game to make the part with the mermaid braid and bells. I get it all done until you have to use the dandlion puffs to keep the bells quiet. When I try to do it , it looks like it is working until I go to the last bell then it poofs on me. I have done it about a half dozen times and it still does the same thing. What am I doing wrong with the bells? thanks
 posted in The Dragon Dance on Dec 2, 10 3:39 PM
How many people are having problems with this game. So far I have uninstalled once to fix one problem now I have some more. It is very upsetting to have a game that won't work. Do we get notified when a game is working correctly cause I am not playing this game again until it is fixed. So I will uninstall it until the fix is in. Hope someone can tell me about this.
 posted in The Dragon Dance on Dec 2, 10 3:27 PM
I can not either this game seems to have a lot of problems . My first one with the black book I solved by uninstalling and reinstalling. I hope I don't have to do the same thing to solve this one. I think I will stop playing this game untill some one can do all the fixes. I hope someone will let me know when that happens.
 posted in The Dragon Dance on Dec 2, 10 1:54 PM
ok I uninstalled the game and reinstalled and there was the book so I guess if anyone is having the same problem that is one solution. Thanks
 posted in The Dragon Dance on Dec 2, 10 1:18 PM
I used the walkthrough and it shows where the black book is suppost to be but it isn't there
 posted in The Dragon Dance on Dec 2, 10 12:38 PM
I bought this game and I have a problem. I can not find the black book called A dangerous journey vol. 12. It seems to be missing. Can I get some help. Thank you
 posted in Youda Legend: The Curse of the Amsterdam Diamond on Jun 21, 09 1:19 PM
I have the doors all inI the right place and have walked the maze 3 times. I can not seem to get to the other door. all the doors are locked I have tried all of them when I am doing the walk , any help or hits on what to do? Thank You
 posted in The Clumsys on Sep 3, 08 12:56 PM
Can anyone help me I cannot find the last doodle anywhere in the room. And I can't do anything else until I do. I found the eyeglasses and the doodles on the floor but there is one more and I just can't fine it. If anyone can direct me I would be so happy . Thanks Penny
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator