Posts created by gale129

 
 
I located the rune but I cant get it.
 
 
 posted in Awakening: The Sunhook Spire Collector's Edition on Aug 17, 13 7:45 AM
belamba wrote:One other issue...I've managed to save 2 game credits (just don't know how I manage that sometimes), but when i went to purchase game, it didn't give me the usual option of buy on website, or use two game credits.

I just clicked on buy this game. I saw the amount was £0, so assumed it had used my game credits.

After installing it showed I still have 2 game credits. I'm really puzzled by this.

Bought another CE Thursday, but am assuming this BOGOF didn't start until today?


By chance, if the game credits you refer to are ones earned and not purchased (earned credits are not listed in your "game credits" on the website when logged in) you cannot use earned credits to purchase a CE game.
 
 
 posted in Awakening: The Sunhook Spire Collector's Edition on Aug 17, 13 7:05 AM
I can't get the game to start the download. My PC runs the security scan and usually it starts the download right after, highlighting my bigfish app in the process. However, when I go to my BF app, nothing is there. I have attempted to save the download instead of run too. The security check runs and then it gives me the option to "run" from the download file. I clicked on run here as well and it still will not start the download. I also tried running as administrator from the folder it created. Nothing. My BF account shows two less credits than just prior to selecting purchase so I am good on that issue. Help anyone???

Update!! I closed out my BF app, went to the BF site and to my purchases tab. My purchase was listed (thank goodness) and I clicked install from there. The security check ran as usual and as I waited with baited breath, it opened my BF app and started the download. Posted just in case someone else has this issue. I download an average of two games a week and this is a first for me.
 
 
i'm not sure if this is actually a tech issue but I finished the game and bonus game and lack 2 pieces of the puzzle. The insutructions say I can "replay the game just to find the other 2 pieces but when I clicked "play" again, it started me all over. When I went back to the bonus screen, it shows that I still have 43 out of 45 puzzle pieces so I didn't "loose them." Does anyone know how to go back into the game to collect the puzzle pieces only?
 
 
The third coin is in the maze but the entrance is easy to miss. At the second screen of the maze where there is wood on the ground and a bird cage, notice there are 2 tunnels on the left (the first one is where the last coin is at the end) and the second tunnel is where you go down to place all the candles and complete the mini game and use the dagger from the coin puzzle.

For those having trouble finding the place where you place the candles, after finding the third coin, go back to the screen with the bird cage. Take the second tunnel on the left and go forward three tunnels. Here there are three ways to go, two on the left and one on the right, take the second tunnel to the left and go forward two tunnels (one tunnel past the statue and the chest game on the ground.) Here you can go straight (dead end) or go right (where there is a break in the wall)
 
 
 posted in Dreamscapes: The Sandman on Mar 13, 13 7:07 AM
I tried using the hamer on the hour glass. It doesnt do anything but go right back in my inventory.
 
 
 posted in Dreamscapes: The Sandman on Mar 13, 13 6:58 AM
I have found the first fuse on the table next to the patient, the screwdriver and got the key in the second room, the sponge to get the code to use with the key to open the cabinet. Got the second fuse in the cabinet and now I am stuck. The hint keeps pointing to the hour glass to the left of the screen and the only inventory item I have left is a hammer and I cant smash it, cant pick it up and the screen will not go past there. Can someone help please?
 
 
 posted in Azada: Elementa Collector's Edition on Mar 8, 13 10:02 AM
During the bonus section of this game (no glitches for me on THIS game up until now) for some reason after collecting several items including the shield for the box under the stones and a gear for use later in the game, the gear is on top of and in the same inventory box as the shield and I cant get to the shield, which is needed to get me to where the gear goes. I exited out of the game and went back and it's still the same. Anyone else with this problem?
 
 
 posted in The Lake House: Children of Silence on Jan 29, 13 12:05 AM
Because when you buy a lot of games, between CE and regular versions of games, one tends to forget what they have and have not purchased and it is usually long been played and deleted. Therefore, we must check our purchase history for the game. And I should point out two things: first, when the regular game comes out 30+ days after the CE, the picture is completely different than the one for the CE; secondly, there is a lot of different "words" that can be added to the beginning of a game. Those of us who have over 300 games in our history have a lot of searching to do!
 
 
 posted in The Lake House: Children of Silence on Jan 25, 13 11:18 PM
I don't think I have ever known BF to post a CE game and later post as a regular game with a different name, even though just THE was added. I go by the name of the game in my purchase history to see if I bought the CE when the regular game comes out and when the name has changed ....... anyone else?
 
 
 posted in Mystery Trackers: Four Aces Collector's Edition on Oct 15, 12 6:32 PM
I need to blow up the creature in the sewer but I don't have the Dynamite i got from the box and the game will not let me open the box back up to see if it's there. Any suggestions?
 
 
In the bonus section, I got the jellyfish but not the gas mask, which triggers the portable lab to make the "gas" for the gas mask. Cant kill the bad guy without it! Im stuck.
 
 
The game just as well have froze for me close to the beginning when I combined the pic from the hat on the dock with the other item and got the 1\2 locket (the game went into very, very slow motion) My problem with uninstalling and re-installing is my internet only allows for a limited amount of mgs of downloading per day and the first download put me way past my limit for another few days. Surely there are others who also have limited downloading and BF should take this into serious consideration before releasing a new game that most have to uninstall and reinstall to make it work properly.
 
 
When I getto the train station, the place where you pick up the valve has something flying around buy on my screen it's with boxes. I got past that but when I clicked to unlock and open the suitcase with the color code, the whole box is white. I could figure out where to put the key because of the "interactive wheels" but that does not help when trying to solve the code. Anyone else have this problem?
 
 
Game page shows 750 mg to download for the game. Game is downloading now but shows 1.5 gb for total download. I thought I just read the other day that 1 gb is = to 1000 mg? If this is correct, the game is actually around 1500 mg ram to download. Is it because I did not download the demo, just purchased the game?
 
 
After reading these great reviews, I just decided to buy the game at 700+ mg rather than download 400+ mg for an hour long demo as I am on a "fixed income" regarding mgs per day. Good thing I took advantage of the game credits sale last weekend!!! Thanks for all the great input!
 
 
 posted in Behind the Reflection 2: Witch's Revenge on Mar 21, 12 2:36 PM
Where is the last piece (body) of the voodoo doll?
 
 
 posted in Behind the Reflection 2: Witch's Revenge on Mar 21, 12 1:54 PM
Where is the last piece of the voodoo doll?
 
 
 posted in Secrets of the Past: Mother's Diary on Oct 27, 11 8:16 AM
lknee wrote:In the fireplace scene upstairs where the tile with the ballet pose is, it wouldn't let me pick it up, and when I come back to it after closing the screen zoom and reopening it, the tile is gone and I get gears like I need to do something but can't do anything. Nothing else can be done till that screen is finished. Ballerina won't let me change positions because it says I still need the clue.


Just wondered if this issue has a fix? I would like to buy the game but my trial ended when I had the same issue as iknee and I couldn't go any further without solving the ballerina riddle. Don't want to purchase if I can't continue.
 
 
 posted in Silent Scream: The Dancer on May 20, 11 10:10 PM
When I combine the dull scissors and the stone/wheel/sharpner, nothing happens. In order to go on, I need sharp scissors to cut the rubber hose for the kitchen sink. Any ideas?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator